dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
2621
share rss forum feed


Zywall Noob

@cableone.net

USG 20W - Port Forwarding not Working Locally

I'm new to Zywall USG 20W but have never had this issue with other routers including Zywall 2 Plus.

I have ports forwarding to a DVR. I can view the DVR from anywhere in the world using »*ip-address-here*:*port-number-here*/

Anywhere other than on a computer on my own USG 20W LANs (LAN1, LAN2, WLAN1, etc.)

I'm created a service called DVR that specifies the desired port.

I have NAT type virtual server, interface WAN1, original IP any, mapped IP to my DVR, both ports set to my DVR service.

And I have a firewall rule to allow my NAT through form anywhere sending this port's traffic to my DVR.

it works form the outside world but not from within? What am I doing wrong?


Zywall Noob

@cableone.net
Oh and the reason for this is so that a smartphone app may view the cameras with the same settings from the outside world or at the location.

So I want to be able to use the IP address or a dynamic DNS address to forward the right ports to my DVR... whether I am on wifi or LAN right next to my DVR... or another LAN, 3G, etc... With most routers this seems to automatically work but I somehow hit a snag with the USG 20W...


Anav
Sarcastic Llama? Naw, Just Acerbic
Premium
join:2001-07-16
Dartmouth, NS
kudos:5
reply to Zywall Noob
Well If am on the outside, I probably try to access my DVR using a WANIP address (or an url associated with a dyn address aka dyndns.coms service.

If I want to access the DVR from within the LAN I would use its LANIP address.

There is also a loopback function which you can invoke for the virtual server rules which may allow you to do what your attempting (simulating outside looking in).
--
Ain't nuthin but the blues! "Albert Collins".
Leave your troubles at the door! "Pepe Peregil" De Sevilla. Just Don't Wifi without WPA, "Yul Brenner"

LlamaWorks Equipment


Brano
I hate Vogons
Premium,MVM
join:2002-06-25
Burlington, ON
kudos:11
reply to Zywall Noob
As mentioned, in NAT you have to enable "NAT Loopback" for every single virtual server you define.
On Z2+ NAT loopback is on by default, on USG is not.