dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
680
share rss forum feed

Gem
Premium
join:2005-09-10
kudos:4

Does .net 3.5 replace the need for .net 2.0 and 4.0?

Does Msft .net framework 3.5 replace the need for .net framework 2.0 and 4.0?

That would be great, if so.


dave
Premium,MVM
join:2000-05-04
not in ohio
kudos:8

1 recommendation

No.

Any given app is written to require a specific version of the .net framework.



QuaffAPint
A Big Thanks To The Troops

join:2001-01-10
Downingtown, PA
Reviews:
·Verizon FiOS
reply to Gem

The way it works is 1.x written apps need 1.x framework, similar with 4.x written apps needing 4.x framework.

However, 2.x and 3.5x written apps will work with the 3.5 framework. So if you have an app that calls for the .net 2.x framework, and only have the 3.5 framework installed, the app will still work.

Why they did that one 2/3.5 naming oddity, I don't know.



sekim
Premium,MVM
join:1999-08-17
Saint Petersburg, FL
kudos:1

1 recommendation

reply to Gem

Win8 shows this in the Programs & Features / windows features...

Gem
Premium
join:2005-09-10
kudos:4

Cool. So with net 3.5 we have 2.0 and 3.0 as well, but not 4.0 - correct?

That's good. Two less versions of .net to worry about if space is limited on the OS drive such as small SSDs.