dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
1050
share rss forum feed


horacebork
Premium
join:2011-03-17
09001
Reviews:
·voip.ms
·Time Warner Cable

panasonic tgp500 de-registering

i am having trouble with the panasonic tgp500 deregistering from all voip providers. i currently use 3 for different purposes: normal voice, fax and backup line.

the last 2 days the phones have been deregistered. sunday by 2pm and today by 10am. not sure of the exact times.
the de-registration was for all providers, all lines.

both times, the lines re-registered on a device reset.

i use an apple extreme base station, and that is probably the issue.
not sure if the 'sip alg' is configurable. 'spi firewall' shouldn't be an issue, should it?

do i need to use a different router?
--
".. the sofa has just vanished." ".. well, that's one mystery less."



Gershom 1624

@optonline.net

I have the similar Panasonic KX-TGP551 using CallCentric, CWU, and a free SIP provider.

Deregistration has never been an issue.

i use an apple extreme base station, and that is probably the issue.

The use of that device often seems to come up in posts dealing with VoIP problems.

not sure if the 'sip alg' is configurable.

Disable it. Period.

For example:
»www.phone.com/setup/panasonic-kx-tgp500/

'spi firewall' shouldn't be an issue, should it?

Probably not but some people believe otherwise. You can always disable it and see if things improve.

OR:

If it gives you choices such as:

1) Endpoint Independent
2) Address Restricted
3) Port And Address Restricted

If you have that sort, and it is currently set to the equivalent of (3) then try (2). If you currently have (2) then try (1). This is at least a little less radical than losing the protection altogether.

do i need to use a different router?

Possibly. Those Extreme Apples do have a PITA reputation for VoIP. But try the other steps first. Especially killing the [sip alg].


horacebork
Premium
join:2011-03-17
09001
Reviews:
·voip.ms
·Time Warner Cable

not sure if the 'sip alg' is configurable.

Disable it. Period.

i understand. i guess what i was really asking is how do i disable sip alg on the apple base station?
--
".. the sofa has just vanished." ".. well, that's one mystery less."


horacebork
Premium
join:2011-03-17
09001
Reviews:
·voip.ms
·Time Warner Cable

1 edit
reply to Gershom 1624

after some more research i am convinced i need a different router. =(
the apple extreme basestation is just not configurable enough.
if there were a 'sip alg' and/or 'spi firewall' config points, it might be ok.

is there a thread already discussing best routers for byod voip providers?
if not, perhaps one needs to be started?
--
".. the sofa has just vanished." ".. well, that's one mystery less."



Gershom 1624

@optonline.net

said by horacebork:

is there a thread already discussing best routers for byod voip providers?

if not, perhaps one needs to be started?

Topic often comes up, IIRC there is not a recent thread, so why not....

You may want to see the info that PhonePower posts on customer-provided routers, though at the moment their website is rather slow:

»www.phonepower.com/wiki/Customer···_Routers

grand total

join:2005-10-26
Mississauga
kudos:2
Reviews:
·Anveo
·VMedia
reply to horacebork

said by horacebork:

i am having trouble with the panasonic tgp500 deregistering from all voip providers. i currently use 3 for different purposes: normal voice, fax and backup line.

the last 2 days the phones have been deregistered. sunday by 2pm and today by 10am. not sure of the exact times.
the de-registration was for all providers, all lines.

both times, the lines re-registered on a device reset.

i use an apple extreme base station, and that is probably the issue.
not sure if the 'sip alg' is configurable. 'spi firewall' shouldn't be an issue, should it?

do i need to use a different router?

I have a suggestion, it may not be a good one, but I'm going to make it anyway. Go to the VOIP tab of your KX-TGP500 setup. Modify the SIP Source Port to be something outside the 5060 to 5080 range, for example 35060. That may help avoid whatever special SIP processing your router is trying to do.
--
DPC3825 (bridged mode) - WRT610N + Tomato - Panasonic KX-TGP500 - Asterisk 11.0.2 on Virtual Server
Anveo - FreePhoneLine - Voxbeam - Numbergroup - Callcentric - VoIP.MS - Localphone - UKDDI


horacebork
Premium
join:2011-03-17
09001
Reviews:
·voip.ms
·Time Warner Cable

I have a suggestion, it may not be a good one, but I'm going to make it anyway. Go to the VOIP tab of your KX-TGP500 setup. Modify the SIP Source Port to be something outside the 5060 to 5080 range, for example 35060. That may help avoid whatever special SIP processing your router is trying to do.

hah! great minds and all that. i did this earlier today for almost the same exact reasons.
i changed the sip source port for all my lines.
that and turned off nat on my aebs. prolly doesn't do anything.
but with any testing like this, needs a coupla days or more to test.
even then, even if things are working, it doesn't mean the problem has been solved. =/
--
".. the sofa has just vanished." ".. well, that's one mystery less."


horacebork
Premium
join:2011-03-17
09001
Reviews:
·voip.ms
·Time Warner Cable
reply to Gershom 1624

You may want to see the info that PhonePower posts on customer-provided routers

i just turned off nat (see above). is that a mistake?

questions about nat and assigning udp ports:
are these the sip source ports?
or is this the proxy/service/presence server ports?
or all of the above?

--
".. the sofa has just vanished." ".. well, that's one mystery less."


horacebork
Premium
join:2011-03-17
09001
reply to grand total

nope. it's still de-registering over night.
should i start a 'recommended router' thread?
--
".. the sofa has just vanished." ".. well, that's one mystery less."


conwaytwt
Premium
join:2004-04-09
Conway, AR
Reviews:
·Conway Corp.

1 edit

I don't know what else you have tried, but have you tried shortening your keep alive interval? If I recall the default is 300 seconds but you should try 120 or even 60.

[Actually I am assuming the TGP500 is similar to my TGP-550]

»Re: How to configure Panasonic KX-TGP550 with Vitelity

[edit: fixed broken link]



horacebork
Premium
join:2011-03-17
09001
Reviews:
·voip.ms
·Time Warner Cable

conwaytwt

my keep alive is 12 seconds on all my lines =/
is it too short? maybe they have 'pester' avoidance? the 550 and 500 are nearly the same as far as software goes.
grand total could tell you the specifics.

and is the link you provide supposed to go somewhere?
seems i cannot see that link (says it's for members).
i guess that excludes cogs like myself. =)
--
".. the sofa has just vanished." ".. well, that's one mystery less."


conwaytwt
Premium
join:2004-04-09
Conway, AR
Reviews:
·Conway Corp.

2 edits

Sorry about that... I fixed the link to the thread I was (trying to) point to. HOWEVER there's a lot more info in this longer thread:

»Panasonic KX-TGP551T04

[Edit: I just read through that whole thread and cannot see the config info... use the search field at the top of the screen and find more threads by searching for KX-TG and there will be more info.]

I just dug through my own notes and found that for mine to keep registration I had to set TWO items -- one visible on the config interface, one hidden. You have to use a config file to set one of the two, so I put both in the config file and copied the file to my public DropBox folder (URL obscured here) and pointed the phone to look at it on reset. Here's what's in it:

# PCC Standard Format File # DO NOT CHANGE THIS LINE!
 
# Conwaytwt custom configuration file.
 
# URL of this configuration file
CFG_STANDARD_FILE_PATH="http://dl.dropbox.com/xxxxxx"
 
############################################################
# SIP Settings #
# Suffix "_1" indicates this parameter is for "line 1". #
############################################################
 
# Expiration time of SIP registration; 1 hour=3600, 5 min = 300
REG_EXPIRE_TIME_1="300"
REG_EXPIRE_TIME_2="300"
 
# Keep Alive for NAT traversal, in seconds
PORT_PUNCH_INTVL_1="120"
PORT_PUNCH_INTVL_2="120"
 
EMERGENCY_CALL1="911"
 
 


horacebork
Premium
join:2011-03-17
09001
Reviews:
·voip.ms
·Time Warner Cable

2 edits

Sorry about that... I fixed the link to the thread I was (trying to) point to. HOWEVER there's a lot more info in this longer thread:

»Panasonic KX-TGP551T04

nice thread. great info. firmware is up to 12.58 as of this posting.

# Keep Alive for NAT traversal, in seconds
PORT_PUNCH_INTVL_1="120"
PORT_PUNCH_INTVL_2="120"
 
EMERGENCY_CALL1="911" 
 

i currently have nat turned off on my apple base station router.
do i need the port_punch_intvl_* variables? might not hurt.

there is a note in my 12.58 admin guide for this variable:

This setting is available only when "SIP_TRANSPORT_[1-8]" is set to "0" for UDP.

Also, I set the emergency call number from the web config pages.

question: is the config file re-loaded every time the unit is restarted? [edit: yes it is]

--
".. the sofa has just vanished." ".. well, that's one mystery less."

conwaytwt
Premium
join:2004-04-09
Conway, AR
Reviews:
·Conway Corp.

said by horacebork:

i currently have nat turned off on my apple base station router.
do i need the port_punch_intvl_* variables? might not hurt.

I apologize I really don't know the effect of having NAT turned off... does that mean the router is working in bridge mode? Does that mean you don't really have any firewall between you and your ISP? I wouldn't think that would be a good idea but I would defer to others.

there is a note in my 12.58 admin guide for this variable:

This setting is available only when "SIP_TRANSPORT_[1-8]" is set to "0" for UDP.

Also, I set the emergency call number from the web config pages.

Yes I use UDP. Do you have a reason for not using it? My phones are connected to Voip.ms and Anveo. I don't think voip.ms supports TCP directly ... it might work with Anveo but I haven't tried.

The reason I put the emergency call number in the config file was so I would know the phone had loaded the config -- if I delete it in the web config and it shows up then I know the phone has loaded the config file

question: is the config file re-loaded every time the unit is restarted?

It's supposed to -- but of course the file has to be "visible" to the phone for it to work, so you would need it on a server on your LAN or on a public server the phone can "see" when it boots.


horacebork
Premium
join:2011-03-17
09001
Reviews:
·voip.ms
·Time Warner Cable

1 edit


nat config screen on airport utility

I apologize I really don't know the effect of having NAT turned off... does that mean the router is working in bridge mode? Does that mean you don't really have any firewall between you and your ISP? I wouldn't think that would be a good idea but I would defer to others.

looks like my machine has a 192.168.*.* address as well as all the other devices on my network.
looks like they are all local net. all internet connections work just fine.
doesn't seem like anything is exposed at all. (?)

[edit] occurs to me that maybe the cable modem is providing the nat?
or maybe even though it's turned off on the airport, it's still really on?
see screen snap of the nat config screen on the airport utility.

Yes I use UDP. Do you have a reason for not using it? My phones are connected to Voip.ms and Anveo. I don't think voip.ms supports TCP directly ... it might work with Anveo but I haven't tried.

no - just clarifying that the config was not being set for the sip_transport variable. seems set from the web interface to udp.

The reason I put the emergency call number in the config file was so I would know the phone had loaded the config -- if I delete it in the web config and it shows up then I know the phone has loaded the config file

hah. i had just pm'd you about doing *exactly* this same thing.
we'll see if anything changes over the next couple of days.
--
".. the sofa has just vanished." ".. well, that's one mystery less."

conwaytwt
Premium
join:2004-04-09
Conway, AR
Reviews:
·Conway Corp.

1 edit

thanks for the screenshot of your airport config --

I think your router IS doing NAT. That screen just lets you add on additional NAT options, including a protocol other than uPnP or a host to send all the traffic to (without filtering).

»support.apple.com/kb/PH5103

I think you can safely ignore what's on the NAT screen. HOWEVER as I said in the PM, I only have just enough networking knowledge to be dangerous...



horacebork
Premium
join:2011-03-17
09001
Reviews:
·voip.ms
·Time Warner Cable

2 edits

understood re: nat vs nat port mapping. i think you're right.

in other news:

i have been doing some more testing and the registration might not actually be the issue.
it seems that when calling certain numbers, there is a time lag between when i place the call (press 'talk') and when the other end responds (rings or other action).

this morning, i tried calling my cell and it took about 20 seconds for it to start ringing.
tried several times and the time got shorter, but not less than 10 seconds.
other calls connected within about 3 or 4 seconds and a local call connected in 10 seconds.
seems sporadic.

so i had an idea about the registration and was wondering if the connection goes 'stale'.
not sure where any alleged 'staleness' might originate: between my sip device and voip provider? router?
i just restarted my tgp500 and when i call my cell, the phone starts ringing in about 5 seconds.
this is much shorter than the 10-20 seconds before the device was restarted.

this is all very circumstantial, but might help indicate what might be happening.

tomorrow i'll test by dialing *in* as the first test to see what happens.

--
".. the sofa has just vanished." ".. well, that's one mystery less."



horacebork
Premium
join:2011-03-17
09001
Reviews:
·voip.ms
·Time Warner Cable

4 full days of registration - a record since my lnp home number port to my voip provider.
also, the time lag between placing a call and ringing on the other end is normal now: just a couple seconds.

on the tgp500, the config file is the only place where you can set the REG_EXPIRE_TIME_(1-6)
i had the web config pointing to a cfg file on my local machine ftp and the problem was probably that this file is not always available.
my machine is not 'up' 24/7 - i put it to sleep evenings and down hours.
so i moved my cfg file to the web. that and i changed the time from 180 to 300.

the time difference is what my voip provider recommends, but i suspect the file availability itself was a bigger issue.

as of now: i have no nat port mapping and there does not seem to be any sip alg or spi firewall settings on the airport extreme base station.
these settings remain 'at large' and are on the back-burner for the moment.
--
".. the sofa has just vanished." ".. well, that's one mystery less."