dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
1660
share rss forum feed


disconnected

@snet.net

[WIN7] W7 64 XP Virtual Machine CMD prompt can't see USB Drive

Click for full size
I have a USB drive set up in Integration Options to be available to Windows XP virtual machine under Windows 7 Pro 64-bit.

Windows XP explorer can see the USB drive. However, my batch files, which back up certain Win16 apps data to the USB drive cannot function due to an "invalid drive" error. Sure enough, the CMD window cannot see any drives other than A: C: and D: (the latter being the CD drive).

I need to find a way to automate backup of certain data that gets updated several times daily.

Prior to upgrading from Win XP to Win 7 64, this batch file would copy some database directories to a USB drive letter Z:. The drive is still assigned Z:, shows up as "Z on QUADCORE2" in Windows virtual XP explorer, but in an invalid drive if I try to access it from virtual XP's command prompt, which is why my backup.bat file fails.

I Googled the problem extensively, but was unable to find any discussion about this particular problem of how to access a drive in CMD that is accessible only in Explorer.

Any ideas?

rfnut
Premium
join:2002-04-27
Fisher, IL
kudos:2

Re: [WIN7] W7 64 XP Virtual Machine CMD prompt can't see USB Dri

while picture indicates Z onQUADCORE2, I do not see any ":" in there. Is it mounted without a drive letter as a network share named "Z onQUADCORE"


disconnected

@spcsdns.net
I noticed that pipe symbol too. My next approach was to treat it as a network drive, then:
\\TSCLIENT\Z: however, that also resulted in an invalid drive specification. This is a head scratcher.


quaker
Premium
join:2001-12-27
Rocky River, OH
Reviews:
·Cox HSI

2 edits
reply to disconnected
as someone else said it doesn't appear that your "Z on QUADCORE2" is mapped to a drive letter. go to your disk management to see if windows has your usb mounted and from there you can change the drive letter to something else. otherwise i would just share the usb drive from the host pc and just mount the remote share in the virtual XP.

rfnut
Premium
join:2002-04-27
Fisher, IL
kudos:2
reply to disconnected
Since it looks like a share, not a drive, map by name, but since there is a space, use \\tsclient\"Z onQUADCORE2". or remove the space in the name of the drive.


disconnected

@snet.net
When I try to map the network drive, the system says the network path could not be found. Yet, when I double-click on that network drive icon, it opens and I can access the data within. XP virtual behaves very differently than a real PC with regard to attached drives and networks.

Tried modifying this command as follows:

XCOPY c:\Mymwin2\mymdata\*.* \\tsclient\"Z onQUADCORE2\Mymwin2\mymdata" /D/Y

and got an invalid drive spec error again.

This whole mess is making me really wish there were some replacement for Managing Your Money that could import MYMDATA files and is compatible with modern Windows systems.

I like to automate my backups, but if I cannot access connected drives, it makes the process become a manual one, which is not likely to get done regularly.


cmcasey79

join:2000-12-10
Allen Park, MI
kudos:1
to map the drive, from the command prompt on the virtual machine, try:

net use z: \\quadcore2\z /persistent:yes

If that works, your original script would run. The command prompt really doesn't handle network paths and stuff, so this should get around it.
--
- cmcasey79, BrightHouse RoadRunner Turbo, Farmington Hills, MI

rfnut
Premium
join:2002-04-27
Fisher, IL
kudos:2
reply to disconnected
I assume you also tried without the \\tsclient suach as \\"z on..."

Aranarth

join:2011-11-04
Stanwood, MI
Reviews:
·Frontier Communi..
reply to disconnected
are you using xp mode?

if you are go to the USB pull down at the top of your screen and turn on USB FD 2.0.

You get a weird pop-up but choose yes, the drive will disappear from win7 and show up in xp mode, to give it back go back to usb and choose release.

Note I do not know if you can force the drive letter to change to x: or not. If not edit your script.


disconnected

@snet.net
reply to cmcasey79
Click for full size
Okay here's my results with that command:

I'm trying to avoid adding complexity to this process, such as remembering to go to the USB menu and select from the half dozen or so thumb and hard drives attached to this PC (they don't show up with volume label--just a bunch of "U3 Cruzer Micro" entries and I must guess which one is my Z drive).

It seems that accessing a drive that has been made accessible by the integration features settings should not be so difficult in a command shell.

rfnut
Premium
join:2002-04-27
Fisher, IL
kudos:2
Reviews:
·Mediacom
reply to disconnected
Click for full size
For the fun of it I just installed the xpmode to see what is up. I see usb drives are mounted as names like yours. My assumption of the named drive is wrong, sorta. You do not need to mount as Z:. It is already Z. Just Z. No ":" no name. \\tsclient\Z\... Included is a screenshot showing how it looks and a proper copy which did copy to the usb drive as shown in explorer "\\tsclient\F\temp.


disconnected

@snet.net
BINGO! You got it! Thank you so much. I never imagined that dropping the ":" from the drive letter was valid under this condition, but it works.

rfnut
Premium
join:2002-04-27
Fisher, IL
kudos:2
Glad to see it is working now