dslreports logo
site
    All Forums Hot Topics Gallery
spc
Search Topic:
uniqs
4721
share rss forum feed


TSI Gabe
Premium,VIP
join:2007-01-03
Chatham, ON
kudos:7

Youtube

We are well aware that many customers have been experiencing less than stellar Youtube streaming and want to let you know that we've been actively looking into it.

We are still talking to Google about this and at this point need your help to figure this out.

I don't want to point any fingers but we've noted that we aren't the only ISP affected by this, DSLR themselves posted about it here »Why Is Everyone Having YouTube Streaming Issues? and really need to get to the bottom of this...

We've started running "pytomo", a python tool that basically benchmarks Youtube's Quality of Service and I thought that it would be great if the TekSavvy techies out there could also run it and feed us back with the data it outputs

»code.google.com/p/pytomo

The tool runs on pretty much anything, from Windows to Linux and logs all that data in a single db file that we can then use to send valuable data back to Google.

If a few inclined techies could run this script from their home connection, preferably at peak time for a few hours and then send us back the db file it generates it would greatly help us find where the problem is. In fact I'd like to see data whether or not you happen to be on our network which would give us a great baseline to see where the problem is.
--
TSI Gabe - TekSavvy Solutions Inc.
Authorized TSI employee ( »TekSavvy FAQ »Official support in the forum )


Scycotic

join:2012-12-10

I'm currently with TSI but haven't experienced problems with Youtube. Would you still benefit from the data if I ran pytomo?



TypeS

join:2012-12-17
London, ON
kudos:1
reply to TSI Gabe

I don't experience at the streaming issue really, it was bad for a few days two or three weeks ago then went away. I can still run the tool at peak hours for the next week if it will help.


mactalla

join:2008-02-19
kudos:1
reply to TSI Gabe

Running it for DSL/West. Can't say whether it's still an issue here as I rarely watch YouTube, but I know it had a problem quite a long time ago. At that very least it will give you an extra data point for either the good or bad column.



jmcneill

join:2010-04-06
Canada
reply to TSI Gabe

How many URLs are you looking for? The default 10k?


dlinker

join:2012-03-02
Mississauga, ON
reply to TSI Gabe

Glad you are looking into this Gabe!



evil_gusgus

join:2008-04-14
London, ON
reply to TSI Gabe

Currently I'm in Boulder, CO so I can't test from home



silvercat

join:2007-11-07
reply to TSI Gabe

To whom and to what e-mail address do we send the db file to ?


lostgoat

join:2010-06-16

said by silvercat:

To whom and to what e-mail address do we send the db file to ?

I would also like to know where we should send the information we collect.

Also, any preferred times or lengths that you would like us to run this? I'm thinking of setting up a cron job for this.

mactalla

join:2008-02-19
kudos:1

The link indicates that running it for ~12h is suggested. It looks like the .db is quite small so there shouldn't be any concern about running it too long. I think just letting it run for a day should cover any peak time and give them a visual of how it changes over time.



andyb
Premium
join:2003-05-29
SW Ontario
kudos:1
reply to TSI Gabe

I'll give it a shot.



creed3020
Premium
join:2006-04-26
Kitchener, ON
kudos:2
reply to TSI Gabe

I haven't noticed any issues when I do use Youtube but then again I don't use it as frequently as others. I'll run this script.

I'm glad to see though that the DSLR news article went up and that TSI is taking this seriously.



fourboxers
Co-Lead Mod
join:2003-05-04
Toronto, ON
reply to mactalla

(topic move) Youtube

Moderator Action
The post that was here (and all 9 followups to it), has been moved to a new topic .. »off topic



sssstf

@teksavvy.com
reply to TSI Gabe

Re: Youtube

hum, I have capchas now on youtube (translated from French) : We are recieving a lot of request from you network..... so fill out this capcha.

maybe you found to many testers


graniterock

join:2003-03-14
London, ON

I'm running it but it said "public IP not found" I think it is running but it doesn't seem to go crazy with the bandwidth or anything like that. Hopefully it is working and hasn't been blocked by youtube or something silly.


Scycotic

join:2012-12-10

Doesn't seem to use much bandwidth, I ran it for five or so hours.



squircle

join:2009-06-23
Oakville, ON
reply to graniterock

said by graniterock:

I'm running it but it said "public IP not found" I think it is running but it doesn't seem to go crazy with the bandwidth or anything like that. Hopefully it is working and hasn't been blocked by youtube or something silly.

That's because the service they're using to determine your public IP isn't working right now (or may not exist anymore, I'm not sure).

twizzler66

join:2011-06-25
Guelph, ON
reply to TSI Gabe

Just an FYI (and if this is truly a case of blocking primary servers and accessing backup servers it doesn't really resolve the issue), but blocking the IP ranges talked about in this thread - »Youtube is slow - have resulted in a 100% improvement on streaming youtube for me - unfortunately it does jack squat to fix issues with twitch.tv....

...now if only someone could provide a similar (if temporary) fix for twitch tv...



Teddy Boom
k kudos Received
Premium
join:2007-01-29
Toronto, ON
kudos:20
reply to TSI Gabe

I'll try to run it.

I'm really replying to say how happy I am to see this approach being used. I hope it yields some very useful data, and I hope to see the approach applied to other issues.
--
electronicsguru.ca



King Sull
Premium
join:2012-03-26
Etobicoke, ON
reply to TSI Gabe

IP range blocking worked for me.



Mimiga King

join:2008-09-15
Quebec, QC
reply to TSI Gabe

When I run pytomo_windows_x86.exe and enter the data as..

y :enter
Teksavvy Solutions :enter
:enter (no proxy)

it then fails to fetch my public IP address, where can I enter it manually?


stevey_frac

join:2009-12-09
Cambridge, ON
Reviews:
·TekSavvy Cable

Don't worry about that. You're running on a router, so it can't verify a public IP. They can still log all the relevant information.

I've got this setup and running. I'll do a run now, and again around 9:00 p.m. tomorrow for a 'good case' / 'bad case' comparison.

Hope this helps!



Mimiga King

join:2008-09-15
Quebec, QC
reply to Mimiga King

said by Mimiga King:

When I run pytomo_windows_x86.exe and enter the data as..

y :enter
Teksavvy Solutions :enter
:enter (no proxy)

it then fails to fetch my public IP address, where can I enter it manually?

Forgot to say that it asks me to stop the crawl just after saying that it can't fetch the public IP.

right now I'm running "pytomo_web_interface_windows_x86.exe" and it says it runs on sevver 0.0.0.0:5555

stevey_frac

join:2009-12-09
Cambridge, ON
Reviews:
·TekSavvy Cable

Ya, it's just telling you that if you need to stop the crawl, you can do so with Ctr-C.

If you look at it, you can see that it spawned a process that's out there crawling away like a madman.



Mimiga King

join:2008-09-15
Quebec, QC

said by stevey_frac:

Ya, it's just telling you that if you need to stop the crawl, you can do so with Ctr-C.

If you look at it, you can see that it spawned a process that's out there crawling away like a madman.

Ok, thanks. well, here goes a 24/7 1969 video playlist running on my server. results should be interesting ^^

stevey_frac

join:2009-12-09
Cambridge, ON

I don't follow... If you didn't enter any info, it should be doing a 10k video list...

You don't have to watch youtube to have it work. You just launch the executable, and it goes out to youtube and grabs streams and benchmarks them.


pldube

join:2011-06-11
canada
reply to TSI Gabe

I got:

Public IP address not found: , retrying in 1 seconds

Public IP address not found: , retrying in 2 seconds

Public IP address not found: , retrying in 3seconds

Public IP address could not be logged



TSI Gabe
Premium,VIP
join:2007-01-03
Chatham, ON
kudos:7

That's fine, it's just a warning but the program still runs.

To clarify things, yes it does gran "up to" 10,000 videos by default which is obviously a lot. You don't need to run it for that long, that could quite obviously take a very long time. Only run it for a few hours preferably at peak. Better would be about 24h

You can then send us the logs at support@teksavvy.com
--
TSI Gabe - TekSavvy Solutions Inc.
Authorized TSI employee ( »TekSavvy FAQ »Official support in the forum )



jmcneill

join:2010-04-06
Canada

I uploaded a ~12hr run to the direct forum earlier this morning.


JMJimmy

join:2008-07-23
reply to TSI Gabe

Here's a bit of cosmic irony: while the program is running, streaming is better than it's been in ages.