dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
792
share rss forum feed


red2

@fastwebnet.it

pdfs open in Firefox 19.0 even when Adobe is DISABLED !!

I recently updated to Firefox 19.0.

In Firefox, under "options" all the Adobe types have always been marked as "SAVE FILE" as you see in the attached image.

In the FF Add-Ons manager, Adobe Acrobat is listed as currrent (version 10.1.6.1) and I've ensured that it is marked 'DISABLED".

However, now every time I click on a pdf file it opens in the browser. That NEVER happened before. What gives?


trparky
Apple... YUM
Premium,MVM
join:2000-05-24
Cleveland, OH
kudos:2

1 recommendation

That's because Firefox changed it so that PDFs are opened inside the browser using their new jsPDF engine. It doesn't require any outside plugin, only the browser's Javascript engine is needed to render and display PDF files.

If you want to disable it, go to about:config and search for "pdf" and find an entry called "pdfjs.disabled" and set it to "true".
--
Tom
Boycott AT&T uVerse! | Tom's Android Blog | AOKP (The Android Open Kang Project)

Velnias

join:2004-07-06

1 recommendation

reply to red2
It's Mozilla's built-in PDF reader. Search for "pdf" type.


red2

@fastwebnet.it
Thank you ! I guess I didn't get the memo.

I imagine that it is still safer to open pdfs externally after scanning them first, no?


Bill_MI
Bill In Michigan
Premium,MVM
join:2001-01-03
Royal Oak, MI
kudos:2
Reviews:
·WOW Internet and..
I just checked if Windows XP has the same as Linux in the 18.0.2 to 19.0 update. It does. This generic PDF addition was added (see picture) on this XP machine that has NEVER seen Adobe anything.

Notice I typed pdf in the search area.

My point is, you might want to check for this to control PDFs and not look only at Adobe entries.

I'm curious if you also have this entry?


HA Nut
Premium
join:2004-05-13
USA
reply to red2
"I imagine that it is still safer to open pdfs externally after scanning them first, no?"

It is in my opinion.


red2

@fastwebnet.it
reply to Bill_MI
It was not there, but then I realized that I had used the about:config fix that trparky suggested. As soon as I changed it back to its original setting, I had the same "Portable Document Format" in Options as you.

However, I could change the action to "Save File". When I did that and looked at the pdfjs.disabled setting in about:config again, it changed it back to "true". So it is apparently the same thing as the about:config setting.


Bill_MI
Bill In Michigan
Premium,MVM
join:2001-01-03
Royal Oak, MI
kudos:2
Reviews:
·WOW Internet and..

2 edits
Thanks for reporting back as that's good to know.

EDIT: I'm not seeing the same. If I set pdfjs.disabled=TRUE then I loose the "Preview In Firefox" option for PDFs. Which makes sense.

Yep, trparky See Profile is right on. pdfjs.disabled=TRUE is the global disable for the Firefox PDF viewer.


NotTheMama
What Would Earl Do?

join:2012-12-06
reply to HA Nut
As long as you aren't using an Adobe product. (/only slightly facetious )