dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
449
share rss forum feed


sisili

@davita.com

[FireFox] Problem with 'modutil' tool when installing a PKCS#11

Hi,
I am trying to install a PKCS#11 module into Firefox browser via an MSI setup application.
After doing some search through the internet, I bumped into the 'modutil' tool which has a wide variety of

responsibilities especially in my case for installing/uninstalling the PKCs#11 module to NSS security databases.
I downloaded the latest source code and built it using MozillaBuild. Unfortunately, it shows me an error even when I try

to create security databases (3 with .db extension). The error says "Function failed: The certificate/key database is in

an old, unsupported format"!.
Does anybody know how I can overcome this issue, and is there any unseen aspect to work with this utility. Also, is there

a solution to install/uninstall pkcs#11 module for all user profiles with one common process.
Finally, is there a better solution to do the task of installation using my setup. I use WiX Toolset to create MSI setup.

Thank you