dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
1091
share rss forum feed

jl747

join:2005-03-24
Mount Prospect, IL

1 edit

[WIN7] W7 No internet connection

At night I like to block all internet access via my firewall so that I do not have to shut down the computer.
When I am ready to access the internet and email in the AM I get a No Internet connection message on the Network center and the icon on the Desktop taskbar.

I would do the repair and I still get no connection.
I have removed the check mark from the box next to IPV6 in the Properties.
Changed the WLAN settings to Automatic.
Still nothing.

The only way to get connected is by rebooting.

Does anyone have any suggestions?
Thanks in advance for your help.

Windows 7 Pro – Firefox 19-
Linksys Router WRT54G v5



dib22

join:2002-01-27
Kansas City, MO

File and sharing center, change adapter settings, right click ... disable, then right click ... enable.


jl747

join:2005-03-24
Mount Prospect, IL

I did what you suggested and now lets see what happens.



dib22

join:2002-01-27
Kansas City, MO

said by jl747:

I did what you suggested and now lets see what happens.

Basically I was offering it as an alternative to rebooting... so next time it wont let you have internet access, disable and re-enable the adapter and it should restore it.

You can also "repair" it.. but I find disable/reenable to be faster.

jl747

join:2005-03-24
Mount Prospect, IL

I did the repair and it did not find a fix.

Rebooting always solves it.


dave
Premium,MVM
join:2000-05-04
not in ohio
kudos:8
Reviews:
·Verizon FiOS
reply to dib22

It seems to me that if the intent is to have no internet connection at certain times, then the most straightforward thing to do is to disable the internet connection at those times.

That is, instead of using the firewall to block internet access, and then when you want internet access,disabling the interface and then enabling it again, one could (1) disable the interface when one doesn't want access, and (2) enable the interface when one does want access.

Mind you, I don't see the point of all this. If your computer is secure enough to be connected when you're using it, it's certainly secure enough to be connected when you're not using it. (Given the user is the usual weak point in the defence, the net probably ought to be connected at night and disconnected when in use )

My solution is to just let the computer sleep at night.



Micha3615

join:2004-08-21
Mississauga, ON
reply to jl747

When you say, block internet via my firewall.

Is this via software or hardware firewall?

If you have flashed your router with dd-wrt you can use this: »www.dd-wrt.ca/wiki/index.php/Acc···rictions



La Luna
RIP Lisa
Premium
join:2001-07-12
Warwick, NY
kudos:3
reply to dave

said by dave:

.....Mind you, I don't see the point of all this. If your computer is secure enough to be connected when you're using it, it's certainly secure enough to be connected when you're not using it.....

My solution is to just let the computer sleep at night.

^^^This (bolded mine).

I also don't see any point of disabling internet when the computer is not in use (and I certainly wouldn't do it via firewall). I would be interested in hearing the purpose of this.
--
The Alien in the White House

20,196 DEADLY TERROR ATTACKS SINCE 9/11

jl747

join:2005-03-24
Mount Prospect, IL

1 recommendation

reply to jl747

It is just an option and something I got used to doing at night when I am not using the computer.

I block the access via the firewall software.

I'll probably use the sleep mode in the future.
That way I'll save on what little power (electricity) it uses and wear and tear on the hard drive.



CCat
We're all quite mad here
Premium,MVM
join:2005-12-06
Wonderland
kudos:18
Reviews:
·Time Warner Cable

1 edit

I have this shortcut on my Win 7 Pro for my Internet connection.

downloadDesktop Shor···tion.pdf 143024 bytes


La Luna
RIP Lisa
Premium
join:2001-07-12
Warwick, NY
kudos:3
reply to jl747

said by jl747:

It is just an option and something I got used to doing.....

Well, STOP IT!!!

J/K, was just curious.
--
The Alien in the White House

20,196 DEADLY TERROR ATTACKS SINCE 9/11

jl747

join:2005-03-24
Mount Prospect, IL
reply to jl747

Thanks.

I think I'll use the sleep mode.

At least one of us will get some rest.



Pentangle
With our thoughts we make the world.
Premium
join:2006-06-01
Vancouver BC
kudos:2
reply to jl747

said by jl747:

It is just an option and something I got used to doing at night when I am not using the computer.

I block the access via the firewall software.

I'll probably use the sleep mode in the future.
That way I'll save on what little power (electricity) it uses and wear and tear on the hard drive.

If it's electricity you'd like to save, why not turn the thing off?


norwegian
Premium
join:2005-02-15
Outback
reply to jl747

You could always disable the Local Area Connection, be it wireless or hardwired. If the connection is disabled you have no connection.

In Control Panel either via the:
Network and Sharing Center | Local Area Connection
Or
Device Manager | Network Adapters

Disabling either of these 2 will shut the Internet down, including the connection to your router, isolating your computer, just reverse the setting when you need it.
--
The only thing necessary for the triumph of evil is for good men to do nothing - Edmund Burke



NotTheMama
What Would Earl Do?

join:2012-12-06
reply to jl747

Interestingly, I often find that simply starting Internet Explorer resolves such/similar problems, at least more often than not.
--
"Face piles of trials with smiles; it riles them to believe that you perceive the web they weave."



norwegian
Premium
join:2005-02-15
Outback

I've always wondered why opening a browser would fix that.
Do you know why a browser would effectively fix an (I assume) winsock issue?



NotTheMama
What Would Earl Do?

join:2012-12-06

Not really. I just assumed it was due to Internet Explorer's "special relationship" with the OS. I don't remember it working as well--or at all--with any other browser.
--
"Face piles of trials with smiles; it riles them to believe that you perceive the web they weave."


dave
Premium,MVM
join:2000-05-04
not in ohio
kudos:8
Reviews:
·Verizon FiOS
reply to norwegian

Depends what the indication of "connected to the internet" really means. At least with wired Ethernet, it seems quite subjective. Neither Ethernet nor IP have the concept of "connection", and the thing at the other end of the wire is not something I'd call "the internet".

So, maybe it just means that traffic is being sent and received. In which case, making some traffic be sent or received would change the state.


jl747

join:2005-03-24
Mount Prospect, IL
reply to NotTheMama

I tested this by opening IE and it reestablished the connection.
As did Firefox.

Never knew this.

Thanks.


dave
Premium,MVM
join:2000-05-04
not in ohio
kudos:8
Reviews:
·Verizon FiOS
reply to dave

This seems to be "how it works".

»technet.microsoft.com/en-us/libr···10).aspx

I'd further suppose that, absent any new reason like a link-up indication, it's going to probe periodically. But when you try and make a TCP connection, that causes another trigger.

I doubt it has much to do with Internet Explorer in particular.



NotTheMama
What Would Earl Do?

join:2012-12-06

said by dave:

I doubt it has much to do with Internet Explorer in particular.

So I would have thought, which is why I tried with Firefox--and Opera, too, as I recall--first a few times, with considerably less success--so I stopped trying them. IE might as well be good for something, and this is as good as anything. It's been awhile since I last had to do this though--maybe now any browser is as good as any other.
--
"Face piles of trials with smiles; it riles them to believe that you perceive the web they weave."

dave
Premium,MVM
join:2000-05-04
not in ohio
kudos:8

Interesting!


jl747

join:2005-03-24
Mount Prospect, IL
reply to jl747

Well after testing this possible solution further with the firewall blocking the internet and then turning it on (No Connection showing) I opened IE and it would not connect.

Time it was blocked was approx 6 hours.

Oh well.

Again thanks for your suggestions.



norwegian
Premium
join:2005-02-15
Outback


Have you tried disabling the connection as suggested at the hardware level rather than the winsock/firewall level?


jl747

join:2005-03-24
Mount Prospect, IL

Yes I have.

I'll will just put the system to sleep.

It's easy and painless.



norwegian
Premium
join:2005-02-15
Outback


That still gives the no connection error. Wow.
You can always look at cleaning or resetting the connection/dns cache etc to see if it helps, but if you are happy as you are I'll move on.


jl747

join:2005-03-24
Mount Prospect, IL

I did do a flush and it was still a no go.

I am moving from here.

Thanks