dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
9312
share rss forum feed

TheBoyBlunde

join:2013-03-08
Broomfield, CO

3 edits

[Modem] Can Not Get IP Address from PPPoE

I have Earthlink DSL powered by a zyxel p-660r elnk modem, connected via Ethernet to a Cisco M20 router. Last Saturday, following some poor advice from technical support while working on an account issue I reset my modem and router and have been unable to get a proper connection since. Ideally, I want the modem in bridge mode and the router handling all connection duties. However, since that reset I have been unable to make it work.

Problem Description
Each time I try to establish a pppoe connection from the router to the modem so I can get online, I get a “Can Not Get IP Address From PPPoE” error.
To set the modem in bridge mode, I do the following. Reset it with a paperclip on the “reset” button, then enter my default connection information and log in to my connection. this link should show you the steps I took to establish the connection. I verify the connection works by first pinging www.google.com and checking my email. I then set the modem in bridge mode by doing this. However in each instance I have more settings than are shown in those articles. I assume they are irrelevant but I'll post them if it will help.

I connect to the M20 router, then set up the connection settings (except for the DNS servers) as found in this thread - »DSL Speedstream 5360 not connecting to Linksys E1200 Router.
I then do the following: turn the modem off and unplug the router. Wait 3 minutes, then turn the modem on. Then plug in the router and wait five minutes to see if a connection is established by waiting to see if the internet light turns on on the router. When it doesn’t, I log into the router, click on the “Status” option, and click on “Connect.” Usually it tries to connect five or six times, then fails to connect. It gives me a “Can Not Get IP Address From PPPoE” error.

Attempted Fixes
I’ve tried to set up a WRT54GL and a WRT54GS with the default connection settings as found in the above thread, each with an IP address of 192.168.1.1. I’ve tried the power cycle thing each time and I have been unable to connect each time.
I have also tried a flurry of connection settings and IP address combinations. I have found posts suggesting I need to clone the MAC address from…something, and I have found posts suggesting I need to enter the username as ELN/username@earthlink.net. I can enter an alternate MAC address by going to the main setup screen, clicking on “MAC Address Clone”, and typing in an alternate MAC address.
Here’s what I’ve tried so far strictly through the M20 router:
IP Address 192.168.1.1, mac address cloned from modem, username normal. No connection.
IP Address 192.168.1.1, mac address normal, username entered with ELN prefix. No connection.
IP address 192.168.1.2, mac address normal, normal login details. No connection
IP address 192.168.1.2, mac address cloned from modem, username normal. No connection.
IP address 192.168.1.2, mac address cloned from modem, username with ELN prefix. No connection.
IP address 192.168.1.2, mac address normal, username with ELN prefix. No connection.
I’m going to try the above settings with the IP address as 192.168.2.1 but I doubt it’ll make any difference.

Recent Changes
Well, last Saturday I was unable to connect. I called tech support because I got a “Password Bad” error when I tried to connect through my router, and they insisted there was some sort of unnamed fraudulent activity so they reset my password. The tech insisted I reset my modem to get the correct password, and I was unable to connect. When I called a few hours later, they said “oh no it’s the old password.” I still was unable to connect and have been unable to connect since. I still don’t know what happened with that password business. I’m especially not happy I can’t connect properly.

Operating System
Each router is running the newest stock firmware I could find. The modem is untouched.

Location
I’m in the US.

Googled
I have googled repeatedly and never found a concrete answer.

So, does anyone have any ideas on what I should try to get my stupid router connected to my stupid modem again?

Edited heavily to sound less complain-y and make more sense. Also, I can connect with the router in DHCP mode and the modem acting as a router, but that is unacceptable. I want to control which ports go to which devices on my LAN.

I can also connect with a computer directly cabled to the modem, but while nice that I can get online, it doesn't mean much.



Doctor Olds
I Need A Remedy For What's Ailing Me.
Premium,VIP
join:2001-04-19
1970 442 W30
kudos:18

1 edit

When you reset the ZyXEL Modem did you remember to put it back in the mode it was before the reset? Was it in Bridge Mode or was it in Routing Mode handling the PPPoE login?

It sure sounds like after rereading your post that you need to set the ZyXEL Modem to Bridge Mode.

Also any Router you use behind the ZyXEL must not use the same IP as the ZyXEL which the default IP is 192.168.1.1. Use 192.168.2.1 or whatever you prefer, just not 192.168.1.1
--
What’s the point of owning a supercar if you can’t scare yourself stupid from time to time?


TheBoyBlunde

join:2013-03-08
Broomfield, CO

Just to make sure, all I have to do is go to the WAN setup and change the mode from "routing" to "bridge", correct?


TheBoyBlunde

join:2013-03-08
Broomfield, CO

Well, here's what I tried.

Modem Side:
1) Reset the modem through the reset button. I held it down for 20 seconds just in case.
2) Sign into the modem via the configuration page, 192.168.1.1/zCfgPPPOE.html
3) Enter my username and password, click apply.
4) Verify the connection works by checking Facebook, my email and pinging www.earthlink.net.
5) Go to the LAN configuration page and turn off DHCP. Click apply. (Change DHCP from "Server" to "None")
6) Go to the security page and turn off all the security options. They were all "such and such traffic is filtered from the WAN to the LAN" options. Click apply.
7) Go to the WAN Setup, and change "Mode" from "Routing" to "Bridge". Click apply.
Once everything was set, hit the power off button on the modem and start a timer to make sure I wait at least 5 minutes before I turn anything on.

Router Side:
1) Reset the router through the reset button. I held it down for 20 seconds just in case.
2) Connect my laptop via ethernet cable to a LAN port on the router. Sign into the router at 192.168.1.1 once it picks up a new DHCP assigned IP.
3) On the "Setup" screen on the router, change the router's IP address to 192.168.1.2. Click "Save Settings".
4) Once my laptop picks up a new DHCP address for the new gateway, log back into the router, and set up the PPPoE connection with the connection settings as indicated in the above mentioned thread aside from the DNS servers.
5) Once I make sure everything is set up correctly (verify the connection settings and the router IP address again), save settings one more time, then pull the power plug on the router.

Once everything is set up:

1) Reboot my laptop, then make sure it does not have an assigned IP address from DHCP by checking through "ipconfig" on a command prompt.
2) Once the timer I set went off, I turned the modem back on.
3) Once it powered up and the power, ethernet and DSL lights were all on, I connected the router to the modem via ethernet.
3) Plug in the power cord for the router and wait until it boots up.
4) I then reset the timer for five minutes and waited to see if the "Internet" light on the modem turned on.
5) It didn't, so I logged into the router, clicked on "Status" at the top, and clicked on "Connect" to force the router to connect.
6) The browser window refreshed about 6 times, then spat a "Can Not Get IP Address From PPPoE" error at me.

At this point I think either the modem is refusing to fully go into bridge mode, OR there's a setting I'm missing. If anyone has any other ideas, please let me know.

If I need to post some of those other settings, I'll happily post them. I'm on a different internet connection right now so I don't have access to the modem but I'll post as soon as I can.



Doctor Olds
I Need A Remedy For What's Ailing Me.
Premium,VIP
join:2001-04-19
1970 442 W30
kudos:18

2 edits

said by TheBoyBlunde:

3) On the "Setup" screen on the router, change the router's IP address to 192.168.1.2. Click "Save Settings".

Is that a typo?

It should be 192.168.2.1, not 192.168.1.2

Then follow the FAQ article here.

»support.earthlink.net/articles/d···mode.php

You should only need to copy the two pages seen in the FAQ.
--
What’s the point of owning a supercar if you can’t scare yourself stupid from time to time?

TheBoyBlunde

join:2013-03-08
Broomfield, CO

1 edit

Sorry, forgot to hit "quote reply" and I'm not sure how to copy the previous post. 192.168.1.2 is not a typo. Does that matter?

Also I had the router and modem with the exact same IP address for three years with no problems and it worked fine until I reset everything. Is that...not supposed to work like that?



Doctor Olds
I Need A Remedy For What's Ailing Me.
Premium,VIP
join:2001-04-19
1970 442 W30
kudos:18

Yes, it matters when you reset the ZyXEL Modem and all of a sudden there is an IP conflict on the LAN. Which is exactly what happened after you reset the ZyXEL Modem.

To set the ZyXEL Modem into Bridge Mode you follow the FAQ instructions and do not mess with any other settings or re-enter the Username/Password as that is Router Mode info. Your ZyXEL Modem pages should exactly match the two pages seen in the FAQ.
--
What’s the point of owning a supercar if you can’t scare yourself stupid from time to time?


TheBoyBlunde

join:2013-03-08
Broomfield, CO

You were right, though I went the other way with the IP addresses. I changed the modem to 192.168.0.1 and left the router at 192.168.1.1. I had to reset everything a couple of times to get it to take, but I'm finally back online with my router handling connection duties and the modem being a simple pass through. Thanks for your help!

Now that I think about it, I think that's how I had it set before, but it had been 3 years since I logged in so I forgot. Regardless, it works and I'm up and running thanks to your help Doctor Olds.



Doctor Olds
I Need A Remedy For What's Ailing Me.
Premium,VIP
join:2001-04-19
1970 442 W30
kudos:18

Glad to hear of your success! Congratulations!

You might want to create a text file (i.e., ModemRouterSetup.txt and then save it to your My Documents folder in a Earthlink sub-folder or whereever you prefer and under what filename works best for you) with your current setup and IP changes described so if a problem occurs again you will have all the info to configure it back the current way quickly.
--
What’s the point of owning a supercar if you can’t scare yourself stupid from time to time?


OriginalDrM

join:2003-05-08
Pompano Beach, FL
reply to TheBoyBlunde

Is it just as reasonable to change the Zyxel's IP address and leave the router alone?



Doctor Olds
I Need A Remedy For What's Ailing Me.
Premium,VIP
join:2001-04-19
1970 442 W30
kudos:18

said by OriginalDrM:

Is it just as reasonable to change the Zyxel's IP address and leave the router alone?

Yes, as long as you remember the new IP if you want to access the device without resetting it and having an IP conflict.
--
What’s the point of owning a supercar if you can’t scare yourself stupid from time to time?