dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
707
share rss forum feed

cisco7940sip

join:2013-03-10

1 edit

[Other] cisco 7940 sip phone not registered

tried to hook a cisco 7940 sip phone with freephoneline.
7940phone->asus rt-n16 with omato Firmware 1.28.0000 MIPSR2-104 K26 USB AIO->cable modem

7940phone config is fine as it was working with a low end router without any problem, it got issue only when changed to this rt-n16 router.
set UDP timeout unreplied to 10 and disabled SIP already, forwarding for port 5060-5062 and 16384-16400, still no luck.

ran grep 192.168.1.c /proc/net/ip_conntrack got
udp 17 3599 src=192.168.1.c dst=72.53.73.a sport=5061 dport=5060 packets=1715 bytes=1015280 [UNREPLIED] src=72.53.73.a dst=72.53.73.b sport=5060 dport=5061 packets=0 bytes=0 mark=23068674 use=1

192.168.1.c is my sip phone IP, 72.53.73.b is my router wan IP and 72.53.73.a is the wan gateway of my router.

strange enough here is that it seems trying to register with the wan gateway instead of the freephoneline proxy which should be 208.65.240.44

Tried change nat address to 192.168.1.c/192.168.1.1, set nat-received processing to 1, reboot router, reboot phone, no luck still.

sipdefault:
# Image Version
image_version: "P0S3-8-12-00"

# Proxy Server
proxy1_address: "208.65.240.44"

# Proxy Server Port (default - 5060)
proxy1_port: "5060"

# NAT/Firewall Traversal
nat_enable: "1"
nat_address: "72.53.73.b"
voip_control_port: "5061"
start_media_port: "16384"
end_media_port: "16399"
nat_received_processing: ""

# Proxy Registration (0-disable (default), 1-enable)
proxy_register: "1"

# Phone Registration Expiration [1-3932100 sec] (Default - 3600)
timer_register_expires: "300"

# Codec for media stream (g711ulaw (default), g711alaw, g729)
preferred_codec: "g729"

...

P.S. I once put 72.53.73.a(my wan gateway ip) instead of 72.53.73.b(my wan ip) into nat address.

Any ideas?