dslreports logo
 
    All Forums Hot Topics Gallery
spc

spacer

Search Topic:
uniqs
4055
share rss forum feed

pablo
MVM
join:2003-06-23
kudos:1

1 recommendation

openSUSE 12.3 Available

Hi,

The latest version of openSUSE is available: 12.3

See »software.opensuse.org/123/en

I'm seeding. I may install it on one of my machines today.

Cheers,
-pablo
--
openSUSE 12.2/KDE 4.x
ISP: TekSavvy Bonded DSL; backhauled via a 6KM wireless link
Assorted goodies: »pablo.blog.blueoakdb.com


sempergoofy
Premium
join:2001-07-06
Smyrna, GA
I downloaded last night and have already burned both i586 and x86_64 DVDs.

On my way to a test server this morning to give it a spin.
--
nohup rm -fr /&


sempergoofy
Premium
join:2001-07-06
Smyrna, GA
My first attempts are unsatisfactory on a 32-bit server with 15-inch flat panel Viewsonic VG700b. After probing during the install, I get an "OUT OF RANGE" error from the monitor. I am going to have to try changing the VGA mode from the initial panel to see if I can get past that.
--
nohup rm -fr /&


nwrickert
sand groper
Premium,MVM
join:2004-09-04
Geneva, IL
kudos:7
Reviews:
·AT&T U-Verse
reply to pablo
said by pablo:

The latest version of openSUSE is available: 12.3

Well, now you tell us - a dollar short and a day late

I am already up and running with 12.3. On one box, I started a few days early by using "zypper dup" to upgrade from RC2 (release candidate 2). On other boxes, I installed from the DVD image (but written to a USB).

Everything is mostly okay, though I did file one bug report (related to UEFI install).
--
AT&T Uverse; Buffalo WHR-300HP router (behind the 2wire gateway); openSuSE 12.3 RC2; firefox 19.0

pablo
MVM
join:2003-06-23
kudos:1
said by nwrickert:

Well, now you tell us - a dollar short and a day late

I was waiting for you to tell us!!! I meant to post it yesterday but the day got away from me ... you know how it goes.

I'm currently backing up my laptop and do a complete re-install. For me, I like to wipe the slate clean between versions.

Cheers!
-pablo
--
openSUSE 12.2/KDE 4.x
ISP: TekSavvy Bonded DSL; backhauled via a 6KM wireless link
Assorted goodies: »pablo.blog.blueoakdb.com

pablo
MVM
join:2003-06-23
kudos:1
reply to sempergoofy
Hi,

I'm starting the install now.

My first try, at the initial boot screen, I tried to set the video to the maximum (1600x1200) and the installer hung. The next time around I used the default video settings and that worked. The installation is currently formatting my SSD .. oh, now it's deploying images ... the fun begins!

Cheers,
-pablo
--
openSUSE 12.2/KDE 4.x
ISP: TekSavvy Bonded DSL; backhauled via a 6KM wireless link
Assorted goodies: »pablo.blog.blueoakdb.com


sempergoofy
Premium
join:2001-07-06
Smyrna, GA

1 edit
reply to pablo
My luck was not much better with the installer. I was able to select a different video from "Default" at the initial boot screen via pfkey. I selected 1024x768. That seemed to get me past the out-of-range and I completed the installation and the initial pseudo reboot in order to login. I looked around and then rebooted.

I saw the grub2 welcome text flash, and then "OUT OF RANGE" again from the monitor. So apparently he must have built in defaults into grub. It booted (as evidenced by the hard drives flashing with activity). But "OUT OF RANGE" remains on the screen.

I just logged in via ssh from another machine. I guess I'll start digging into the mess.

So far, I am unimpressed with the quality.

Edit: I fixed it via curses-mode yast after logging in via ssh.
Yast -> System -> boot loader
Boot loader: Grub2
Boot loader options ->
It had correctly specified the "video=1024x768" kernel option from the installation steps, but had
Use graphical console (checked)
console resolution: Autodetect by grub2
I changed from autodetect to 1024x768

After selecting ok and having it rewrite everything, graphical grub2 worked correctly upon reboot. So, grub2 is not autodetecting too well w.r.t. the monitor on that system.

--
nohup rm -fr /&

pablo
MVM
join:2003-06-23
kudos:1
Nice work wrangling that one ... I had better success than you. Everything installed fine and I did a successful `halt' and `reboot'

`sleep' works. `hibernate' didn't work before and doesn't work now. I may actually do something about it this time. Although, I prefer `sleep' over `hibernate' anyway ...

At the moment, I'm running an update to get the latest updates to the installed software .. perhaps after that I'll hack on the `hibernate' ... just for an hour or so ...

Cheers,
-pablo
--
openSUSE 12.2/KDE 4.x
ISP: TekSavvy Bonded DSL; backhauled via a 6KM wireless link
Assorted goodies: »pablo.blog.blueoakdb.com


sempergoofy
Premium
join:2001-07-06
Smyrna, GA
reply to sempergoofy
So, I try to launch firefox after logging in. It blows me off immediately back to the login screen. From the .xsession-errors file:

I've installed every opensuse release on this server with the same monitor since suse 9.3 pro. Never had a problem like this.

--
nohup rm -fr /&


pcdebb
RIP lil hurricane
Premium
join:2000-12-03
Brandon, FL
kudos:5
reply to pablo
been wanting to try this over Linux Mint.....

pablo
MVM
join:2003-06-23
kudos:1
reply to pablo
Hmmm, seems the nvidia proprietary driver from the repository isn't providing me direct rendering.

I've downloaded the latest driver from nvidia and I'll install it. First I'll switch to nouveau for a bit.

Cheers,
-pablo
--
openSUSE 12.2/KDE 4.x
ISP: TekSavvy Bonded DSL; backhauled via a 6KM wireless link
Assorted goodies: »pablo.blog.blueoakdb.com


sempergoofy
Premium
join:2001-07-06
Smyrna, GA
Something is definitely not right in the land of "X" for me on that old server with this release using the normal-for-me KDE. Despite having turned off desktop effects, the screen is really laggy. If I have top open in a window and then start trying something in another window, Xorg jumps to 99 or 100% utilization immediately.

I decided to give "sax3" a try to perhaps get a new X conf since it is in the repository. It handed me a big fat segfault for my trouble as it did about two years ago when I tried sax3.
--
nohup rm -fr /&

pablo
MVM
join:2003-06-23
kudos:1
Hi,

What's the result of "glxinfo | fgrep -i 'direct rendering' ?

It should be `Yes'

Cheers,
-pablo


sempergoofy
Premium
join:2001-07-06
Smyrna, GA

1 edit
I'll post as soon as I can. I just brought the system up after having shut it down last night after the segfaulting sax3. It has the suse "vine" graphic displayed, but won't accept any keystrokes, including ctrl-alt-Fn to switch to another logical terminal. I am able to ssh in from another computer and see "plymouthd" running at 100% on one of the two cpus.

Killing plymouthd did not change anything with respect to the server console responding to keystrokes. So I just did an shutdown -r.

Edit: Sheesh. It really has his underwear wrapped around its head. Gee, thanks sax3. Looks like I get to go hand crank an xorg.conf because right now, xorg.conf does not exist and I don't see that sax3 may have taken a backup before destroying whatever was there after the installation.

--
nohup rm -fr /&

pablo
MVM
join:2003-06-23
kudos:1
Hi,

Just a gentle reminder the nouveau drivers don't use the old xorg.conf file. Everything is contained within /etc/X11/xorg.conf.d

FWIW, one I uninstalled the nvidia drivers, I nuked the xorg.conf I had and all is well on my little laptop.

Cheers,
-pablo
--
openSUSE 12.2/KDE 4.x
ISP: TekSavvy Bonded DSL; backhauled via a 6KM wireless link
Assorted goodies: »pablo.blog.blueoakdb.com


sempergoofy
Premium
join:2001-07-06
Smyrna, GA
Good reminder.

I have recovered the system back to the point where sax3 did its worst. I had to delete
99-saxdevice.conf
99-saxmonitors.conf
99-saxscreen.conf
from /etc/X11/xorg.conf.d/ directory.

So currently, I am back to grub2 specifying 1024x768 to the kernel and also an explicit specification of those dimensions as grub2 options instead of autodetection as described above. However, the KDE desktops are defaulting to 1280x1024. Specifying 1280x1024 to grub2 yields the aforementioned "out-of-range" error in the display.

I had to install mesa-demo in order to get the glxinfo command available:

This is a 10+ year old server with an ATI MACH64 chipset for the VGA on the mobo.

--
nohup rm -fr /&

pablo
MVM
join:2003-06-23
kudos:1
One thought is to try the proprietary ATI graphics drivers. For a 10+ year old box though ... Hmmm.

Cheers,
-pablo

pablo
MVM
join:2003-06-23
kudos:1
Hi,

One issue I've come across is `kwin' consuming an extraordinary amount of CPU during certain events. Not tons but enough to impact certain windowing functions.

For example, I have focus-follows-mouse enabled with a 0ms delay. Previously, mousing to another window was instantaneously active. Now, there's a slight (.1 to .2 second) delay. Running `top' at the same time as I mouse around shows a `kwin' spike.

I could do one of two things: 1) start with a fresh .kde environment or 2) try the nvidia proprietary driver (the compile your own since the repo version, Direct Rendering is busted on my laptop).

It's easy to start fresh:

o cd /home
o mv pablo pablo.orig
o mkdir pablo
o chown pablo.users pablo

Log back in ... and let the bifurcation begin (if kwin starts to behave

Cheers,
-pablo
--
openSUSE 12.2/KDE 4.x
ISP: TekSavvy Bonded DSL; backhauled via a 6KM wireless link
Assorted goodies: »pablo.blog.blueoakdb.com


nwrickert
sand groper
Premium,MVM
join:2004-09-04
Geneva, IL
kudos:7
Reviews:
·AT&T U-Verse
said by pablo:

One issue I've come across is `kwin' consuming an extraordinary amount of CPU during certain events.

I have not noticed that.

For example, I have focus-follows-mouse enabled with a 0ms delay.

I use a 200 ms delay. Perhaps that's why I'm not seeing the kwin spikes. My eyes don't move fast enough to need a zero delay.
--
AT&T Uverse; Buffalo WHR-300HP router (behind the 2wire gateway); openSuSE 12.3; firefox 19.0.2

pablo
MVM
join:2003-06-23
kudos:1
said by nwrickert:

I use a 200 ms delay. Perhaps that's why I'm not seeing the kwin spikes. My eyes don't move fast enough to need a zero delay.

Hi,

I have the delay set to zero so I can mouse to one window, input, mouse to another. 200 ms quite a delay. Could you reset it to 1 ms (or 0 ms) and see if you can reproduce the issue on your end?

Thx!
-pablo
--
openSUSE 12.2/KDE 4.x
ISP: TekSavvy Bonded DSL; backhauled via a 6KM wireless link
Assorted goodies: »pablo.blog.blueoakdb.com


nwrickert
sand groper
Premium,MVM
join:2004-09-04
Geneva, IL
kudos:7
Reviews:
·AT&T U-Verse
I changed to 0ms, but I left "raise window" at 200. There was very little difference.

I ran top in an xterm. Then moved the mouse pointer between several windows. The highest that kwin ever got was 6.3% of cpu, but it was usually closer to 2%. If I am not busily moving the mouse between windows, it drops a lot lower.

For me, the consistently highest cpu consumer was amarok (I was playing some music at the time), with firefox next. And I was not doing anything in firefox. It was open to this thread. Presumably, moving the focus to the firefox window causes it to do something.

Oops, I should have mentioned Xorg, which was consistently I high cpu gobbler, fighting for top of the list with amarok. When I am not doing anything, Xorg drops to lower in the "top" list (or off-screen at the bottom). But typing this response or moving the mouse between windows pushes up the Xorg usage.

I do suspect that the video driver is at least partly responsible for what you are seeing. The system where I am typing this is using i915 (Intel graphics).
--
AT&T Uverse; Buffalo WHR-300HP router (behind the 2wire gateway); openSuSE 12.3; firefox 19.0.2

pablo
MVM
join:2003-06-23
kudos:1
Thank you very /much/ for the response. I believe when you say "there was very little difference" is that switch from 200 ms to 0 ms, the pause was the same. That confirms what I'm seeing. A few releases back, I saw a similar regression.

I'll try the nVidia proprietary driver but I suspect it's a kwin issue.

Cheers,
-pablo
--
openSUSE 12.2/KDE 4.x
ISP: TekSavvy Bonded DSL; backhauled via a 6KM wireless link
Assorted goodies: »pablo.blog.blueoakdb.com


signmeuptoo
Bless you Howie
Premium
join:2001-11-22
NanoParticle
kudos:5
reply to pablo
Is everyone having problems with it? I lack the skill and knowledge of the rest of you, I was waiting for 12.3 to dual boot (Win8), but I don't know if I dare try it now. 12.2 is pretty docile.

I have a question though:

I am using an ATI video card at the moment, but my replacement nVidia card is enroute. In Windows, I can have both drivers coexist, I don't have to uninstall one. How about in SuSE?

pablo
MVM
join:2003-06-23
kudos:1
reply to pablo
All right, as I thought about it, it's easier for me to boot to single user mode and rename my home directory and create a new empty one. With the empty one, KDE will create the initial configuration files.

The problem is not visible with the freshly minted set of configuration files. I'll next try to figure out what's horked on my configuration file. It shouldn't take too long to bifurcate the problem.

Cheers,
-pablo
--
openSUSE 12.2/KDE 4.x
ISP: TekSavvy Bonded DSL; backhauled via a 6KM wireless link
Assorted goodies: »pablo.blog.blueoakdb.com

pablo
MVM
join:2003-06-23
kudos:1
reply to signmeuptoo
said by signmeuptoo:

Is everyone having problems with it? I lack the skill and knowledge of the rest of you, I was waiting for 12.3 to dual boot (Win8), but I don't know if I dare try it now. 12.2 is pretty docile.

Hi,

You can check the openSUSE forums to see what are the general impressions from people. A sample size of three (or four) of us isn't significant.

I can't answer your dual graphics card question .... sorry!

Cheers,
-pablo
--
openSUSE 12.2/KDE 4.x
ISP: TekSavvy Bonded DSL; backhauled via a 6KM wireless link
Assorted goodies: »pablo.blog.blueoakdb.com


sempergoofy
Premium
join:2001-07-06
Smyrna, GA
reply to pablo
I tried the "new home directory" procedure, but did not receive any improvement. Still seeing high CPU utilization by Xorg.

Next up, seeing if ATI drivers have any benefit. Am also considering giving another graphical desktop a try, like gnome.
--
nohup rm -fr /&


SuseLurker

@wideopenwest.com
reply to pablo
I'm up on 4 different computers, all installs uneventful.

3 of the computers are using various versions of Intel's gma graphics, one uses an Nvidia 9600 gpu and all are Intel cpu's on various manufacturers motheboards of varying ages.

Triple boot on two of them, Win 7, Win 8 and OpenSuse 12.3, dual boot on one and just OpenSuse on the other

All non-uefi as I didn't see the need to punish myself.(g)

I had been up on 12.3 rc1 on two of them for about 3 weeks and no problems there either.

Pleased with the results so far.

SuseLuker


paradigmfl

join:2005-07-16
Reviews:
·ooma
·Bright House Net..
reply to pablo
I would advise caution if you are using the proprietary nvidia driver. I saw some issues with it which caused the inability to boot into a graphical environment. Make sure to have a backup first if you do it.

pablo
MVM
join:2003-06-23
kudos:1
Hi,

I appreciate your warning. I'm quite adroit without a graphical interface. I've hosed my box (and un-hosed) it plenty that I feel comfortable should things go sideways.

btw, even the latest nVidia graphics driver didn't enable "Direct Rendering"

I've also noticed one other wonky thing with how the font is printed in the title of windows. More on that at some point in the future.

Cheers,
-pablo
--
openSUSE 12.2/KDE 4.x
ISP: TekSavvy Bonded DSL; backhauled via a 6KM wireless link
Assorted goodies: »pablo.blog.blueoakdb.com


nwrickert
sand groper
Premium,MVM
join:2004-09-04
Geneva, IL
kudos:7
Reviews:
·AT&T U-Verse
said by pablo:

btw, even the latest nVidia graphics driver didn't enable "Direct Rendering"

Add yourself to the "video" group, and see if that helps.

(based on a discussion I noticed at opensuse forums).
--
AT&T Uverse; Buffalo WHR-300HP router (behind the 2wire gateway); openSuSE 12.3; firefox 19.0.2