dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
33
share rss forum feed


koitsu
Premium,MVM
join:2002-07-16
Mountain View, CA
kudos:23

1 edit
reply to norwegian

Re: [Laptop] How do I replace my hard drive: operating system/s

I'm sorry, it appears I missed analysing the SMART error log portion of your post; bad formatting (use of "copy" not "code") made me miss this, but it's still my mistake.

SMART Self-test log structure revision number 1
Num Test_Description Status Remaining LifeTime(hours) LBA_of_first_error
# 1 Short offline Fatal or unknown error 10% 5631 -
# 2 Short offline Fatal or unknown error 40% 5631 -
# 3 Short offline Fatal or unknown error 90% 5623 -
# 4 Short offline Fatal or unknown error 30% 5623 -
# 5 Short offline Fatal or unknown error 10% 5622 -
# 6 Short offline Fatal or unknown error 50% 5620 -
# 7 Short offline Fatal or unknown error 10% 5619 -
 

Chances are what's causing these entries is is WD's own software ("WD LifeGuard Diagnostics"). The SMART self-test log contains a status_type field for each test, represented by 4 bits (range 0-15). A value of 3 indicates "Fatal or unknown error".

SMART short, long, and conveyance tests are basically implemented at the firmware level -- the drive itself does the analysis/testing. What the firmware chooses to look for is unknown -- this is implemented per-vendor and per-model of drive. Only Western Digital knows. The short test does not do a surface scan (LBA scan) of the platters; historically this test has looked for things like internal servo failures and some other low-level (often mechanical) things. However, servo failure is supposed to be indicated with a status_type code of 6.

If the short test is failing, especially at random completion percentages (vs. a constant point), then this does seem to point to some kind of internal oddity happening within the drive. I cannot explain this behaviour -- only WD would be able to explain what's actually causing that to fail. These type of "odd" failures, combined with audible noises coming from the drive (which presumably are not the drive parking its heads), probably indicate something mechanical that intermittently has problems -- something that is not tracked with SMART attributes, but is checked with an internal SMART short test.

I would suggest you tell WD Technical Support about the failed self-test when using WD LifeGuard Diagnostics. Show them the above data from smartmontools (the same data you provided earlier), and point them to the SMART self-test log section. If the drive is under warranty, they should have no problem issuing an RMA for it, and I suggest you do an Advanced RMA (where they send you a replacement drive before you send them the wonky one).

I should note, however, that sector/LBA-wise, there's really no indication of the drive ever having encountered issues -- so your data should be safe/intact for the time being.

If I was in your shoes, I would do exactly the above -- replace the drive solely as a precaution.

P.S. -- I would also appreciate an audio sample of some kind of what the noise is that you're hearing. It won't necessarily tell me what the actual problem is, but sometimes it's enough for me to say "servo problem" or "actuator arm problem". This is purely educational and doesn't help solve the issue in any way; only WD can do something about that.
--
Making life hard for others since 1977.
I speak for myself and not my employer/affiliates of my employer.


Lizzie

@comcast.net

I can tell you this and describe it as best I can:

Imagine the Windows start up musical sound, which plays when Windows boots, which is 4 notes. This was almost identical only with 3 notes.

There was an extremely faint buzzing sound of 4 very brief pulses that played underneath the music.
Imagine the sound of a vibrator being flipped on and off
very fast 4 times.

It went of for 3.5 days, every five minutes, even when out of the computer.

The drive has a round silver thing in a recessed part of the front of the hard drive, with some copper wires, about 5 of them, going into the case of the hard drive, which I assume is the power source, as it looks like a battery. There are several small square holes along the edges of the drive which must be, one of them, a speaker.

I appreciate you coming back to advise me to swap out the hard drive for a new one. I doubt I will be getting another westerndigital one, as this is only 1.5 years old.



Msradell
P.E.
Premium
join:2008-12-25
Louisville, KY

I've never seen a hard drive that had a speaker built into it! Either the sound wasn't coming directly from the hard drive or the noise you were hearing was some kind of a squeak due to a mechanical problem. Since the noise was very repetitive, the squeak isn't very likely.



Lizzie

@comcast.net

I know it sounds crazy to have a speaker in a hard drive but it must have one. When it finally goes bad completely I will dismantle it.



Lizzie

@comcast.net
reply to Msradell

Have you ever seen one with a battery imbedded into it on the outside of the case?
This one has that too.



Lizzie

@comcast.net
reply to Msradell

Here is the latest email from westerndiital:

"We asked because these drives do not making any type musical sound or melody.

That music you hear is coming from another component of your computer, not the hard drive.

We will recommend you to have your computer checked by a technician. He will help you determine

where the melody comes from."

I didn't believe it could be happening either.
That's why I had to put the computer, minus the hard drive, in the farthest part of the house.

Then as I was holding the hard drive, outdoors, to make sure, found that it was the hard drive doing it.

I guess this will remain a mystery without an answer.