dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
929
share rss forum feed

slidebite

join:2012-12-07
Lethbridge, AB
Reviews:
·TekSavvy DSL

2 edits

[DSL] Steam users - favor to ask

I've had some really odd issues since this weekend with download speeds, mostly from Steam. Originally I posetd the message as a Telus-area favor but there seems to be someone on Shaw that has an issue too so I edited it.

I have a DSL 25/2 package which with my old Telus acct and Teksavvy I would typically see 2.3-2.5MB/sec downloads reliably for pretty much ever. Since this past weekend, I'm getting 1.5 so about 1mb/sec less than normal regardless of time of day and server.

I've done all the basic trouble shooting I can think of, tried several different steam servers, rebooted equipment, used different PCs, safe mode, yadda, but no avail.

Other than the odd hiccup, Speedtest.net tests from preferred servers seem to be within spec or at least close to it... so I am puzzled. I have tried some other big file downloads on other servers and I'm pulling close to what I should.

So here is my favor to humbly ask:

Those of you with Steam and Teksavvy, especially southern Alberta, can you try to update/download a game in your steam library and see if you're getting expected speeds?

I am kind of trouble shooting here but I don't want to send Teksavvy on a wild goose chase either if it is isn't their issue. I don't have any friends that are on Teksavvy so I am kind of on my own here.

Or, alternatively, does anyone know of any steam settings I may not be aware of? I've already tried different servers, made sure my speed settings was more than ample.


RandalIT

join:2012-07-26
Calgary, AB

Re: [DSL] Teksavvy DSL customers in Telus land - favor to ask

Hey slidebite

How are you measuring the speeds of the downloads from Steam? I know that the numbers next to games that are downloading are some time close and other times not. Could possibly be Steam, I would have to check when I get home.



jtl999
CEO of Actiontec Dev Team

join:2012-11-24
In the GVRD
kudos:4
reply to slidebite

Same problem on Shaw.
Can you post a speedtest.net image?


slidebite

join:2012-12-07
Lethbridge, AB
Reviews:
·TekSavvy DSL
reply to slidebite

Same problem on Shaw? Really? That is interesting.

Speedtest by and large is normal. The odd time it fluctuates, but I don't think enough to say there is a problem.




However, Steam is averaging 1.5mb/sec whereas it used to be 2.5~ish.

I did a resmon to see where it connected to and it's kind of like a torrent.



Which kind of made sense as it is generally REALLY good at filling the pipe.

I would be really curious if others on Teksavvy are having this issue especially if you are on Shaw.

graniterock
Premium
join:2003-03-14
London, ON
Reviews:
·WIND Mobile
·TekSavvy Cable
reply to slidebite

Re: [DSL] Steam users - favor to ask

My experience with Steam is at times it can have wonky speeds. It's well documented on the steam forums and on a google search. Sometimes you can have luck if you switch to a different steam server but in my experience if one is slow the rest are within 20% of that. I always assumed it was a steam issue but never dedicated myself to getting to the bottom of it. (I'm on TSI Cable in Ontario Rogers territory).


slidebite

join:2012-12-07
Lethbridge, AB
Reviews:
·TekSavvy DSL

You are right, all servers seem to be close in speed but I really haven't seen anything documented or in my other queries other than people that genuinely do have there server set inappropriately OR on really busy days, like new releases or super sales.

This is irritating me because Steam is one of the few apps that I use regularly that takes advantage of my bandwidth, so if I am only getting about 60% of speed I notice it.

It was working great up until this past weekend (or maybe Friday), so I am just scratching my head if it is unique to me/my system/area or a bigger Teksavvy thing.


BrianON

join:2011-09-30
Ottawa, ON

1 edit
reply to slidebite

Sometimes the steam servers can be slow. Usually selecting a different region alleviates the problem. Other than that not sure what it could be.


slidebite

join:2012-12-07
Lethbridge, AB
Reviews:
·TekSavvy DSL
reply to slidebite

Well folks, I figured it out! It had nothing to do with Teksavvy at all.

I have my windows updates set to manual, and I just remembered doing a "recommended driver update" for my wireless card a couple weeks ago. Since I did a fresh windows re-install today, I paid close attention to all of my updates and one of them was for my Wireless ASUS card. Since I did all my windows updates before installing my software I didn't try Steam without it first.

However, on a absolute hunch (because I tried everything else) I rolled back the driver to generic MS Railink driver 3.0.0.41 from Feb 2009 which was the default driver on Windows 7. And VOILA! Normal downloads again! (well, for my package!). My other PCs have a similar wireless card so I need to them back now too.

If anyone discovers a phenomena like this, might be worth a try.



drjp81

join:2006-01-09
canada

I've had this happen with three different machines with Atheros 5XXX. BY 3 different manufacturers. So your experience isn't unique I can assure you.
--
Cheers!