dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
2273
share rss forum feed

moonpuppy

join:2000-08-21
Glen Burnie, MD

FINALLY! HAm Radio Deluxe and Kenwood TS-440s

Finally, got everything working. Here is a little history.

Have had a TS-440SAT for quite a while but haven't had time to get it going (new house, wife, child, work....the usual.) So I finally got back to it. Ordered an IC-10 chipset, serial cable and USB adapter off of eBay. Installed the chips in the radio (to get a serial connection) and tried to use it.

Here is where the first problem came in. The USB to serial adapter. Word of advice....never use any with the Prolific chipset. I kept getting Code 10 in device manager (Windows 8 and & machines.) Found it, a version of this chipset (HX & HXA) is not compatible with Windows 7 or 8.

Finally found one with an FTDI chipset and it worked right out of the box. The cool thing with mine (Parallax) is that it has a green LED (for status) and a red LED (for data) that lets me know if everything is communicating. In fact, it did better than an older XP tower with a native serial port.

Loaded up Ham Radio Deluxe version 5 and it immediately connected to the radio. No signal meter (this has an analog meter) but everything else seems to work. No antenna yet and I did not try the transmit but it controlled the radio perfectly.

Now, to get the antenna on the roof.



aSic
application specific
Premium
join:2001-05-17
Wakulla, FL
Reviews:
·Comcast

Amusing. All my other gear "prefers" the Prolific Chipset in the Serial2USB adapters I've used. At the same time, I still run XP across the board..
--
Teamwork is a lot of people doing what I say.


moonpuppy

join:2000-08-21
Glen Burnie, MD

XP is not an option for me.


n_w95482
Premium
join:2005-08-03
Ukiah, CA

2 edits
reply to moonpuppy

downloadPL2303.exe.zip 1,853,810 bytes
I'm not sure what version of the Prolific chip my adapter is, but I went through driver hell to get it working in Windows 7. A couple of times I got the same code 10 error that you did.

I ended up using a specific Vista driver (wasn't the first or last version they did, somewhere in the middle), now it works like a champ. I think it was cranky with XP as well, but none of my machines currently run that so I haven't spent time sorting that out.

I've attached that driver to this post in case you want to try it. I use my adapter to program my Yaesu VX-7, and it works perfectly with VX-7 Commander once I set the write delay to 18.

I used an adapter with the FTDI chip once, definitely less hassle to get it working .
--
KI6RIT