dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
5915
share rss forum feed

Jinzo

join:2011-06-14
Burlington, ON

Comcast SMTP whoa's

Has Comcast changed there SMTP policy? My parents spend three months a year down in Florida and use Comcast as their provider.

Up here in Canada they use Teksavvy. I basically configured their Outlook Express on their laptop to access the their teksavvy pop3 account to receive their mail. Since they are on Comcast I set it up to use their smtp.comcast.net Port 25 as the outgoing mail server.

This worked for several years now. Until last Sunday. They can still get mail via teksavvy but can no longer send.

Here is their setup:
smtp.comcast.net port 25 This used to work
smtp.comcast.net port 587 Got this from this article
»customer.comcast.com/help-and-su···ettings/
Also tried:
smtp.comcast.net Port 465 I had them enable SSL, got it from this article
»customer.comcast.com/help-and-su···nternet/
None of the above work.

I suspect the reason they can't send is that comcast systems are now looking at the sender address. If it is not a WhoEver@comcast.net the email is rejected.

Can anybody from Comcast confirm this? If this has changed is their any work around. They are used to work with Outlook Express and I don't want to train them on Teksavvy webmail if I can avoid it.



graysonf
Premium,MVM
join:1999-07-16
Fort Lauderdale, FL
kudos:2

Comcast no longer allows the use of port 25 to send mail, even when using their own server.

Have you tried these settings for outgoing mail when on a non-Teksavvy connection?

Server: out.teksavvy.com
Port: 1025
Username: complete teksavvy email address
Password: your teksavvy email account password



NetFixer
Snarl For The Camera Please
Premium
join:2004-06-24
The Boro
Reviews:
·Cingular Wireless
·Comcast Business..
·Vonage

1 edit
reply to Jinzo

As graysonf already mentioned, Comcast no longer allows port 25 usage of their smtp.comcast.net server for mail submission (from anyone, anywhere).

However, your failure using port 587 to smtp.comcast.net should have worked. I normally use my own SMTP server that forwards to Comcast's Business Class SMTP server on port 587. But I just did a test by modifying my SeaMonkey email client to send its email messages using smtp.comcast.net on port 587 (one from a Microsoft MSN account, and one from one of my own domain accounts). Both of those emails went through immediately with no problems. Did you use the full username@comcast.net email address as the email account name, and enable authentication using those credentials for the outbound email when you tried using port 587 with smtp.comcast.net?

The failure when using port 465 with SSL may have been Microsoft's annoying habit of reverting to port 25 for outbound email even if you initially manually set it to port 465. I have on many occasions had to go back into the email account setup multiple times when using MS Outlook (Express) and MS Live Mail to correct that well known problem (if you are persistent enough that should eventually work).

Shown below is the full source for the two received email messages to illustrate that using port 587 with smtp.comcast.net does indeed work even when the "from" address is not a comcast.net email address (I only edited the personal part of the email addresses to lower the spam rate to those email accounts).

Email sent from MSN account:
From - Wed Mar 27 17:55:46 2013
X-Account-Key: account2
X-UIDL: 203
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00000000
X-Mozilla-Keys:                                                                                 
Received: from imta01.potomac.co.businessclass.comcast.net (76.96.111.6) by
 PO1HUB01.po1.comcast.net (172.24.252.233) with Microsoft SMTP Server id
 8.2.176.0; Wed, 27 Mar 2013 16:54:51 -0600
Received: from qmta09.westchester.pa.mail.comcast.net ([76.96.62.96])by
 imta01.potomac.co.businessclass.comcast.net with bizsmtpid
 Gmur1l00324bTx001murEx; Wed, 27 Mar 2013 22:54:51 +0000
Received: from omta12.westchester.pa.mail.comcast.net ([76.96.62.44])by
 qmta09.westchester.pa.mail.comcast.net with comcastid
 GbFC1l0020xGWP859muroX; Wed, 27 Mar 2013 22:54:51 +0000
Received: from [IPv6:2601:5:c80:62:b0b9:a6f2:61b2:8f80]
 ([IPv6:2601:5:c80:62:b0b9:a6f2:61b2:8f80])by
 omta12.westchester.pa.mail.comcast.net with comcastid
 Gmuq1l00l3jwQcW3YmuqsR; Wed, 27 Mar 2013 22:54:51 +0000
From: my name <my_name@msn.com>
To: my name <myname@dcsenterprises.comcastbiz.net>
Date: Wed, 27 Mar 2013 16:54:50 -0600
Subject: Test Message using Comcast SMTP
Thread-Topic: Test Message using Comcast SMTP
Thread-Index: Ac4rPhcc9K0+jBxqTXeDE1oLldMyjg==
Message-ID: <515378BA.2030705@msn.com>
Reply-To: "my_name@msn.com" <my_name@msn.com>
Accept-Language: en-US
Content-Language: en-US
X-MS-Exchange-Organization-AuthAs: Anonymous
X-MS-Exchange-Organization-AuthSource: PO1HUB01.po1.comcast.net
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
x-authority-analysis: v=2.1 cv=KqH1bgmN c=1 sm=1 tr=0
 a=9fOd34CRxRfhPBBaahwN3Q==:117 a=C_IRinGWAAAA:8 a=1feV9YNv0uYA:10
 a=psyL_uJ75t4A:10 a=7cBF1dnHSVMA:10 a=erfevXAxgKcA:10 a=kj9zAlcOel0A:10
 a=xqWC_Br6kY4A:10 a=AAvYLDLOAAAA:8 a=UIhnRnI3ObIA:10
 a=vf_M0ex5t2fhGvCx-doA:9 a=CjuIK1q_8ugA:10
dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=comcast.net;
s=q20121106; t=1364424891;bh=PGSZ69BN53r6sA3mBQYN7LKav3R/xZme4bKLk2luxeY=;
h=Received:Received:Message-ID:Date:From:Reply-To:MIME-Version:To:
 Subject:Content-Type;
b=trmXf+dhrL97ciKRdvTqjsJo/daMtqXqzlmkb5WCNeZbO3dNNWo2BIj4c3CZGT9q+
 2JvBxEumIkxccfMlCHLSdJk5ydlJVHw7bQlYjt5JjfA1D+IMHGZKN/EYcEm6VQMy7D
 4VbqB/qbuZUI79kc+HoS8j/mHMWn78BEeT+85c6yepuA/kbgmFTJnBSZZ9hAoPDbsL
 ZDq7aqHqYfAuaLKatwP/g7mW9Coec/L+X/XfAHNS3ryHA1cZNmCNU/A7+bFAQYnPIV
 N15euSDo07ykcx1hHmmHG6ySS7sb6j+1qJi29mMxOda2wE2UkLDgSXFFfYhqvfAQFP
 tUryKLGb857Fg==
user-agent: Mozilla/5.0 (Windows NT 5.1; rv:16.0) Gecko/20121026
 Firefox/16.0 SeaMonkey/2.13.2
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: quoted-printable
MIME-Version: 1.0
 
This is a test Message using the Comcast SMTP server
 
 

Email sent from a private domain account:

From - Wed Mar 27 17:56:22 2013
X-Account-Key: account2
X-UIDL: 204
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00000000
X-Mozilla-Keys:                                                                                 
Received: from imta03.potomac.co.businessclass.comcast.net (76.96.111.6) by
 PO1HUB01.po1.comcast.net (172.24.252.233) with Microsoft SMTP Server id
 8.2.176.0; Wed, 27 Mar 2013 16:56:05 -0600
Received: from qmta01.westchester.pa.mail.comcast.net ([76.96.62.16])by
 imta03.potomac.co.businessclass.comcast.net with bizsmtpid
 Gmvh1l00H0M1gvg01mw5Rj; Wed, 27 Mar 2013 22:56:05 +0000
Received: from omta21.westchester.pa.mail.comcast.net ([76.96.62.72])by
 qmta01.westchester.pa.mail.comcast.net with comcastid
 Gapx1l0031ZXKqc51mw5KA; Wed, 27 Mar 2013 22:56:05 +0000
Received: from [IPv6:2601:5:c80:62:b0b9:a6f2:61b2:8f80]
 ([IPv6:2601:5:c80:62:b0b9:a6f2:61b2:8f80])by
 omta21.westchester.pa.mail.comcast.net with comcastid
 Gmw41l01S3jwQcW3hmw4sr; Wed, 27 Mar 2013 22:56:05 +0000
From: my name <mys@dcsenterprises.net>
To: my name <myname@dcsenterprises.comcastbiz.net>
Date: Wed, 27 Mar 2013 16:56:04 -0600
Subject: Test Message using Comcast SMTP
Thread-Topic: Test Message using Comcast SMTP
Thread-Index: Ac4rPkM/FW+u6fzDQQ2nk0gmeG9qzg==
Message-ID: <51537904.6000100@dcsenterprises.net>
Reply-To: web master <webmaster@dcsenterprises.comcastbiz.net>
Accept-Language: en-US
Content-Language: en-US
X-MS-Exchange-Organization-AuthAs: Anonymous
X-MS-Exchange-Organization-AuthSource: PO1HUB01.po1.comcast.net
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
x-authority-analysis: v=2.1 cv=HMB7oedv c=1 sm=1 tr=0
 a=ZEjHZJKeZgBjZCHK70ibxQ==:117 a=C_IRinGWAAAA:8 a=1feV9YNv0uYA:10
 a=psyL_uJ75t4A:10 a=DG1RRlLuvOgA:10 a=-MdkRRnrcs8A:10 a=kj9zAlcOel0A:10
 a=xqWC_Br6kY4A:10 a=AI_oQw_aAAAA:8 a=wnRyGxjGAAAA:8 a=UIhnRnI3ObIA:10
 a=NMaY4_iP2TBcLWr9tWAA:9 a=CjuIK1q_8ugA:10 a=vK1pb1XMIckA:10
 a=bH4PfjBifx8A:10
dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=comcast.net;
s=q20121106; t=1364424965;bh=flQQe0aMe4QLWUDyfX8TfKrfZ2X4Hs17fflPpzKN9WM=;
h=Received:Received:Message-ID:Date:From:Reply-To:MIME-Version:To:
 Subject:Content-Type;
b=YeD39jqoGhF8hp+TQn83Tmz3IpviUfnhwp+IeZBW7BFNedrSi0R3E2mi9iMz5ph8f
 CahS4UHQaDYjIX2Moqu78FkhEpyZo711ia+lgR8yZ3XBrJBwBUwSFa5cnXKM/jA7xp
 nMa/nzYAm622VAA0InlO980c1scPzaaiTWQnSOvqcukxH5Q+t0EFKj1ka1McNQicqm
 BWy19h3fXqjbAmjR37yoFHL83VENbef8EBJaQiXryd3QiRZVgK71Co4dXS401gbxRv
 Q81CHnkM7rgBvKBoWiyUwCXUG+SfKxATfG4ZePj6vFLjQD2Of9nCGg70GCpG5ztxGA
 JSrjWYmWd/EfQ==
user-agent: Mozilla/5.0 (Windows NT 5.1; rv:16.0) Gecko/20121026
 Firefox/16.0 SeaMonkey/2.13.2
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: quoted-printable
MIME-Version: 1.0
 
This is a test Message using the Comcast SMTP server.
 
 

--
A well-regulated militia, being necessary to the security of a free State, the right of the people to keep and bear arms shall not be infringed.

When governments fear people, there is liberty. When the people fear the government, there is tyranny.

Jinzo

join:2011-06-14
Burlington, ON
reply to graysonf

Hmm you are referring to this article:
»teksavvy.com/Contents/Item/Display/278

I was not aware they had an external smtp server accessable outside of their network. My parents are on their way back to Canada now, so I will need to test this on my company network when I get their laptop off them.

This is probably the best solution going forward.


Jinzo

join:2011-06-14
Burlington, ON
reply to NetFixer

I had to walk them through the change over the phone so I can't be 100% they did it correctly.

When I tried the SSL setup I had him change the port than select the SSL option. You are correct in that Outlook forced it back to 25 which i had him change again.

The outlook profile was setup with their emailname@teksavvy.com They don't have, or never looked into getting any comcast email address going. Up to this point we had never required it as we were able to bounce the outgoing email off the smtp server. So we never bothered to get a comcast email going. I was hoping to just be able to modify the ports without authenicating for out going email.

Looking at the instructions for the port 587 they appear to want you to specify a login for this to work, which we didn't do or have at this time.

I think I will try the teksavvy external SMTP to work around this.

Just curious, any idea why Comcast made this change? I am guessing it was for security.



NetFixer
Snarl For The Camera Please
Premium
join:2004-06-24
The Boro
Reviews:
·Cingular Wireless
·Comcast Business..
·Vonage

said by Jinzo:

Looking at the instructions for the port 587 they appear to want you to specify a login for this to work, which we didn't do or have at this time.

I think I will try the teksavvy external SMTP to work around this.

Just curious, any idea why Comcast made this change? I am guessing it was for security.

Yes, it was for security and especially for spambot control. By not allowing unauthenticated mail submission, it makes it more difficult for a spambot infected computer to actually be able to send spam. If your parents never setup a Comcast email account, there will be no way that they can send email using a Comcast email server.
--
A well-regulated militia, being necessary to the security of a free State, the right of the people to keep and bear arms shall not be infringed.

When governments fear people, there is liberty. When the people fear the government, there is tyranny.


madylarian
The curmudgeonly
Premium
join:2002-01-03
Parkville, MD
reply to Jinzo

said by Jinzo:

The outlook profile was setup with their emailname@teksavvy.com

That should make no difference at all. I have a personal domain address that I use for most of my email and in my email client (Pegasus) I can switch back and forth between my domain server and Comcast's server. Both work just fine. In fact, I have been using SMTP port 465 for a few years now and it has always worked.

mady
--
Honi soit qui mal y pense


NetFixer
Snarl For The Camera Please
Premium
join:2004-06-24
The Boro
Reviews:
·Cingular Wireless
·Comcast Business..
·Vonage

said by madylarian:

said by Jinzo:

The outlook profile was setup with their emailname@teksavvy.com

That should make no difference at all. I have a personal domain address that I use for most of my email and in my email client (Pegasus) I can switch back and forth between my domain server and Comcast's server. Both work just fine. In fact, I have been using SMTP port 465 for a few years now and it has always worked.

mady

What does make a difference is the part of the OP's post that you ignored and did not quote (reproduced below in bold type).

said by Jinzo:

The outlook profile was setup with their emailname@teksavvy.com They don't have, or never looked into getting any comcast email address going. Up to this point we had never required it as we were able to bounce the outgoing email off the smtp server. So we never bothered to get a comcast email going. I was hoping to just be able to modify the ports without authenicating for out going email.

As I have already pointed out in this thread (and as is fully documented in numerous Comcast help files); you can not send email through a Comcast email server anymore without using authentication. That was in fact one of the reasons for doing the port 25 ban; to force users to use only authenticated servers.
--
A well-regulated militia, being necessary to the security of a free State, the right of the people to keep and bear arms shall not be infringed.

When governments fear people, there is liberty. When the people fear the government, there is tyranny.


graysonf
Premium,MVM
join:1999-07-16
Fort Lauderdale, FL
kudos:2
reply to Jinzo

I googled for it and wound up there or on a similar page.

Also, I'd be willing to bet it will work on their network too, making it a permanent non-location specific solution that works anywhere. Have them try that when they get home.


dczar1

join:2013-04-09
Oak Park, IL
reply to Jinzo

I'm having similar problem in Chicago. I used Eudora specifying incoming and outgoing mail servers and ports. Worked fine up until around 10 days ago. Now, I get mail from my email account I've had since around 1998 or so, but I can't send via smtp.comcast.net and I can't ping that address with a network utility.

rebooted the modem.
rebooted my router.
reloaded three different email clients and set up

can't send anything but I get mail from my third party provider and before you ask, I really, Really, REALLY don't,can't switch to a different email address for business reasons as well as so many places that contact me at my email address.

I've set things up the way their techs tell me on phone and still wont' work using port 465 etc. is there a way around this compound I'm locked in?



graysonf
Premium,MVM
join:1999-07-16
Fort Lauderdale, FL
kudos:2

The IPv4 address for smtp.comcast.net is 68.87.26.155 and it is non-pingable.

The settings for sending mail are:

Server Name: smtp.comcast.net
Port: 465
Connection Security: SSL/TLS
Authentication Method: Your unencrypted username and password

It works for me.



pflog
Bueller? Bueller?
Premium,MVM
join:2001-09-01
El Dorado Hills, CA
kudos:3

said by graysonf:

The IPv4 address for smtp.comcast.net is 68.87.26.155 and it is non-pingable via ICMP.

FTFY.

% tcping smtp.comcast.net 25
smtp.comcast.net port 25 open.

Sorry, couldn't resist.
--
"I drank what?" -Socrates


graysonf
Premium,MVM
join:1999-07-16
Fort Lauderdale, FL
kudos:2

But the IPv6 address for smtp.comcast.net is pingable via ICMP

C:\Users\Fred>nslookup smtp.comcast.net
Server: cdns01.comcast.net
Address: 2001:558:feed::1

Non-authoritative answer:
Name: smtp.g.comcast.net
Addresses: 2001:558:fe14:70::30
68.87.26.155
Aliases: smtp.comcast.net

C:\Users\Fred>ping 2001:558:fe14:70::30

Pinging 2001:558:fe14:70::30 with 32 bytes of data:
Reply from 2001:558:fe14:70::30: time=41ms
Reply from 2001:558:fe14:70::30: time=38ms
Reply from 2001:558:fe14:70::30: time=40ms
Reply from 2001:558:fe14:70::30: time=39ms

Ping statistics for 2001:558:fe14:70::30:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 38ms, Maximum = 41ms, Average = 39ms

So there!



pflog
Bueller? Bueller?
Premium,MVM
join:2001-09-01
El Dorado Hills, CA
kudos:3

haha didn't think to check ipv6
--
"I drank what?" -Socrates



NetFixer
Snarl For The Camera Please
Premium
join:2004-06-24
The Boro
Reviews:
·Cingular Wireless
·Comcast Business..
·Vonage

1 edit
reply to graysonf

said by graysonf:

But the IPv6 address for smtp.comcast.net is pingable via ICMP

But the IPv6 smtp.comcast.net server still does not allow active sessions on port 25 (even on a business class connection where outbound port 25 is not blocked):

webhost:/ # telnet smtp.comcast.net 25
Trying 2001:558:fe14:70::30...
Connected to smtp.comcast.net.
Escape character is '^]'.
554 omta15.westchester.pa.mail.comcast.net comcast Port 25 not allowed
 - http://customer.comcast.com/help-and-support/internet/email-client-programs-with-xfinity-email/
Connection closed by foreign host.
 


OTOH, it does still accept authenticated port 587 sessions (even without TLS):

webhost:/ # telnet smtp.comcast.net 587
Trying 2001:558:fe14:70::30...
Connected to smtp.comcast.net.
Escape character is '^]'.
220 omta06.westchester.pa.mail.comcast.net comcast ESMTP server ready
quit
221 2.0.0 omta06.westchester.pa.mail.comcast.net comcast closing connection
Connection closed by foreign host.
 

So perhaps that might be a solution for dczar1. That is assuming that local lack of SSL support is the dczar1's problem (as is the case with Microsoft's SMTP service) as opposed to the inability to change the outbound port, or to use authentication.

--
A well-regulated militia, being necessary to the security of a free State, the right of the people to keep and bear arms shall not be infringed.

When governments fear people, there is liberty. When the people fear the government, there is tyranny.


graysonf
Premium,MVM
join:1999-07-16
Fort Lauderdale, FL
kudos:2

I never said anything about port 25 not being blocked on smtp.comcast.net via IPv6. But I will say that Comcast is not blocking port 25 via IPv6 elsewhere.

Stunnel can be used to work around most client limitations regarding destination ports and lack of SSL.



NetFixer
Snarl For The Camera Please
Premium
join:2004-06-24
The Boro
Reviews:
·Cingular Wireless
·Comcast Business..
·Vonage

said by graysonf:

I never said anything about port 25 not being blocked on smtp.comcast.net via IPv6. But I will say that Comcast is not blocking port 25 via IPv6 elsewhere.

Port 25 is not being "blocked" per se for use with smtp.comcast.net (IPv4 or IPv6), the server itself is simply refusing to allow an active session on port 25. However, many (and likely soon all) Comcast residential users do have a universal IPv4 port 25 block (and I suspect that eventually Comcast security will notice the IPv6 oversight).

said by graysonf:

Stunnel can be used to work around most client limitations regarding destination ports and lack of SSL.

Yes, stunnel (and other local proxy solutions) can be used to get around a client config limitation problem. Recent versions of Eudora do support SSL, but dczar1 could not get that to work, so I suspect that setting up an stunnel proxy would be equally problematic. Are you volunteering to set that up for dczar1?
--
A well-regulated militia, being necessary to the security of a free State, the right of the people to keep and bear arms shall not be infringed.

When governments fear people, there is liberty. When the people fear the government, there is tyranny.


NetFixer
Snarl For The Camera Please
Premium
join:2004-06-24
The Boro
Reviews:
·Cingular Wireless
·Comcast Business..
·Vonage
reply to dczar1

said by dczar1:

I'm having similar problem in Chicago. I used Eudora specifying incoming and outgoing mail servers and ports. Worked fine up until around 10 days ago. Now, I get mail from my email account I've had since around 1998 or so, but I can't send via smtp.comcast.net and I can't ping that address with a network utility.

rebooted the modem.
rebooted my router.
reloaded three different email clients and set up

can't send anything but I get mail from my third party provider and before you ask, I really, Really, REALLY don't,can't switch to a different email address for business reasons as well as so many places that contact me at my email address.

I've set things up the way their techs tell me on phone and still wont' work using port 465 etc. is there a way around this compound I'm locked in?

Recent versions of Eudora do support SSL on port 465, but just changing the port is not sufficient. You will need to make sure that SSL is selected, and you you will also need to setup the outbound server settings to use authentication (the same way that you do for incoming email). Another configuration option for outbound mail would be to use port 587 for the outbound server. Port 587 does not require SSL in case you are using an older version of Eudora that does not support SSL, but you will still need to use authentication.
--
A well-regulated militia, being necessary to the security of a free State, the right of the people to keep and bear arms shall not be infringed.

When governments fear people, there is liberty. When the people fear the government, there is tyranny.

dczar1

join:2013-04-09
Oak Park, IL
reply to graysonf

Doesn't work for me as I've tried that on three email clients.


dczar1

join:2013-04-09
Oak Park, IL
reply to NetFixer

I've tried that too and it hasn't worked on 587 or 465.



NetFixer
Snarl For The Camera Please
Premium
join:2004-06-24
The Boro
Reviews:
·Cingular Wireless
·Comcast Business..
·Vonage
reply to dczar1

said by dczar1:

Doesn't work for me as I've tried that on three email clients.

If you open up a command prompt window (or a terminal session depending on the OS) and do a "telnet smtp.comcast.com 587" what kind of response to you get (if any)?

I am reproducing below the test session that I did for my earlier post here to show you an example of what you should get back. If you want to troubleshoot this, I first need to know if you have a connection problem or an authentication problem (just saying that "it doesn't work" isn't much help for troubleshooting).

webhost:/ # telnet smtp.comcast.net 587
Trying 2001:558:fe14:70::30...
Connected to smtp.comcast.net.
Escape character is '^]'.
220 omta06.westchester.pa.mail.comcast.net comcast ESMTP server ready
quit
221 2.0.0 omta06.westchester.pa.mail.comcast.net comcast closing connection
Connection closed by foreign host.
 


--
A well-regulated militia, being necessary to the security of a free State, the right of the people to keep and bear arms shall not be infringed.

When governments fear people, there is liberty. When the people fear the government, there is tyranny.

dczar1

join:2013-04-09
Oak Park, IL
reply to NetFixer

said by NetFixer:

said by graysonf:

But the IPv6 address for smtp.comcast.net is pingable via ICMP

But the IPv6 smtp.comcast.net server still does not allow active sessions on port 25 (even on a business class connection where outbound port 25 is not blocked):

webhost:/ # telnet smtp.comcast.net 25
Trying 2001:558:fe14:70::30...
Connected to smtp.comcast.net.
Escape character is '^]'.
554 omta15.westchester.pa.mail.comcast.net comcast Port 25 not allowed
 - http://customer.comcast.com/help-and-support/internet/email-client-programs-with-xfinity-email/
Connection closed by foreign host.
 


OTOH, it does still accept authenticated port 587 sessions (even without TLS):

webhost:/ # telnet smtp.comcast.net 587
Trying 2001:558:fe14:70::30...
Connected to smtp.comcast.net.
Escape character is '^]'.
220 omta06.westchester.pa.mail.comcast.net comcast ESMTP server ready
quit
221 2.0.0 omta06.westchester.pa.mail.comcast.net comcast closing connection
Connection closed by foreign host.
 

So perhaps that might be a solution for dczar1. That is assuming that local lack of SSL support is the dczar1's problem (as is the case with Microsoft's SMTP service) as opposed to the inability to change the outbound port, or to use authentication.

I have SSL support in all three email clients, Eudora, Thunderbird and Mail. Ccast says it's because the domain of my incoming mail is not from ccast so I can't then send mail.

Seems like a devious plan to put third-party ISP's out of biz...I've had my email address for some 22 years. How many sites have I registered with that have it, clients and whomever else? I literally can't switch as comcast would like me to.


NetFixer
Snarl For The Camera Please
Premium
join:2004-06-24
The Boro
Reviews:
·Cingular Wireless
·Comcast Business..
·Vonage

1 edit

said by dczar1:

I have SSL support in all three email clients, Eudora, Thunderbird and Mail. Ccast says it's because the domain of my incoming mail is not from ccast so I can't then send mail.

Seems like a devious plan to put third-party ISP's out of biz...I've had my email address for some 22 years. How many sites have I registered with that have it, clients and whomever else? I literally can't switch as comcast would like me to.

If and/or when you decide that you want help troubleshooting your problem and are willing to cooperate with the troubleshooting process instead of just ranting, perhaps you might get some help.

FWIW, I did a test for the OP in this thread: »Re: Comcast SMTP whoa's that did exactly what you are describing (sending email from two different domains using smtp.comcast.net on port 587, and Comcast did not reject my email (as the attached received email source illustrates).

As for me, I'm done with this thread since you obviously don't want my help. Good luck with solving your problem.
--
A well-regulated militia, being necessary to the security of a free State, the right of the people to keep and bear arms shall not be infringed.

When governments fear people, there is liberty. When the people fear the government, there is tyranny.


graysonf
Premium,MVM
join:1999-07-16
Fort Lauderdale, FL
kudos:2
reply to NetFixer

I'd venture to say that if it doesn't work for him he's doing something wrong. The most common mistake is to use username/password encryption. This will not work.



graysonf
Premium,MVM
join:1999-07-16
Fort Lauderdale, FL
kudos:2
reply to dczar1

said by dczar1:

Doesn't work for me as I've tried that on three email clients.

Paste in or fully describe your configuration screen.

dczar1

join:2013-04-09
Oak Park, IL
reply to NetFixer

said by NetFixer:

said by dczar1:

Doesn't work for me as I've tried that on three email clients.

If you open up a command prompt window (or a terminal session depending on the OS) and do a "telnet smtp.comcast.com 587" what kind of response to you get (if any)?

I am reproducing below the test session that I did for my earlier post here to show you an example of what you should get back. If you want to troubleshoot this, I first need to know if you have a connection problem or an authentication problem (just saying that "it doesn't work" isn't much help for troubleshooting).

webhost:/ # telnet smtp.comcast.net 587
Trying 2001:558:fe14:70::30...
Connected to smtp.comcast.net.
Escape character is '^]'.
220 omta06.westchester.pa.mail.comcast.net comcast ESMTP server ready
quit
221 2.0.0 omta06.westchester.pa.mail.comcast.net comcast closing connection
Connection closed by foreign host.
 


"telnet smtp.comcast.com 587
smtp.comcast.com: nodename nor servname provided, or not known"

dczar1

join:2013-04-09
Oak Park, IL

telnet smtp.comcast.com 587
smtp.comcast.com: nodename nor servname provided, or not known


dczar1

join:2013-04-09
Oak Park, IL
reply to NetFixer

said by NetFixer:

said by dczar1:

I have SSL support in all three email clients, Eudora, Thunderbird and Mail. Ccast says it's because the domain of my incoming mail is not from ccast so I can't then send mail.

Seems like a devious plan to put third-party ISP's out of biz...I've had my email address for some 22 years. How many sites have I registered with that have it, clients and whomever else? I literally can't switch as comcast would like me to.

If and/or when you decide that you want help troubleshooting your problem and are willing to cooperate with the troubleshooting process instead of just ranting, perhaps you might get some help.

FWIW, I did a test for the OP in this thread: »Re: Comcast SMTP whoa's that did exactly what you are describing (sending email from two different domains using smtp.comcast.net on port 587, and Comcast did not reject my email (as the attached received email source illustrates).

As for me, I'm done with this thread since you obviously don't want my help. Good luck with solving your problem.

Gosh, and here I thought I explained quite clearly what I had done and you get snarky. How positively nice is that?


graysonf
Premium,MVM
join:1999-07-16
Fort Lauderdale, FL
kudos:2
reply to dczar1

said by dczar1:

telnet smtp.comcast.com 587
smtp.comcast.com: nodename nor servname provided, or not known

WRONG.

It's smtp.comcast.net


NormanS
I gave her time to steal my mind away
Premium,MVM
join:2001-02-14
San Jose, CA
kudos:11
Reviews:
·SONIC.NET
·Pacific Bell - SBC

1 edit
reply to dczar1

said by dczar1:

Seems like a devious plan to put third-party ISP's out of biz...I've had my email address for some 22 years. How many sites have I registered with that have it, clients and whomever else? I literally can't switch as comcast would like me to.

Can you not use a 'comcast.net' email address solely for the authentication? SBC put their customers through this same wringer ten years ago. What I did was to configure my client to use '******@pacbell.net' for authentication, but '********@aosake.net' for the "From:" address. Nobody ever saw the 'pacbell.net' address, just the 'aosake.net' address.

It works the same with my new ISP:

From: and Auth difference.


Addendum:

As an example, here are headers (my server is temporarily offline, so I used another account):
x-store-info:J++/JTCzmObr++wNraA4Pa4f5Xd6uens/GgAwQp04qJrhQ4X0uoZBxy/dkHL
    xXCBwcjWNRRSpd5wSmJIm7sPnF90XvpI8tgDdQqFgQ94hQrwykr8H4IG9Nepp4wYI/bbM9fSYt1l+Dw=
Authentication-Results: hotmail.com; spf=none (sender IP is 64.142.19.5)
    smtp.mailfrom=**********@netscape.net; dkim=none header.d=netscape.net; x-hmca=none
X-SID-PRA: **********@netscape.net
X-AUTH-Result: NONE
X-SID-Result: NONE
X-Message-Status: n:n
X-Message-Delivery: Vj0xLjE7dXM9MDtsPTE7YT0xO0Q9MTtHRD0xO1NDTD0w
X-Message-Info: aKlYzGSc+LngSIEN9nC7GRaVlXLN7zbKfIbKa3LQPpvRklgyf+bf1scoommzxBTAkAMxYwudjV
    0qga6n0nCDcfOtPllc5DBdQN2m8xxSK/yMpJH5Hzv/zxqZOrK/sk+sVaTixt5quAZd91kfuAq5n0OMMoo45RWa
Received: from b.mail.sonic.net ([64.142.19.5])
         by COL0-MC4-F26.Col0.hotmail.com with Microsoft SMTPSVC(6.0.3790.4900);
 Wed, 10 Apr 2013 22:50:16 -0700
Received: from akari.akari.aosake.net (reki.aosake.net [173.228.7.217])
(authenticated bits=0)
by b.mail.sonic.net (8.13.8.Beta0-Sonic/8.13.7) with ESMTP id r3B5oFIN030506
(version=TLSv1/SSLv3 cipher=AES256-SHA bits=256 verify=NO)
for <**********@hotmail.com>; Wed, 10 Apr 2013 22:50:15 -0700
Content-Type: text/plain; charset=iso-8859-15; format=flowed; delsp=yes
Date: Wed, 10 Apr 2013 22:50:14 -0700
To: "**********@hotmail.com" <**********@hotmail.com>
Subject: [TEST] SMTP Server
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
From: "NormanS" <**********@netscape.net>
Message-ID: <op.wvc3tza65ghexu@akari.akari.aosake.net>
User-Agent: Opera Mail/12.15 (Win64)
Return-Path: **********@netscape.net
X-OriginalArrivalTime: 11 Apr 2013 05:50:16.0527 (UTC) FILETIME=[714E85F0:01CE3678]
 
Lines 15 through 19 show my ISP (Sonic.net) message submission server accepting email with authentication.

Line 26 shows the From: address as a Netscape domain.

No line shows my Sonic.net email address, though it was needed to authenticate to the server.

This is pretty much what NetFixer See Profile showed in his headers. When I was with AT&T, this still worked the same; different servers, same results.

Comcast expects you to authenticate to their message submission server with a Comcast UserID; they don't require From: to be a Comcast email address.

--
Norman
~Oh Lord, why have you come
~To Konnyu, with the Lion and the Drum