dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
963
share rss forum feed

Dagwood01

join:2007-10-22
Oakville, ON

1 edit

[Equipment] Can't Register To My Providers After DSL Upgrade

I recently upgraded to 25/10 DSL service with Bell which included a Sagemcom 2864 modem. Prior to that I had DSL 6/.8 service and my own modem. I'm also using am Asus RT-N66U router.

Prior to the upgrade everything was working fine. I have an OBI100 and service with Freephoneline.ca and voip.ms. Ever since the upgrade my OBI100 cannot contact either provider to register the device. I'm wondering if it's got anything to do with the new modem.

Any ideas?

Edit - fixed it by changing my X_UserAgent ports from the default 5060 for SP1 and 5061 for SP2.


Dan_voip

join:2007-01-03
Saint-Hubert, QC
kudos:4
Reviews:
·TekSavvy DSL

said by Dagwood01:

Edit - fixed it by changing my X_UserAgent ports from the default 5060 for SP1 and 5061 for SP2.

I wonder what values did you have before, however it's weird not working with something else.
If you want to go back to non standard ports something to try will be to put PPPoE credentials in your Asus router and make sure your Obi is connected behind it.
That way Sagemcom will be used just as a modem, the routing part will be done by your Asus router.

Dagwood01

join:2007-10-22
Oakville, ON

I've only had my OBI100 for a few weeks. One of the first things I did was to change the ports from 5060 and 5061 to other higher random numbers as it's my understanding that will avoid SIP scanners. I could be totally wrong on this. I never did try 5060 and 5061 in my previous 6/.8 DSL setup so I don't know if they worked. Somehow my changes went back to the defaults around the same time I upgraded my DSL and started using the Sagemcom so I suspected it was the culprit. With the OBI not registering I tried a few things with the Sagemcom such as disabling DHCP and changing the PPoE credentials to test@test to purposely prevent it from being able to log on and instead using the credentials from my router. None of that made any difference but as soon as I changed the port numbers in the OBI it worked fine.


decx
Premium
join:2002-06-07
Vancouver, BC
reply to Dagwood01

Note that the N66U firmware has a built-in SIP ALG that kind of locks up after working for awhile and stops the client from registering. You can test this out by using your original port of 5060 and rebooting the N66U to see if the client can register again.


Dagwood01

join:2007-10-22
Oakville, ON

said by decx:

Note that the N66U firmware has a built-in SIP ALG that kind of locks up after working for awhile and stops the client from registering. You can test this out by using your original port of 5060 and rebooting the N66U to see if the client can register again.

I do recall reading about that but I couldn't figure out how to disable that as it's not part of the web interface, that I could see anyway. I did see comments about using terminal for it, but didn't get that far. At some point I will try setting the ports back to normal and rebooting the router to see if it works, out of curiosity.

decx
Premium
join:2002-06-07
Vancouver, BC

Unfortunately it's not disable from the OEM firmware (maybe on the more recent ones which I haven't tied but check the settings under Firewall > General).

You can disable it if you run a recent version of Merlin's custom Asuswrt-Merlin firmware by unchecking Firewall > General > "Enable Sip Helper".

A third option is to run a Tomato variant for the N66u which should also have an option to disable the SIP ALG.

Edit: I've just recently started testing the latest Merlin firmware with the SIP ALG disabled to see if it really does solve the problem as the older versions pre 2013 had the same issue as the OEM Asus firmware (on which Asuswrt-Merlin is based).


RonR

join:2003-10-10
Ash Flat, AR
kudos:5

said by decx:

A third option is to run a Tomato variant for the N66u which should also have an option to disable the SIP ALG.

FWIW, I find the SIP Tracking / NAT Helper in Toastman's builds very beneficial. I have multiple OBi's running behind it on a Netgear WNR3500L and operation is very stable with the SIP Tracking / NAT Helper enabled. With it disabled, OBi to OBi SIP calls on the same LAN fail to negotiate proper RTP connections.

Dagwood01

join:2007-10-22
Oakville, ON
reply to Dagwood01

Is setting "Enable SIP Helper" to no in Merlin the same as enabling SIP Tracking / NAT Helper in Tomato? I'm a bit confused as it would seem that decx might be suggesting the opposite of RonR, but perhaps it's just the different terminology in the 2 firmwares.


toro

join:2006-01-27
Scarborough, ON
kudos:6
Reviews:
·Rogers Hi-Speed
·Bell Sympatico
reply to Dagwood01

How did you configure the WAN connection of your Asus RT-N66U ?
If you set it up for DHCP, then you are doing double NAT because the Sagemcom also has a built in router.
You can set it to PPPoE (the Sagemcom allows PPPoE passthrough) to get a routable IP address and avoid the double NAT.
--
Providers (through asterisk): voip.ms, freephoneline, smartcall.ro, ipcomms, callcentric. Hardware: Vonage VDV21, Moto VT2x42, Linksys SPA series, Grandstream HT series, Panasonic KX-TGP5x0
»www.voipfan.net


decx
Premium
join:2002-06-07
Vancouver, BC
reply to Dagwood01

said by Dagwood01:

Is setting "Enable SIP Helper" to no in Merlin the same as enabling SIP Tracking / NAT Helper in Tomato? I'm a bit confused as it would seem that decx might be suggesting the opposite of RonR, but perhaps it's just the different terminology in the 2 firmwares.

No, it's the exact opposite. Since Asus and Merlin has the SIP ALG enabled by default, you only really have one other option to try anyways... For most cases where users have problems with connectivity relating to SIP and there is a SIP ALG involved, I (and quite a few others in this forum) would recommend trying again with the ALG disabled as ALGs have often been known to cause more problems than they solve.

Dagwood01

join:2007-10-22
Oakville, ON
reply to toro

said by toro:

How did you configure the WAN connection of your Asus RT-N66U ?
If you set it up for DHCP, then you are doing double NAT because the Sagemcom also has a built in router.
You can set it to PPPoE (the Sagemcom allows PPPoE passthrough) to get a routable IP address and avoid the double NAT.

I have DHCP turned off on the Sagemcom and have the user ID set to test@test which I believe prevents a PPoE connection initiated by the Sagemcom. My N66U has DHCP turned on and the WAN is set for PPoE. Are these the ideal settings? I don't fully understand a lot of this.

decx
Premium
join:2002-06-07
Vancouver, BC

Yep those settings would work as you're using PPPoE pass through on the Sagemcom which is essentially making it act as a bridge.