dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
907
share rss forum feed


miakica

join:2009-11-10

[WIN7] Very interesting USB3 problem...

I have two USB3 drives, 32 GB Corsair Survivor and 32GB Corsair Flash Voyager. I also have four computers running Windows 7. two desktops and two laptops.

My USB flash drives won't work in one of the desktops in USB3 mode.
I plug them in the front panel or rear panel, and I get the sound that they are inserted, but they don't show in my computer, or in computer management. If I plug them in USB2 ports, they are immediately recognized, and they show in both, my computer and disk management.

Both USB drives work well in USB3 mode on other computers, just not on this one. I even tried clean reinstall of Windows 7 on this computer, but it still doesn't work

But, the interesting thing is that all of the USB2 flash drives that I have (a whole bunch of them), work well in USB3 ports in the same computer that USB3 flash drives don't work...
So, in short...

I insert USB3 flash drive in USB3 port, and it doesn't work...

I insert USB3 flash drive in USB2 port, and it works...

I insert USB2 flash drive in USB3 or USB2 port, and it works...

It's driving me nuts...

MoBo - Asus SABERTOOTH Z77
CPU - Intel i7 3770K
RAM - 16GB Corsair Vengeance (4x4GB)
GPU - ATI 7770
HD - OCZ RevoDrive 3 X2 - PCI Express

Anybody has any ideas?

Thanks



miakica

join:2009-11-10

And I forgot to mention...

I also have external USB3 3.5 enclosure (Vantec NexStar CX NST-310S3-BK) with a 2TB drive, and it works perfectly in USB3 port



norwegian
Premium
join:2005-02-15
Outback

»www.asus.com/Motherboards/SABERT···ications

quote:
Intel® Z77 chipset :
4 x USB 3.0 port(s) (2 at back panel, blue, 2 at mid-board)
ASMedia® ASM1042 controller :
2 x USB 3.0 port(s) (2 at back panel, blue)
Intel® Z77 chipset :
10 x USB 2.0 port(s) (4 at back panel, black, 6 at mid-board)
Have you tried all ports for usb, maybe the ASMedia drivers work and the Z77 don't, or vice-versa?
Have you tried uninstalling the usb ports from device manager and a reboot to see if it goes away or works for a day or 2 before the bug is reproduced?

I also see there is a known USB issue that has been reviewed in bios updates, which mentions compatibility issues.

»www.asus.com/Motherboards/SABERT···nload_30
quote:
Version 1403
Description SABERTOOTH Z77 BIOS 1403
1.Improve compatibility with Windows 8 OS.
2.Improve system stability.
3.Enhance compatibility with some USB devices.
4. Fixed Nvidia GTX 680 hang when running with UEFI driver.
5.Support new CPUs.
--
The only thing necessary for the triumph of evil is for good men to do nothing - Edmund Burke



miakica

join:2009-11-10

said by norwegian:

»www.asus.com/Motherboards/SABERT···ications

quote:
Intel® Z77 chipset :
4 x USB 3.0 port(s) (2 at back panel, blue, 2 at mid-board)
ASMedia® ASM1042 controller :
2 x USB 3.0 port(s) (2 at back panel, blue)
Intel® Z77 chipset :
10 x USB 2.0 port(s) (4 at back panel, black, 6 at mid-board)
Have you tried all ports for usb, maybe the ASMedia drivers work and the Z77 don't, or vice-versa?
Have you tried uninstalling the usb ports from device manager and a reboot to see if it goes away or works for a day or 2 before the bug is reproduced?

I also see there is a known USB issue that has been reviewed in bios updates, which mentions compatibility issues.

»www.asus.com/Motherboards/SABERT···nload_30
quote:
Version 1403
Description SABERTOOTH Z77 BIOS 1403
1.Improve compatibility with Windows 8 OS.
2.Improve system stability.
3.Enhance compatibility with some USB devices.
4. Fixed Nvidia GTX 680 hang when running with UEFI driver.
5.Support new CPUs.

I tried all the ports, and I have the newest BIOS


dib22

join:2002-01-27
Kansas City, MO
reply to miakica

Do you have the USB 3 driver installed?

Intel USB 3.0 Driver V 1.0.5.235 for Windows Win7 32bit & Win7 64bit---(WHQL).

»www.asus.com/Motherboards/SABERT···nload_30



miakica

join:2009-11-10

1 recommendation

said by dib22:

Do you have the USB 3 driver installed?

Intel USB 3.0 Driver V 1.0.5.235 for Windows Win7 32bit & Win7 64bit---(WHQL).

»www.asus.com/Motherboards/SABERT···nload_30

Yup...

All of the new drivers from Asus sie


Octavean
Premium,MVM
join:2001-03-31
New York, NY
kudos:1

What BIOS settings do you have available for the USB 3.0 ports in question? Does this happen all the time or after resuming from sleep? A Z77 board such as this would have native USB 3.0 ports of the Intel chipset and 3rd part USB 3.0 ports do all USB 3.0 ports on the board have this issue?


Gem
Premium
join:2005-09-10
kudos:4
Reviews:
·CableOne

1 recommendation

reply to miakica

You need to have BOTH USB3.0 drivers installed on Z77 mobos - Intel AND ASMedia USB3.0.

You also need to double check your bios to be sure that both types of USB3.0 ports are enabled. Both the normal USB3.0 ports and the ASMedia 3.0 ports.

I had the same problem as you do with my Z77 mobo until taking the two steps described above. See if that works for you. Good luck.



Cartel
Premium
join:2006-09-13
Chilliwack, BC
kudos:2

try enable/disable 3.0 legacy support in bios.



miakica

join:2009-11-10

1 recommendation

reply to Gem

said by Gem:

You need to have BOTH USB3.0 drivers installed on Z77 mobos - Intel AND ASMedia USB3.0.

You also need to double check your bios to be sure that both types of USB3.0 ports are enabled. Both the normal USB3.0 ports and the ASMedia 3.0 ports.

I had the same problem as you do with my Z77 mobo until taking the two steps described above. See if that works for you. Good luck.

This did it...

ASMedia wasn't enabled in BIOS.

Many thanks, sir

Gem
Premium
join:2005-09-10
kudos:4

You are welcome.