Tell me more x
, there is a new speed test available. Give it a try, leave feedback!
dslreports logo
 
    All Forums Hot Topics Gallery
spc

spacer

Search Topic:
uniqs
2146
share rss forum feed


oliver

@221.120.125.x

CISCO Port Forwarding

interface GigabitEthernet0/0
ip address x.x.x.36 255.255.255.248
ip nat outside
ip virtual-reassembly in
no ip route-cache
duplex auto
speed auto
no cdp enable
!
interface GigabitEthernet0/1
ip address 192.168.1.3 255.255.255.0
ip nat inside
ip virtual-reassembly in
no ip route-cache
duplex auto
speed auto
no cdp enable

ip nat inside source static tcp 192.168.1.252 22 x.x.x.36 6922 extendable
ip route 0.0.0.0 0.0.0.0 x.x.x.33

access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit any

Anything wrong with my config? port forwarding to my ssh wont work. Im using CISCO 1900 Series.

Thank you..

cramer
Premium
join:2007-04-10
Raleigh, NC
kudos:9
1) you have "route-cache" disabled. All packets will be process switched. You have your router configured to run at about 1/10,000th it's possible speed.
2) unless you fat fingered the "x.x.x" parts, it looks fine.
3) if 1.252 doesn't have 1.3 as it's default gateway, this will not work.

HELLFIRE
Premium
join:2009-11-25
kudos:21
reply to oliver
...since you don't have any ACL applied inbound on what I'm guessing is an internet edge router, don't
see any issue. Otherwise I'd fix the route-cache as cramer See Profile suggests.

Regards


oliver

@221.120.125.x
I already enabled the route-cache and made my ssh server point to 1.3 gateway. It still won't work. Here is my new config

interface GigabitEthernet0/0
ip address 221.120.125.36 255.255.255.248
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
no mop enabled
!
interface GigabitEthernet0/1
ip address 192.168.1.3 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
no mop enabled
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source static tcp 192.168.1.210 22 221.120.125.36 6922 extendable
ip route 0.0.0.0 0.0.0.0 221.120.125.33

I can ping both public and private ip from my ssh server..


RyanG1
Premium
join:2002-02-10
San Antonio, TX
kudos:1
reply to oliver
change:
ip nat inside source static tcp 192.168.1.210 22 221.120.125.36 6922 extendable

to:
ip nat inside source static tcp 192.168.1.210 22 interface GigabitEthernet0/0 6922

you would think the original way would work but ive seen issues with it in the past.

-- EDIT --

Also, i just noticed...you do not have the PAT statement in there for traffic... you have the acl for it... but you are missing:

ip nat inside source list 1 interface GigabitEthernet0/0 overload

so you may not need the first command i referenced but since you are using the interface IP, its best to use the interface command.

Ryan
--
Human beings, who are almost unique in having the ability to learn from the experience of others, are also remarkable for their apparent disinclination to do so. -Douglas Adams

HELLFIRE
Premium
join:2009-11-25
kudos:21
reply to oliver
said by RyanG1:

Also, i just noticed...you do not have the PAT statement in there for traffic... you have the acl for it... but you are missing:

...Good catch on that one [user-RyanG1]... unless OP neglected to post that originally.

Regards