dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
1218
share rss forum feed

batsona
Maryland

join:2004-04-17
Ellicott City, MD
Reviews:
·Vonage
·Verizon FiOS

[Exchange] Outlook2010 disobeying me...


My HTTPS settings...
The last time I had this issue, I was using Outlook2007. Now I've just 'inherited' the problem again after many months of successful operation with Outlook2010. Outlook uses some sort of fuzzy logic to determine what a 'fast' and 'slow' network is. There are two ways that Outlook can connect:

TCP port 135 (To an AD server, or the exchng srvr itself)?

HTTPS to the proxy specified.

I used my win7 laptop connected to a docking station, and a LAN connection attached to it. --This works like the wind.... no prob for many months. This morning, I attached to a different wireless network at work (still un-fettered access to all campus resources). This is the only thing that changed. NOW.. when i connect to the Exchng srvr, I noticed that "netstat -an" tells me that I'm using TCP/135 to connect to the server, and not HTTPS. NOTE: TCP/135 is not open, not even internally; only HTTPS can be used. Use of 135 will guarantee a failure.

Question: (I'm OK with doing this in the registry, if Outlook is going to be an a$$ about this...) how do I convince Outlook2010 ONLY ever connect using HTTPS via proxy, and never [what it calls] "TCP/IP" (TCP/135)? I've looked on the Internet, and 6 out of 10 complaints end in, "yea, I have that problem too", then there's no resolution provided. Its not good when the "IT Guy can't get his email working..."

techsup1983

join:2013-03-23

Hello. Your settings don't seem quite right. I would start with entering almost the owa address like »email.company.com
The next settings would most likely read something like msstd:email.company.com
and for proxy authentication set this to basic.


batsona
Maryland

join:2004-04-17
Ellicott City, MD
Reviews:
·Vonage
·Verizon FiOS

I should have mentioned that I wiped out some of the hostnames in my screenshot, to avoid disclosing the internal structure of my workplace. Rest assured that the settings in the box 'used to work' just fine. I moved to a wireless network that I'm not usually on, and now i can't connect anymore. Outlook wants TCP/IP, instead of HTTP. Does anyone know how to use registry to trick Outlook into only ever using HTTP, and never 'auto-detecting' whether it's on a slow or fast network?



Micha3615

join:2004-08-21
Mississauga, ON
reply to batsona

If you connect to a different internet connection, for instance from home. Do you get the same result?

Is it everyone that gets the same issue or only a selected few?


batsona
Maryland

join:2004-04-17
Ellicott City, MD
Reviews:
·Vonage
·Verizon FiOS

It used to work on my home internet connection w/ no problem. the last time I tried it, since all this started, it actually did NOT work. This is actually just affecting me.

Something dynamic or 'intelligent' is happening to my laptop where it's trying to detect how to connect, and it's learned something 'wrong' somehow.

I'm not able to get back to my docking station (where it does work) since I'm in training this week and away from my normal work-area.

Did I mention that through my career, I'm famous for coming up with problems that a.)No one's ever seen before or b.)no one can fix....



Micha3615

join:2004-08-21
Mississauga, ON
reply to batsona

What do you see when you start outlook with the rpcdiag?

I'm guessing you have tried to create a new outlook profile?


batsona
Maryland

join:2004-04-17
Ellicott City, MD
Reviews:
·Vonage
·Verizon FiOS

I didn't want to delete / re-add my profile, because I thought I'd lose my auto-complete list (but then again, you can back that up...). i didn't try creating a new profile.

Does rpcdiag come with a resource kit? I've never used that before (or needed it)....? or is 'rpcdiag' a switch?



Micha3615

join:2004-08-21
Mississauga, ON

For rpcdiag / just open the run and type outlook /rpcdiag

This will show you how it's trying to connect. As for the profile, in outlook 2010 it's no longer using the .nk2 file. It's now saved as a Stream_autocomplete file.

But you can just try to create a new outlook/mail profile - not the windows profile. Keep your old mail profile just in case.

Also for the auto complete, you can always use NK2edit to save the autocomplete. Located here: C:\users\%username%\AppData\local\Microsoft\Outlook\RoamCache


batsona
Maryland

join:2004-04-17
Ellicott City, MD
Reviews:
·Vonage
·Verizon FiOS

Click for full size
Output of rpcdiag....
Attached is the output of RPCdiag. I had to blur out the hostnames. I can tell you that both of the hostnames were the name of our Exchange server. Neither was the name of the HTTPS proxy that Outlook is configured to use... Clients cannot access the Exchng srvr directly; everyone must proxy. --At least this more quantitatively demonstrates my issue...


Micha3615

join:2004-08-21
Mississauga, ON
reply to batsona

Ok,

I did a test on my lab laptop and for me it does show the server name but in the conn section it does show https.

Have you tried doing the same settings on a different laptop to see if rpc does work. This would help to rule out the laptop as the issue.

Here we had the same problem a few weeks ago, some user were affected by this and others not.

We had to reboot one of our exchange servers to fix this for our client.

But try a different laptop first and then we if it points to the issue.


batsona
Maryland

join:2004-04-17
Ellicott City, MD
Reviews:
·Vonage
·Verizon FiOS
reply to batsona

OP here... Other notes & things I tried today...

1.) Unchecked "only connect to proxy servers that have this pincipal name in their certificate:" No change.

2.) Tried creating a new profile using the wizzard method. Looked at netstat-an during. It proceeded to try to go out and connect to each of our Exchng servers directly on TCP/443. All failed, since no ports are open directly to the Exchng srvrs.

3.) Tried going into that new profile & manually set the settings. No change -- still uses TCP/135 to my Exchng srvr.

4.) I'm the only laptop having this problem. I had not tried to set up my profile on someone else's laptop.

5.) The closest I came to success, was when I unchecked "use SSL". outlook actually tried to connect to the proper proxy IP but with TCP/80, so it failed...

Are we sure there's no hack where you go into the registry somewhere and manually force Outlook to only connect a certain way? It's trying to auto-detect what it should do, and it's not making the right decision. No patches had been applied & no java-updates etc etc had been done. the only thing that set this off, was me trying to connect to Exchng using Outlook, over a wireless network on campus that I don't usually use. This wireless network is actually the more secure of the 2 that are offered, so it's not like I connected to an unprotected network & filled up with viruses...


batsona
Maryland

join:2004-04-17
Ellicott City, MD
Reviews:
·Vonage
·Verizon FiOS

OP here --- even more info now.. and we're getting CLOSER...

I came across this misc article; it describes in closer detail what the issue is:

»www.fixkar.com/articles/kb/1147/

--although not written by Microsoft -- it says that the connection state is determined by Outlook (Fast network vs. slow network), and indicates what connection type is selected based on each. It's this auto-detect that's not working.

also, in looking at the associated MS articles, I found out how to verify that RCP-over-HTTPS is working:

browse to »myOWAserver.company.com/rpc/rpcproxy.dll Provide credentials. As long as you get a blank screen, with no cert errors then this means that the proxy server you've attached to is valid, and will work with HTTPS. "netstat -an' will show TCP/443 open to the IP of the proxy.

I did this, and it works fine - I have TCP/443 authenticated to the proxy just fine. So, we know that RPC-over-HTTPS is working on the server side, and my credentials work. So now we're more focused on figuring out why Outlook refuses to properly detect the proper "lan speed"... -and what happened to this 'decision' when I connected to that wireless network.

PS.... I'm back on my wired LAN connection in my office, and Outlook still insists on using TCP/135 to the Exchng srvr. Won't talk to the proxy at all.


batsona
Maryland

join:2004-04-17
Ellicott City, MD
Reviews:
·Vonage
·Verizon FiOS
reply to Micha3615

The quote below is from the article at »www.fixkar.com/articles/kb/1147/. Does anyone know what input goes into the decision that Outlook makes, regarding whether to attach via MAPI, or RPC-over-HTTPS? I've been on OWA-only now for a week.

_____________________________________________________
The
decision to switch from LAN to RPC over HTTP is made by outlook based on the speed of the
link that you select in outlook.
Slow Link - RPC over HTTP
Fast Link - RPC (LAN)

Switching happens automatically, and is decided by Outlook.
______________________________________________________


batsona
Maryland

join:2004-04-17
Ellicott City, MD
Reviews:
·Vonage
·Verizon FiOS

Get your sticks and stones ready!!!!!!!!!!

In order to speed up my access, I resolved all the hosts needed for me to attach to Exchng, and put them in my hosts file. Just recently there was an Exchange server upgrade, and apparently new/different front servers were introduced. (raise your stones...)

I commented out all my Exchange stuff in my HOSTS file, and BOOM! it attached. I noticed right away that the IP I was resolving to, for the HTTPS proxy was different. Outlook is happy & healthy now.

Case closed. Using HOSTS for resolution might speed things up, but it will BITE you eventually!