dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
1395
share rss forum feed


bobx

join:2001-02-11
Novato, CA

[Connection Sharing] Ubuntu 12.04 as a gateway/router problems

I am trying to set up a Ubuntu 12.04 box to act as a router for my other computers. I have tried several procedures that I found on the net. The best I can do is the following procedure from »www.gentoo.org/doc/en/home-router-howto.xml

I have no problems accessing the net from the Ubuntu computer. However the other computers can only access certain web sites. They can get to google.com but not dslreports.com. They start to load ebay.com but stall. I am guessing that there are items on some websites that point to other web addresses and these are the cause of the pages not loading.

Here is the iptables I used:

iptables -F
iptables -t nat -F
iptables -P INPUT ACCEPT
iptables -P OUTPUT ACCEPT
iptables -P FORWARD DROP
iptables -I INPUT 1 -i eth0 -j ACCEPT
iptables -I INPUT 1 -i lo -j ACCEPT
iptables -A INPUT -p UDP --dport bootps ! -i eth0 -j REJECT
iptables -A INPUT -p UDP --dport domain ! -i eth0 -j REJECT
iptables -A INPUT -p TCP --dport ssh -i ppp0 -j ACCEPT
iptables -A INPUT -p TCP ! -i eth0 -d 0/0 --dport 0:1023 -j DROP
iptables -A INPUT -p UDP ! -i eth0 -d 0/0 --dport 0:1023 -j DROP
iptables -I FORWARD -i eth0 -d 192.168.0.0/255.255.0.0 -j DROP
iptables -A FORWARD -i eth0 -s 192.168.0.0/255.255.0.0 -j ACCEPT
iptables -A FORWARD -i ppp0 -d 192.168.0.0/255.255.0.0 -j ACCEPT
iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE

I also changed the line in /etc/sysctl.conf to
net.ipv4.ip_forward = 1

I am close but not there yet. Help?

Bob



shdesigns
Powered By Infinite Improbabilty Drive
Premium
join:2000-12-01
Stone Mountain, GA

Re: [Connection Sharing] Ubuntu 12.04 as a gateway/router proble

Try lowering the MTU on the other computers to 1492.

THere is also a clamp MSS on the RP pppoe client.



bobx

join:2001-02-11
Novato, CA

I uncommented most of the ipv4 items in sysctl.conf and that resulted in the same problem.

Next I changed the mtu on the other computer to 1492 (it was 1500) and presto it worked. Now I have to go back to sysctl.conf and comment out things I do not need, if I can figure out which are needed and which are not.
ob
Thank you
Bob


floydb1982

join:2004-08-25
Kent, WA
reply to bobx

Try using Powerline AV 200. Worked for me until my broadband connection went faster than the Powerline AV 200 adapters could possible transfer internet at.