dslreports logo
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
21395
share rss forum feed


Sentinel
Premium
join:2001-02-07
Florida
kudos:2

Playing .mts files with VLC problems

I have a video camera that records directly to an SD card. It's capable of recording in .mp4 or AVCHD. Files recorded in .mp4 are fine. It records with no problems. All I have to do is copy them over to my PC and run them and they play fine.

But anything I record in AVCHD mode results in .mts files that just won't play in VLC. I can hear the audio fine but the picture remains frozen.

Anyone have any ideas?

rfnut
Premium
join:2002-04-27
Fisher, IL
kudos:2
From Google.
Most common reason: Have older version of VLC- Update version.
Another common issue. "Possibly your computer is to slow to playback HD streams without GPU hardware support?"


lordpuffer
RIP lil
Premium
join:2004-09-19
Rio Rancho, NM
kudos:2
Reviews:
·CableOne
reply to Sentinel
VLC's Playback Formats:

»www.videolan.org/vlc/features.ph ··· at=video
»www.videolan.org/vlc/features.ph ··· at=input
»www.videolan.org/vlc/features.ph ··· at=audio


Sentinel
Premium
join:2001-02-07
Florida
kudos:2
So ... what's your point? Please forgive my ignorance but I'm not getting any answer from the links you posted? Should I be seeing something that answers my question? I guess I'm a little slow and I need a bit more of a shove then.


lordpuffer
RIP lil
Premium
join:2004-09-19
Rio Rancho, NM
kudos:2
Sorry......I just posted the pages that showed the formats that VLC played because in your original post you said you couldn't play .mts files.

I should have been clearer...


Dogg
Premium
join:2003-06-11
Belleville, IL
reply to Sentinel
Unless I'm mistaken, mts files are part of the (HD) Blu-Ray format.

And I'm finding mixed information about VLC supporting Blu-Ray.
--
Google is your Friend


Sentinel
Premium
join:2001-02-07
Florida
kudos:2
reply to lordpuffer
Wow, I never even thought of that because I click on them and they start to open so I assumed that VLC played .mts files. I never even thought that perhaps that was a format that it doesn't even support.

Thanks for that.

So it seems that the laptop that I am attempting to play them on does not have a blu-ray disc drive. Should that matter? Does that mean that perhaps this PC does not support the HD/blu-ray standard or something and this is what is causing the issue?

Screen res is 1440x900 on this PC.


lordpuffer
RIP lil
Premium
join:2004-09-19
Rio Rancho, NM
kudos:2
Reviews:
·CableOne
said by Sentinel:

Wow, I never even thought of that because I click on them and they start to open so I assumed that VLC played .mts files.

It looks like it doesn't. I started looking for a codec that will play that type of file in VLC, but ran into mixed results. I would guess that there is one out there though.

Sorry, I'm not sure enough to answer the Blu-ray question.


Sentinel
Premium
join:2001-02-07
Florida
kudos:2
Weird, because I tried playing it on another PC and it kind of plays it but it starts and stops and jitters but it looks like it's trying to play it. So it kind of gives the impression that it recognizes the file, but just can't successfully play it.


aurgathor

join:2002-12-01
Lynnwood, WA
kudos:1
Reviews:
·Frontier Communi..

1 recommendation

MTS stands for Mpeg Transport Stream, and mpeg is supported by VLC. However, as it was already noted, depending on fps and resolution, it may require quite a bit CPU/GPU horespower to play them.

A simply way to verify it is to open up Task Manager, and take a look at CPU Usage in the Performance tab. A constant 100% or near 100% usage is usually indicative of an underpowered CPU.

According to my experience, h264 encoded HD content usually require at least a dual core Pentium, though I'd recommend a core 2 quad or better.
--
Wacky Races 2012!


Sentinel
Premium
join:2001-02-07
Florida
kudos:2
Hmm. Could it then be that it is just not powerful enough?


Dogg
Premium
join:2003-06-11
Belleville, IL
Reviews:
·Charter
reply to Sentinel
A dual core 2ghz cpu is the minimum hardware requirement for HD (ie; 720 & 1080P) files. How well they play, will depend on the file specs and the actual media player/codecs used.

Having said that, you still need a media player with the proper codecs to actually play the files.

The PC they won't play on is likely a media player/codec issue.

The PC they aren't playing smoothly on could be the cpu speed, media player/codecs, or any number of other factors. Such as RAM, other programs running using resources, etc.
--
Google is your Friend


aurgathor

join:2002-12-01
Lynnwood, WA
kudos:1
Reviews:
·Frontier Communi..
reply to Sentinel
Did you check CPU usage? I think that PC should be powerful enough to play most any h264 video, but it's hard to be 100% certain without actually trying it, and checking CPU usage.

My Panasonic GF-1 can also creates .mts files, and I could play those with VLC, although mostly due to the abundance of various compression artifacts, I switched it to mpeg4 which is slightly better quality in my case.
--
Wacky Races 2012!


OldCableGuy

@planetcr.net
Copy them off the SD card first and then try to play them. What you're describing sounds like VLC is not able to read the file fast enough, perhaps your SD card is not very speedy.


Sentinel
Premium
join:2001-02-07
Florida
kudos:2
Sorry if I did not mention that but yeah, I do copy them off the card first. I am trying to play them directly from the HD.
Expand your moderator at work


Dustyn
Premium
join:2003-02-26
Ontario, CAN
kudos:11
Reviews:
·TekSavvy Cable
·Rogers Hi-Speed
reply to Sentinel

Re: Playing .mts files with VLC problems

Click for full size
Just out of curiosity, can Windows Media Player play them?
Mine is set to play them through Windows Media Player on Windows 7 Ultimate 64-bit.

oldnavy
Premium
join:2009-04-12
Brooklyn, NY
reply to Sentinel
Try this:
Open VLC - Tools -Preferences - Input & Codecs.
On right side find Skip H.264 in-loop deblocking filter.
Set it in drop menu to ALL (instead None).
Click on Save.
I had the same problem before.


Sentinel
Premium
join:2001-02-07
Florida
kudos:2

1 edit
Dustyn,
I don't know because I don't have it installed on my PC so I never tried. I guess I should have installed it and tried. Thanks for the idea.

oldnavy,
I will try this too. Thank you.

edit added:
I can't find that setting under input/codecs.

oldnavy
Premium
join:2009-04-12
Brooklyn, NY
I have newest VLC version 2.06. This setting is there. Check if you have SIMPLE checked on the bottom of Preference ( Not All!).
"Skip H.264 in-loop deblocking filter" is located in "Input & Codecs" on right side under "Codecs" third line from a top.


Sentinel
Premium
join:2001-02-07
Florida
kudos:2
Click for full size
Oh, DUH. Sorry. I have to change it to simple vs full advanced settings. Oh ok.


Sentinel
Premium
join:2001-02-07
Florida
kudos:2

1 recommendation

reply to Sentinel
Before changing anything I just installed the new version of VLC with all default settings and it seems to work fine now. So it would seem problem solved.
Thank you all.

rfnut
Premium
join:2002-04-27
Fisher, IL
kudos:2
Your welcome. Seems the first solution was the right one.
Expand your moderator at work


Sentinel
Premium
join:2001-02-07
Florida
kudos:2

1 recommendation

reply to rfnut

Re: Playing .mts files with VLC problems

Yeah, but the version that I had when I made the first post was the latest version when I made that post.