dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
4855
share rss forum feed


drabe96

@comcast.net

[Cable] HDMI sound problem

Hello all, I have an LG 26LN4500 TV connected by HDMI to a Pace PR150BNM HD receiver. Both are brand new. My problem is if I use the all on button on the Comcast remote, I receive no sound on all channels. If I turn just the tv off, and then back on again, the sound then works. I tried different settings on both the Pace box and TV that had to do with audio even though the original settings appeared to be correct. I tried a known working HDMI cable. There was no change. I assumed it must be a handshake issue. I searched for a way to program the Comcast remote to send the turn on command to the tv before the receiver, but it appears this is not possible. I decided to program one of my Harmony remotes for the tv and receiver. Even though it also sends the on command to the receiver before the tv, the sound works perfect. Maybe the delay between commands on the Harmony is longer, but it seems to be the same as the Comcast. I then tried a second Comcast remote and the problem was the same. I have tried all the LG tv codes. This is in my young sons room and the Comcast remote is easier for him to use. Does anyone have any ideas? Thanks.

SpHeRe31459
Premium
join:2002-10-09
Sacramento, CA
kudos:2

1 edit
The Harmony method you used is really the most common way to fix issues like that.

You can also always just leave the cable box on, and only turn the TV off, leaving the box on really isn't much a power difference than off.

You may be able to effectively disable the Power command for cable box in the remote by following these instructions, they are for the older Comast silver remotes so they may not work with the newer XR2 remotes that are being given out with new X1 equipment, but many of the codes seem to be shared between them, see the section on "Disable DVR Power key":
»en.wikibooks.org/wiki/How_to_use···l_On_key

Another method you can do try to smooth out HDMI compatibility issues like that is to put an active HDMI switch in between the TV and cable box. Obviously you don't need it for an extra HDMI port, but many people have found that having an active device in the chain helps avoid the re-handshaking issues that are the root of most of these problems.

Monoprice is a proven vendor, they have relatively inexpensive HDMI switchers that multiple people have used to fix HDMI handshake issues with cable boxes. More info here: »[STB] HDMI resets to 720p

This little guy is only $22. »www.monoprice.com/products/produ···_id=8204

SpHeRe31459
Premium
join:2002-10-09
Sacramento, CA
kudos:2

3 edits
Duh had a total brain fart... by far the easiest way to deal with these issues is it simply to not use HDMI. Use component video instead. Component carries HD video too so there's no real loss there.
Ex: »www.monoprice.com/products/produ···p_id=320
or for a brick and mortar option:
»www.walmart.com/ip/GE-Component-···19204383

The component video input on your TV (like most newer TVs) shares some connections with the standard def A/V (composite) video input. So hopefully you have it free.


Jennifer_b

@comcast.net
That will work for regular HD, but you'll need HDMI if you plan to watch 1080p from a blueray player.

SpHeRe31459
Premium
join:2002-10-09
Sacramento, CA
kudos:2
said by Jennifer_b :

That will work for regular HD, but you'll need HDMI if you plan to watch 1080p from a blueray player.

I don't know why you felt the need to say that. The issue at hand is with a cable box, not a Blu-ray player, so this is of no real importance to the issue.


drabe96

@comcast.net
Thanks for the replies. I think my whole problem is spelled Pace. I sent my wife to the branch office and they told her they had no Motorola receivers. I had already disabled the power comand to the cable on the remote while I was looking for the solution. I guess that was the solution after all.
Expand your moderator at work