dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
733
share rss forum feed


TomS_
Git-r-done
Premium,MVM
join:2002-07-19
London, UK
kudos:5

SSID not visible on Mac, but is on phone

Hi all. For once I am asking for help. :D

I have a 1242AG AP that has worked brilliantly in the past, but Im noticing some odd behaviour with it right now.

A little background: I moved in to a share house, and wi-fi is crazy around here. 2.4GHz is congested like crazy, but 5GHz is scantly used. Not to mention the house is huge and only has a single AP, so theres probably some hidden node stuff going on here...

So I set up my own AP and created two SSIDs, and broadcast one on 2.4GHz and the other on 5GHz giving me the ability to hook my Mac up on a frequency that isn't drowned.

The 5GHz one is giving me a little trouble. It seems to come and go - but only on my Mac. On my Android phone it is always visible. Right now, my Mac is connected to 2.4GHz and my phone to 5GHz. There was a time when the 5GHz SSID used to show up on my Mac, but for some reason it has disappeared now.

In the past I had always broadcast the same SSID on both 2.4 and 5GHz, so maybe I just didnt notice this before...

Can anyone take a look at my config and tell me if Im missing something obvious that might cause trouble?

Thanks. :-)

!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname eal-ap1
!
logging buffered 65535 debugging
logging console informational
enable secret 5 .....
!
no aaa new-model
ip name-server 8.8.8.8
ip name-server 8.8.4.4
!
!
dot11 vlan-name snnap-fast vlan 21
dot11 vlan-name snnap-lan vlan 11
!
dot11 ssid snnap-fast
   vlan snnap-fast
   authentication open 
   authentication key-management wpa
   mbssid guest-mode
   wpa-psk ascii 7 .....
!
dot11 ssid snnap-lan
   vlan snnap-lan
   authentication open 
   authentication key-management wpa
   mbssid guest-mode
   wpa-psk ascii 7 .....
!
power inline negotiation prestandard source
!
!
!
bridge irb
!
!
interface Dot11Radio0
 description ** 802.11b/g Radio
 no ip address
 no ip route-cache
 load-interval 30
 !
 encryption vlan snnap-lan mode ciphers aes-ccm 
 !
 ssid snnap-lan
 !
 mbssid
 channel 2412
 station-role root
 world-mode dot11d country GB indoor
 bridge-group 1
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Dot11Radio0.11
 encapsulation dot1Q 11
 no ip route-cache
 bridge-group 11
 bridge-group 11 subscriber-loop-control
 bridge-group 11 block-unknown-source
 no bridge-group 11 source-learning
 no bridge-group 11 unicast-flooding
 bridge-group 11 spanning-disabled
!
interface Dot11Radio1
 description ** 802.11a Radio
 no ip address
 no ip route-cache
 load-interval 30
 !
 encryption vlan snnap-fast mode ciphers aes-ccm 
 !
 ssid snnap-fast
 !
 no dfs band block
 mbssid
 channel dfs
 station-role root
 world-mode dot11d country GB indoor
 bridge-group 1
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Dot11Radio1.21
 encapsulation dot1Q 21
 no ip route-cache
 bridge-group 11
 bridge-group 11 subscriber-loop-control
 bridge-group 11 block-unknown-source
 no bridge-group 11 source-learning
 no bridge-group 11 unicast-flooding
 bridge-group 11 spanning-disabled
!
interface FastEthernet0
 no ip address
 no ip route-cache
 load-interval 30
 duplex auto
 speed auto
 bridge-group 1
 no bridge-group 1 source-learning
 bridge-group 1 spanning-disabled
 hold-queue 160 in
!
interface FastEthernet0.11
 encapsulation dot1Q 11
 no ip route-cache
 bridge-group 11
 no bridge-group 11 source-learning
!
interface FastEthernet0.13
 encapsulation dot1Q 13
 no ip route-cache
 bridge-group 1
 no bridge-group 1 source-learning
 bridge-group 1 spanning-disabled
!
interface BVI1
 description ** Management Interface
 ip address 172.25.255.18 255.255.255.240
 no ip route-cache
!
ip default-gateway 172.25.255.17
no ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
bridge 1 protocol ieee
bridge 1 route ip
!
!
!
line con 0
 logging synchronous
line vty 0 4
 exec-timeout 0 0
 password 7 .....
 logging synchronous
 login
line vty 5 15
 exec-timeout 0 0
 password 7 .....
 logging synchronous
 login
!
sntp server 80.5.182.144
sntp server 62.253.170.208
end
 

markysharkey
Premium
join:2012-12-20
united kingd

Surely Fa0.13 should be 0.21 with encap dot1q 21 to match Radio 1.21? For sure Fa0.13 is never gonna see Radio 1.21 cos the encap dot1q's don't match.

Try knocking off the MBSSID config lines everywhere as well. I know you have multiple VLAN's but that one has caused me issues in the past where I have one VLAN per radio.
--
Binary is as easy as 01 10 11



TomS_
Git-r-done
Premium,MVM
join:2002-07-19
London, UK
kudos:5

3 edits

1 recommendation

reply to TomS_

*drum roll*

And the magic command of today is:

dfs band 2 3 4 block

edit: that goes under int do1

Seems DFS had selected to operate in band 4, which is the 5.8GHz sub-band, or channels 149/153/157/161, none of which the wireless card in my Mac supports but the phone does, therefore it couldnt see the SSIDs.

I guess in previous instances DFS had selected a lower sub-band, and then shifted to a higher one.

This should solve the problem I hope.


HELLFIRE
Premium
join:2009-11-25
kudos:18
reply to TomS_

Off the top of my head, didn't see anything wierd and whacky with the config -- guest-mode pretty much indicates
"broadcast SSID to everyone."

My next thought after that would've been to get the Mac equivalent of inSSIDer to confirm.

Just so I got it straight TomS_, both the Android and the Mac had A/G capable cards / chips in them, and that Android
could see the the A-band SSID but at the EXACT same time the Mac couldn't?

Regards



TomS_
Git-r-done
Premium,MVM
join:2002-07-19
London, UK
kudos:5

Yep, at the exact same time my Android was on the A SSID, but the Mac couldn't see or connect to it.

I suspect it was quite simply the fact that the Airport card in the Mac doesnt support the channels that make up the 5.8GHz band, but the Android phone does. Since blocking out everything but the 5.2GHz band, both the phone and Mac can connect to the A SSID.


HELLFIRE
Premium
join:2009-11-25
kudos:18

A failure on the Apple Airport's part? Couldn't be [/sarcasm].

IIRC the IEEE spec is pretty clear what frequencies 802.11A equipment is supposed to cover.

Regards



TomS_
Git-r-done
Premium,MVM
join:2002-07-19
London, UK
kudos:5

Heres a screen capture of the wireless card specs from the System Information app (I think formerly called System Profiler?)

Seems odd that it would leave out the 4 higher channels making up 5.8GHz since I always thought those were part of the 5GHz band for 802.11a ...




Cant find a datasheet for the specific chipset used (seems to be a BCM4331 according to the teardown at ifixit.com) so cant tell if this is just Apple being stupid and leaving out support for those channels, or if its actually a hardware limitation and its Broadcom being stupid.


tubbynet
reminds me of the danse russe
Premium,MVM
join:2008-01-16
Chandler, AZ
kudos:1

regulatory domain issues? i know freqs for different wireless domains are different. not sure of the country of origin for your phone and imac.

[edited to add] of course, this is pure speculation as i am too lazy to look it up on my ipad while digesting my fathers day brunch.

q.
--
"...if I in my north room dance naked, grotesquely before my mirror waving my shirt round my head and singing softly to myself..."



TomS_
Git-r-done
Premium,MVM
join:2002-07-19
London, UK
kudos:5

149/153/157/161 are allowed in Europe (according to wikipedia), and I did buy my Mac in Europe, so you'd think that it would work in a situation like that.

I'd be surprised if Apple produced different pieces of hardware for different regions. That sort of thing can be controlled in software these days.


HELLFIRE
Premium
join:2009-11-25
kudos:18

Could be done in software... but do you really want to when you can change more for a "feature / model upgrade?"

Just saying...

Regards



TomS_
Git-r-done
Premium,MVM
join:2002-07-19
London, UK
kudos:5

And then you have to stock multiple different hardware SKUs.

Judging by Apples history, they dont like to produce many variants of their products.

As much as we like to think they are evil, Im thinking bean counters get the better of them at this game.


markysharkey
Premium
join:2012-12-20
united kingd

Bean counters are evil too...



TomS_
Git-r-done
Premium,MVM
join:2002-07-19
London, UK
kudos:5

Yeah, they stop us building the gold plated solutions. :-P



tubbynet
reminds me of the danse russe
Premium,MVM
join:2008-01-16
Chandler, AZ
kudos:1

said by TomS_:

Yeah, they stop us building the gold plated solutions. :-P

isn't that how engineers are made? well -- more appropriately -- solutioneers?

q.
--
"...if I in my north room dance naked, grotesquely before my mirror waving my shirt round my head and singing softly to myself..."

HELLFIRE
Premium
join:2009-11-25
kudos:18

You know a technology's matured when the guys upstairs are accounting types rather than engineers.

I take the BOFH view and like to eliminate them... every so often... preferably in a darkened parking lot...

Regards