dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
1080
share rss forum feed

dkeener

join:2013-06-18
Wheeling, WV

Ether Channel Help

Working with 2 3750 cross stack switches. Trying to setup an etherchannel.
COnfig is below and error is at the end. Second port fails to join
Anyone have some advice? New to networking.

Port-channel48 is up, line protocol is up (connected)
Hardware is EtherChannel, address is 0015.63ec.0304 (bia 0015.63ec.0304)
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Full-duplex, 1000Mb/s, link type is auto, media type is unknown
input flow-control is off, output flow-control is unsupported
Members in this channel: Gi1/0/4
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 484000 bits/sec, 449 packets/sec
5 minute output rate 81000 bits/sec, 1648 packets/sec
6359048 packets input, 855556348 bytes, 0 no buffer
Received 1622946 broadcasts (0 multicast)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 1588978 multicast, 0 pause input
0 input packets with dribble condition detected
21921076 packets output, 4163953334 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 PAUSE output
0 output buffer failures, 0 output buffers swapped out

interface GigabitEthernet1/0/4
description DB2 NIC1
switchport trunk encapsulation dot1q
switchport mode trunk
duplex full
speed 1000
channel-group 48 mode active

interface GigabitEthernet2/0/1
description db2 nic2
switchport trunk encapsulation dot1q
switchport mode trunk
duplex full
speed 1000

3750(config-if)#channel-group 48 mode active
%With LACP enabled, all ports in the Channel should belong to the same switch
Command rejected (Port-channel48, Gi2/0/1): Invalid etherchnl mode


cramer
Premium
join:2007-04-10
Raleigh, NC
kudos:9

The etherchannel must be made of ports from the same physical switch. You tried to add a port from the second switch.


dkeener

join:2013-06-18
Wheeling, WV

yeah I was trying to create physical redundancy as well to protect against a switch failure. Is that not possible? The switches are connected via stacker cables.


Network Guy
Premium
join:2000-08-25
New York
kudos:2

From what I remember, in a 2950 you could only add local physical interfaces into a PO interface.


cramer
Premium
join:2007-04-10
Raleigh, NC
kudos:9
reply to dkeener

Not with those switches, no.


markysharkey
Premium
join:2012-12-20
united kingd
reply to dkeener

Can you have channel-group 48?
Usually channel-group numbers are 1 - 6.

If you are creating an etherchannel group then the config must match on each end. Adding the same config to the link(s) at each end should work. For example:

int ra gig 1/0/1 - 3
switchport mode trunk
channel-group 6 mode active
 

Do that on two switches and you have an etherchannel group.

--
Binary is as easy as 01 10 11

dkeener

join:2013-06-18
Wheeling, WV

I was able to get it working cross switch. You have to use mode on which disables PaGP and allows LACP to come on and form the channel. Mode active is valid only when working within the same physical switch.


nosx

join:2004-12-27
00000
kudos:5

Using mode on is not signaled with LACP like mode active. It will result in potential soft failures blackholing traffic.


cooldude9919

join:2000-05-29
kudos:5
reply to dkeener

Yep ran into this with our 3750x's. To etherchannel across the stack you must use LACP, PAGP wont do it. We have all of our l2 distribution switches linked up across the stack.

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
13     Po13(SU)        LACP      Gi1/0/13(P) Gi2/0/13(P)
17     Po17(SU)        LACP      Gi1/0/17(P) Gi2/0/17(P)
21     Po21(SU)        LACP      Gi1/0/21(P) Gi2/0/21(P)
22     Po22(SU)        LACP      Gi1/0/22(P) Gi2/0/22(P)
23     Po23(SU)        LACP      Gi1/0/23(P) Gi2/0/23(P)
24     Po24(SU)        LACP      Gi1/0/24(P) Gi2/0/24(P)
25     Po25(SU)        LACP      Gi1/0/1(P)  Gi2/0/1(P)
26     Po26(SU)        LACP      Gi1/0/2(P)  Gi1/0/3(P)  Gi2/0/2(P)
                                 Gi2/0/3(P)
27     Po27(SU)        LACP      Gi1/0/4(P)  Gi2/0/4(P)
30     Po30(SU)        LACP      Gi1/0/5(P)  Gi2/0/5(P)
 
 

markysharkey
Premium
join:2012-12-20
united kingd
reply to dkeener

Channel-group x mode active is an LACP command.
Channel-group x mode desirable is PaGP.
No other commands are usually required.
I use the active command all the time to create trunks between switches. There's no point in using the passive option for LACP and even less point in using PaGP unless the switch doesn't support LACP, which is rare these days.
--
Binary is as easy as 01 10 11


HELLFIRE
Premium
join:2009-11-25
kudos:18
reply to dkeener

said by dkeener:

yeah I was trying to create physical redundancy as well to protect against a switch failure.

Probably a better question is exactly WHAT is the environment you're in that you need both?

Trying to wrap my head around "physical redundancy" and "protect against a switch failure." At layer 3,
should be easy enough to do with multi-NIC hosts and HSRP / VRRP. REALLY hard to do at layer 2, you may
as well have a hot / warm swappable spare in the closet.

Even on the highest end devices (think 6500-series), I'm not sure if VSS could be used to do something like this.

Regards

cooldude9919

join:2000-05-29
kudos:5

said by HELLFIRE:

said by dkeener:

yeah I was trying to create physical redundancy as well to protect against a switch failure.

Probably a better question is exactly WHAT is the environment you're in that you need both?

Trying to wrap my head around "physical redundancy" and "protect against a switch failure." At layer 3,
should be easy enough to do with multi-NIC hosts and HSRP / VRRP. REALLY hard to do at layer 2, you may
as well have a hot / warm swappable spare in the closet.

Even on the highest end devices (think 6500-series), I'm not sure if VSS could be used to do something like this.

Regards

If you see his first post, he has his two 3750's stacked. So he is creating physical redundancy in that if he has his switches all trunked to them via 2 links, one to each switch, if one of the 3750's fail, then all the switches will still be able to communicate via the remaining 3750.

Network Guy
Premium
join:2000-08-25
New York
kudos:2
Reviews:
·Future Nine Corp..
·T-Mobile US
·Optimum Online

said by cooldude9919:

if one of the 3750's fail, then all the switches will still be able to communicate via the remaining 3750.

But that only helps to keep nodes in unaffected switch online, the other half is SOL.

cooldude9919

join:2000-05-29
kudos:5

said by Network Guy:

said by cooldude9919:

if one of the 3750's fail, then all the switches will still be able to communicate via the remaining 3750.

But that only helps to keep nodes in unaffected switch online, the other half is SOL.

Not if you are doing etherchannel with each l2 switch, and have one of the two links to each 3750, everything would still communicate fine via the remaining etherchannel trunk.

Given that it doesn't help with devices that hook up with a single connection, like computers, provider handoffs, etc. My work around for that is having spare ports on my 3750x's with the vlan/etc already setup and ready to go, then I would have to manually move a few select ports to the other "remaining" switch.

Network Guy
Premium
join:2000-08-25
New York
kudos:2
Reviews:
·Future Nine Corp..
·T-Mobile US
·Optimum Online

said by cooldude9919:


My work around for that is having spare ports on my 3750x's with the vlan/etc already setup and ready to go, then I would have to manually move a few select ports to the other "remaining" switch.

Right. And that's what I mean. When that second switch fails, there's still some elbow grease to do.

Not that it wouldn't hurt to have it in place though.

cooldude9919

join:2000-05-29
kudos:5

said by Network Guy:

said by cooldude9919:


My work around for that is having spare ports on my 3750x's with the vlan/etc already setup and ready to go, then I would have to manually move a few select ports to the other "remaining" switch.

Right. And that's what I mean. When that second switch fails, there's still some elbow grease to do.

Not that it wouldn't hurt to have it in place though.

Alll depends on what you are trying to accomplish. Any single threaded device will always have a single point of failure, nothing you can do about that. In the event of a switch failure, there will always be some work to do, UNLESS for example you ONLY had etherchannel'd switches going to your stack, then theoretically you would have nothing to move around in the event of a stack member failure.


OmenQ
Spazz
Premium
join:2003-03-21
Continuum

1 edit

I'm doing exactly this at one location. I have two 3750G-12's set up in a stack, with identical port configurations on both stack members, and EtherChannels to all the connected switches. If one stack member fails, the connected switches will not lose network connectivity. Since the site is very remote, having that redundancy without intervention is a requirement.

Relevant info for OP:
Check that load balancing is set the same on both ends of the etherchannel. In my case I have in general config:

port-channel load-balance src-dst-ip

Then I set the port channel:
interface Port-channel20
description To Trailside
switchport trunk encapsulation dot1q
switchport mode trunk

Then the interfaces:
interface GigabitEthernet1/0/5
description To Trailside
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 20 mode active

interface GigabitEthernet2/0/5
description To Trailside
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 20 mode active

The far side switch would have identical settings on the port channel and interfaces, including the channel group number.

I'm not an expert, but this works for me. YMMV and all that.
--
Cogito Ergo Nom


HELLFIRE
Premium
join:2009-11-25
kudos:18
reply to cooldude9919

@cooldude9919
Had a hard time picturing "physical redundancy" in my head... till you mentioned about multi-NIC'd devices.
Then again, I agree with what you said about it depending on what the environment and hosts the OP is setting
up on their end.

IIRC 3750s are pretty expensive as plain user access switches, and kinda low on buffer space for high end server
access switches... unless the budget is just that limited.

I do see em sometimes in a VERY collapsed core / distro / access design -- running an IGP and BGP to the telco,
and POE access for phones, etc.

Regards