dslreports logo
 
    All Forums Hot Topics Gallery
spc

spacer

Search Topic:
uniqs
715
share rss forum feed

hartecom

join:2009-08-11
Fort Worth, TX

1 edit

BEFSR41 port forwarding

I am having trouble getting my apache webserver to show when traversing to my static IP address on the web. I have a BEFSR41 Firmware Version: 2.00.02, Feb 14 2007 local lan has 5 computers on it all have been issued static IP's DHCP is still on to address friendly wifi users.

Apache (httpd) is viewable if I use local private static ip address 192.168.1.114

I've set up port forwarding on port http port 80 to 192.168.1.114 but when I go to the external IP the router shows and requests credentials to log in. I've also tried DMZ to same result.

It's odd because if I set up a Tor hidden service and run thttpd rather than apache (httpd) the webserver shows (I think it's a different port and no forwarding was needed.

Connection is charter. Seems they are not filtering 80 because router webpage shows no matter what I do from external static.

What am I missing?

sorry looks like I posted twice later thread was posted first anon, figured mods would catch it.


aefstoggaflm
Open Source Fan
Premium
join:2002-03-04
Bethlehem, PA
kudos:8
Reviews:
·PenTeleData
·Verizon Online DSL
#1 Go to grc.com -> Freeware -> Utilities -> ID Serve

#2 Download and get the HTTP headers from the computer that you want to host on.

#3 Note: If not on Windows, you also would need Wine to get it working ( »www.grc.com/freeware/wine.htm )

#4 Then go to »network-tools.com/

#5 Select HTTP Headers

#5 Press Go

#6 Do you see the same HTTP headers?
--
Please use the "yellow (IM) envelope" to contact me and please leave the URL intact.


pike
Premium,MVM
join:2001-02-01
Washington, DC
kudos:3
reply to hartecom
Have you tried disabling remote administration? Does this device allow you to configure the port used for remote administration? If so make sure it's not also set to 80 (probably the default).


Bill_MI
Bill In Michigan
Premium,MVM
join:2001-01-03
Royal Oak, MI
kudos:2
Reviews:
·WOW Internet and..
reply to hartecom
said by hartecom:

I've set up port forwarding on port http port 80 to 192.168.1.114 but when I go to the external IP the router shows and requests credentials to log in. I've also tried DMZ to same result.

Are you on this BEFSR41's LAN when you try the public IP? If so, try it from anywhere else in the world and I bet it works.

hartecom

join:2009-08-11
Fort Worth, TX
Thanks so much for helping guys. I pretty much have reached the conclusion that Charter is filtering port 80 as documented on many threads I've read on web.

I know it is unusual to see the router interface by going to the outside static. However during my research I found a thread about a bug in this linksys router which allows at times under certain conditions for the interface to show, even when remote management is turned off.

Still haven't tried accessing from outside the lan, Bill offered this idea as a possible scenario. I will try this when I'm on a different network soon. Honestly though I don't understand the logic of that. Having set up a few servers in my time. I have also seen others in web forums offer this as a possible solution.

Thanks again, The one thing I think I might try is going into the actual cable modem and seeing if there is any kind of firewall or settings there which might be impacting this.


Bill_MI
Bill In Michigan
Premium,MVM
join:2001-01-03
Royal Oak, MI
kudos:2
Reviews:
·WOW Internet and..

1 edit
Interesting. I know most Linksys routers (and Microsoft servers at work) supports this "loopback" function but it's really just a hack. When you send to the public WAN IP from the LAN, a source IP has to be created to get to the LAN server.

From the LAN side, port 80 is the router interface page. I have a feeling that's involved if other ports work. Plus, the ISP shouldn't be involved like they would be from the outside.

Hope I'm not missing something. You are accessing your WAN IP from the LAN to test this on port 80, right?

hartecom

join:2009-08-11
Fort Worth, TX

2 edits

1 recommendation

Wow thanks again Bill for taking an interest. Yes if I go to the WAN IP right now on a browser from inside the LAN. I get the admin splash for router and a prompt for credentials.

If I go to the LAN private IP I get the apache server which is set to listen on 0.0.0.0:80.

Remote management is turned off. The default port for remote management is 8080 if it were enabled.

Port Forwarding is on : http Port 80 TCP and UDP forwarded to internal private IP 192.168.1.114

I've tried viewing from a proxy browser to wan address, which I think would be the same as an outside connection, and the router admin managemen't page doesn't show. Nor does the webserver. The connection simply times out.

Pretty sure this is a "Charter Cable" port 80 filtering issue. ( I could go on a rant about that) Makes me long for an Internet connection with no restrictions like I've had in past.


Bill_MI
Bill In Michigan
Premium,MVM
join:2001-01-03
Royal Oak, MI
kudos:2
Reviews:
·WOW Internet and..
It sounds like you have it figured out. I think you're fighting both an ISP block and loopback not quite the same on port 80. This isn't professional equipment, after all.

If you have loopback working on another port, check on the server end - what IP is a loopback connection coming from? I think you may be surprised - it's an eye-opener how it's handled. Good luck!