dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
731
share rss forum feed

ibloomfield

join:2012-09-17
Golden, CO

Phillips 46PFL5705D/F7 won't turn on (help diagnosing)

Click for full size
Main Board Connector
Click for full size
Inverter Connectors
Click for full size
Power Board
Click for full size
Main Board
Hi Guys,

I've had luck diagnosing tv's here before so I thought I'd enlist your guys help again!

I have a Philllips 46PFL5705D/F7 that will not turn on. The power led (logo led) will blink 25 times before a short gap, and then start the 25 blink cycle again. Pressing the power button elicits no response.

Here is where I'm at (more details below, see pics as well):

1. Tested for voltages at the main board
2. Tested voltages at the inverter board
-------------------------------------------------------------

1 - Main board connector (tested at the main board side of connector).

Pin 1 - 12.48V
Pin 2 - 12.48V
Pin 3 - 12.48V
Pin 4 - 12.48V
Pin 5 - 0V
Pin 6 - 0V
Pin 7 - 0V
Pin 8 - 0V
Pin 9 - 5.38V
Pin 10 - 0V
Pin 11 - 0V
Pin 12 - 3.08V
Pin 13 - NC
Pin 14 - 0V

The 5.38V is a little off, as well as the 3.08V, but my guess is that's not the issue (could be wrong).

2 - Inverter Connector 1 (14 pin w/ controls)

Pin 1-5 - 25.4V
Pin 6-10 - 0V
Pin 11-14 (controls) - 0V

3 - Inverter Connector 2 (10 pin)

Pin 1-5 - 25.4V
Pin 6-10 - 0V

Clearly 25.4V is quite a bit higher than 24V. But, I don't know the inverters' voltage tolerances (could be that 25.4V is fine).

I'm not sure where to go from here. I can take more pictures if necessary and test for voltages at any point.

Any advice as to how to further diagnose?

Thanks in advance for any help.

-Ian


mackey
Premium
join:2007-08-20
kudos:8

Click for full size
Is that an air gap in the chip or is it just an optical illusion? Could be ESD or lightning damage.

That looks like heat sink compound on that large chip above and to the left of the circled one. Did you pull off a heat sink or did it fall off?

/M

ibloomfield

join:2012-09-17
Golden, CO

Click for full size
HDMI IC
Click for full size
CPU (?)
No air gap I'm pretty sure. Also I don't think there was ever a heat sink, none that I'm aware of at least. See pics.

lutful
... of ideas
Premium
join:2005-06-16
Ottawa, ON
kudos:1

I am guessing the backlighting (LED array?) is NOT turning on either. Have you checked for shorts and opens?

Just a wild guess for following signals:

PROTECT3 : some sort of error indication
PSON : which locks the main power supply ???
BL_SW : and maybe also the backlights ?

BL_ADJ1/2 : backlight level adjustment



mackey
Premium
join:2007-08-20
kudos:8
reply to ibloomfield

 
Click for full size
Mmmmmm, even with that new pic it still looks like some copper is sticking out through the plastic. It really looks like lightning zapped a HDMI port frying that chip.

/M