dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
5624
share rss forum feed


harry

@tpgi.com.au

Client has no internet access but router is connected to int

Hi everyone
I have a cisco 1801 router, i have configured the router, i can ping web sites from the router and it works fine, however when connecting a pc to the switch, it connects to the router but no internet access, i can ping the router from the pc but not from the pc from the router.

can anyone help?

Network Guy
Premium
join:2000-08-25
New York
kudos:2
Reviews:
·Future Nine Corp..
·T-Mobile US
Not being able to ping the PC from the router probably indicates the PC is running a software firewall that blocks inbound ICMP echo reply.

Are any other PC's having the same issue? Or just this one computer?

Check TCP/IP settings on the computer and ensure it is using correct addressing and default gateway.


harry

@tpgi.com.au
the issue is not the firewall, because when i connect the pc to another router i can ping it just fine.

markysharkey
Premium
join:2012-12-20
united kingd
reply to harry
Have you added DNS servers to the PC set up or to the routers DHCP settings?
Can you show us a sanitised config?
--
Binary is as easy as 01 10 11


harry

@tpgi.com.au
I have added a DNS and also an static ip address to my pc, however the DHCP seems to be working as my pc does get ip assigned to it. I'm working at home with this so only have one pc connected to it, Just a bit confused with the fa0 and fa1??
please see the config below:

router>en
Password:
router#show config
Using 2066 out of 196600 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$zW5r$WQIcyy4gpeCdy8ykE0mGP/
!
no aaa new-model
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1
ip dhcp excluded-address 192.168.1.1 192.168.1.10
!
ip dhcp pool LAN
import all
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 203.12.160.35 203.12.160.36
!
ip dhcp pool client
dns-server 203.12.160.35 203.12.160.36
!
!
multilink bundle-name authenticated
!
!
archive
log config
hidekeys
!
!
!
!
!
interface FastEthernet0
no ip address
speed auto
full-duplex
no cdp enable
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
no cdp enable
!
interface FastEthernet1
no cdp enable
!
interface FastEthernet2
no cdp enable
!
interface FastEthernet3
shutdown
no cdp enable
!
interface FastEthernet4
shutdown
no cdp enable
!
interface FastEthernet5
shutdown
no cdp enable
!
interface FastEthernet6
shutdown
no cdp enable
!
interface FastEthernet7
shutdown
no cdp enable
!
interface FastEthernet8
shutdown
no cdp enable
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 8/35
pppoe-client dial-pool-number 1
!
dsl operating-mode auto
!
interface Vlan1
ip address dhcp
ip nat outside
ip virtual-reassembly
!
interface Vlan3
no ip address
!
interface Dialer0
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
ppp chap hostname XXXXXXXX
ppp chap password 0 XXXXXXXX
ppp pap sent-username XXXXXXXXXX password 0 XXXXXXXXX
ppp ipcp dns request accept
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
!
no ip http server
ip nat inside source list NAT interface Dialer0 overload
!
ip access-list standard nat
permit 192.168.1.0 0.0.0.255
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
login
!
no process cpu extended
no process cpu autoprofile hog
end

HELLFIRE
Premium
join:2009-11-25
kudos:18
reply to harry
Here's the specific items I see messed up in your config OP

- VLAN 1 is "IP NAT OUTSIDE" -- generally VLAN 1 is used for your INSIDE hosts and interfaces

- you've specified "ip route 0.0.0.0 0.0.0.0 Dialer0" -- generally speaking, if your WAN interface facing the
ISP is getting an address via DHCP, you do NOT need to set a static like this.

ip nat inside source list NAT interface Dialer0 overload
ip access-list standard nat
 

Got the right config here, but watch out about your ACL names... they CAN be case-sensitive.
To keep it simple, redo your config as

ip nat inside source list 1 interface Dialer0 overload
ip access-list 1
 

Fa0 on the 1801 is the ROUTED port, as you can assign an IP address to the INTERFACE itself.
Fa1 - 8 are the SWITCHED ports, they can be put INTO a VLAN, and the VLAN can have an IP address,
but NOT the individual interfaces themselves.

You can reconfigure this yourself, or you can take a look at the forum FAQ for a basic config to crib.

Regards

cramer
Premium
join:2007-04-10
Raleigh, NC
kudos:9
int vlan1
  ip address 192.168.1.1 255.255.255.0
  ip nat inside
 
The "inside" LAN interface needs a fixed address -- it's your router and DHCP server.

The default route to dialer0 is correct -- it's a PPP interface (dsl). 'tho unnecessary, as the ATM interface will trigger the dialer as soon as the interface comes up.


harry

@tpgi.com.au
reply to HELLFIRE
thank for the info HELLFIRE, I have added the changes to my config however i'm still unable to ping the pc from the router.

here is a copy of the config

hostname router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$zW5r$WQIcyy4gpeCdy8ykE0mGP/
!
no aaa new-model
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1 192.168.1.10
!
ip dhcp pool LAN
import all
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 203.12.160.35 203.12.160.36
!
!
multilink bundle-name authenticated
!
!
archive
log config
hidekeys
!
!
!
!
!
interface FastEthernet0
no ip address
speed auto
full-duplex
no cdp enable
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
no cdp enable
!
interface FastEthernet1
no cdp enable
!
interface FastEthernet2
no cdp enable
!
interface FastEthernet3
shutdown
no cdp enable
!
interface FastEthernet4
shutdown
no cdp enable
!
interface FastEthernet5
shutdown
no cdp enable
!
interface FastEthernet6
shutdown
no cdp enable
!
interface FastEthernet7
shutdown
no cdp enable
!
interface FastEthernet8
shutdown
no cdp enable
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 8/35
pppoe-client dial-pool-number 1
!
dsl operating-mode auto
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Dialer0
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
ppp chap hostname XXXXXXXX
ppp chap password 0 XXXXXXXX
ppp pap sent-username XXXXXXX password 0 XXXXXXX
ppp ipcp dns request accept
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
!
no ip http server
ip nat inside source list nat interface Dialer0 overload
!
ip access-list standard nat
permit 192.168.1.0 0.0.0.255
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
login
!
no process cpu extended
no process cpu autoprofile hog
end

HELLFIRE
Premium
join:2009-11-25
kudos:18
reply to harry
Which interface is the PC on, exactly?

Is the PC getting an IP address when you run IPCONFIG on it?

Switchports FE3 - 8 are in shutdown state according to your config... so if you're PC's connected
to one of them, that would explain the behavior you're seeing.

Regards