dslreports logo
 
    All Forums Hot Topics Gallery
spc
Search similar:


uniqs
5658
nikita Josep
join:2013-07-29
255

nikita Josep

Member

Cisco router 2811 configuration

hello guys help me to configure this cisco router 2811

WAN IP ADDRESS:
41.59.251.100/30

LAN IP ADDRESS

41.59.254.160/29

VLAN: 293
tired_runner
Premium Member
join:2000-08-25
CT
·Frontier FiberOp..

1 edit

tired_runner

Premium Member

Sounds like a homework question.

router> en
(type enable password)
router#conf t
router(config)#int fa0/0
router(config-if)#ip add 41.59.251.101 255.255.255.252
router(config-if)#int fa0/1.1 encap dot1q 293
router(config-if)#ip add 41.59.254.161 255.255.255.248
router(config-if)#exit
router(config)#ip name-server 4.2.2.1
 

If you need help understanding this config, ask.
nikita Josep
join:2013-07-29
255

nikita Josep

Member

Thanx network guy...
Up to there i understand...
What about routing? Dhcp? No need?
tired_runner
Premium Member
join:2000-08-25
CT
·Frontier FiberOp..

tired_runner

Premium Member

Is this going to be a home router somewhere I suppose? You'll need a few other things for a "full service" router.

Enable routing:
router(config)#ip routing
router(config)#ip cef
 

Enable NAT:
router(config)#int fa0/0
router(config-if)#ip nat out
router(config-if)#do int fa0/1.1
router(config-if)#ip nat in
router(config-if)#exit
router(config)#ip access-list sta 1
router(config-std-nacl)#permit 41.59.254.160 0.0.0.7
router(config-std-nacl)#exit
router(config)#ip nat sour list 1 int fa0/0 overload
 

DNS services for the LAN:
router(config)#ip dns server
 

DHCP for that LAN:
router(config)#ip dhcp pool POOL1
router(config-dhcp)#dns 41.59.254.161
router(config-dhcp)#network 41.59.254.160 255.255.255.248
router(config-dhcp)#default-router 41.59.254.161
router(config-dhcp)#exit
router(config)#ip dhcp excl 41.59.254.1 41.59.254.161
router(config)#ip dhcp excl 41.59.254.168 41.59.254.254
 

Any reason why you're using a real class A address for your private LAN? The router probably won't care but you may come across certain sites you won't be able to access, namely sites using those same routable addresses.
nikita Josep
join:2013-07-29
255

nikita Josep

Member

Thank you in advance .. this isn't private, but at my office... am not that familiar with cconfiguration ...
Any other support ? What if i use 10.10.11.2 etc as my local lan(my office ip address ) do i need any configuration a part from that familiar?
tired_runner
Premium Member
join:2000-08-25
CT

tired_runner

Premium Member

You should use a private address space for your LAN hosts. Using 41.x.x.x is just asking for things to break.

How many computers will need to access this router and/or Internet?
ladino
join:2001-02-24
USA

ladino to nikita Josep

Member

to nikita Josep
You may want to read the Forum FAQs before you put your devices on-line. And come up with a network design
nikita Josep
join:2013-07-29
255

nikita Josep to tired_runner

Member

to tired_runner
200
nikita Josep

nikita Josep to ladino

Member

to ladino
Thanx
tired_runner
Premium Member
join:2000-08-25
CT
·Frontier FiberOp..

tired_runner to nikita Josep

Premium Member

to nikita Josep
Do this instead:

 
router> en
(type enable password)
router#conf t
router(config)#int fa0/0
router(config-if)#ip add 41.59.251.101 255.255.255.252
router(config-if)#int fa0/1.1 encap dot1q 293
router(config-if)#ip add 10.10.10.1 255.255.255.0
router(config-if)#exit
router(config)#ip name-server 4.2.2.1
 
router(config)#int fa0/0
router(config-if)#ip nat out
router(config-if)#do int fa0/1.1
router(config-if)#ip nat in
router(config-if)#exit
router(config)#ip access-list sta 1
router(config-std-nacl)#permit 10.10.10.0 0.0.0.255
router(config-std-nacl)#exit
router(config)#ip nat sour list 1 int fa0/0 overload
 
router(config)#ip dhcp pool POOL1
router(config-dhcp)#dns 41.59.254.161
router(config-dhcp)#network 10.10.10.0 255.255.255.0
router(config-dhcp)#default-router 10.10.10.1
router(config-dhcp)#exit
router(config)#ip dhcp excl 10.10.10.1 10.10.10.1
 

Now bear in mind that I'm making certain assumptions:

1. Your switch is configured with a VLAN 293 somewhere.
2. The 200 computers are in this VLAN 293.
3. You have trunk ports configured between your switch and the router and whatever other switches involved.
4. VLAN 293 is NOT the native VLAN nor does the management web interface of the switch (if at all) reside in this VLAN, unless OOB management is not possible then there's no other choice.
HELLFIRE
MVM
join:2009-11-25

HELLFIRE to nikita Josep

MVM

to nikita Josep
@nikita Josep
Guessing you're the resident tech head / "IT guy" at the office? Or you drew the short straw when the boss
came around and said "I need someone to configure this 2811?"

tired_runner See Profile 's basically handed you what you need to do config-wise, and I can't 2nd ladino See Profile
enough about reading over the forum FAQ for a design and config guide. Cisco's not impossible, but it'll
definately take some doing, and is no substitute for a good network design overall.

I do hope you started this project with a console cable and a terminal emulator program, like Hyperterm.

Regards
quesix
join:2005-12-19
Cary, IL
ARRIS SB6141
Cisco 2851
Asus RT-AC66

quesix to nikita Josep

Member

to nikita Josep
I believe a few faulty assumptions are being made. some things to confirm, would be why 293 vlan? This may be because the ISP in Africa wants packets on WAN tagged with this vlan? 41.59.251.100/30 would normally contain two host the ISP router/switch and customer device, the ISP device is likely on 41.59.251.101, meaning that should be the gateway and 41.59.251.102 put on WAN interface. Is these real IPs or obfuscated? if simple obfuscation of US based IPs it would make more sense, long as last octet is still .100 in assignment, simple search replace can be done on scripts. based on first response i'm assumign CLI with serial cable is not a problem. Also, if already have 200 actual hosts perhaps should be setup with 10.10.10.0/23 network instead of /24, or perhaps this is a homework problem.
nikita Josep
join:2013-07-29
255

nikita Josep

Member

Thank you a lot !