dslreports logo
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
2203
share rss forum feed

hwgasdfasdf

join:2013-08-11
Edmonton, AB

Actiontec V1000H bridge mode DHCP renew problems

I have an Actiontec V1000H in bridge mode, connected to my linux router (which worked 100% fine with shaw for years).

Every few days, my connection drops seemingly because something goes wrong with my DHCP renews on the public interface to Telus (maybe, or maybe it's actually more a DSL problem). Everything is going fine, then suddenly no connection. Can't even ping the default gw assigned by DHCP. Running dhclient manually on the interface tries to send a RENEW, as the lease has not yet expired, but all the traffic is blocked. I originally thought it was the modem, as power cycling the modem would fix the problem, but since I have discovered I don't actually have to touch the modem at all. If I explicitly release and then renew, I get a different IP, sometimes in a completely different range - it usually flips between an address in 75.158.x.x and some other range - looking in my leases file, it actually hasn't been in the other range for a while now, so I don't have the actual address.

I don't care that my IP changes, but it seems Telus just suddenly decides that it must change, right now, and blocks all traffic from my fomer IP, and it has no relation to the dhcp lease I got previously. The most annoying thing is I typically have many SSH sessions open that I was doing work in, and some web based logins as well that will retain the session as long as the IP remains the same, and every time this happens, all of them are dropped.

I talked to support, and while the person tried to be as helpful as she could, I didn't really get anywhere. She said they adjusted something and put a watch on my port for sync losses, and that it shouldn't happen anymore, but it's still doing the exact same thing. Whomever she was talking to that seemed to know more, apparently I couldn't talk to because "they don't talk to customers".

Anyone ever experience this and know how to fix it? I could write a shell script to check for connectivity, and if not, force a DHCP release / renew, but that seems like a real kludge hack. Symtex perhaps?!?


nss_tech

join:2007-07-29
Edmonton AB
All your connections freezing is no surprise. It sounds like you lose the lease on the IP and it gets reassigned to another port and you lose all connectivity yet the modem does not drop it's connection to the port so support won't likely see any problems. Trying to renew the lease more frequently might help. Taking the gateway out of bridge mode could also fix it.

couttsj

join:2010-07-29
Vernon, BC

1 edit
reply to hwgasdfasdf
I experienced a similar problem quite some time ago when I was using the old Siemens SE567. It would simply lose connection, but the lights all stayed green on the modem. Telephone line quality changes over time, and modems are supposed to periodically check line condition and adjust theirs speeds accordingly. When the problem appeared, I pinged a reliable server on the Telus network with packets larger than the default packets:
C:\>ping -n 20 -l 256 smtp.telus.net
Ping statistics for 207.167.198.18:
Packets: Sent = 20, Received = 20, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 111ms, Maximum = 113ms, Average = 112ms
The packets should vary no more than 5ms, and there should be no dropped packets. If not then there is a line quality issue, which surfaces when you are transmitting or receiving large packets. I was operating the SE567 in bridge mode using fixed IP addressing (except for my own router), so DHCP was not an issue. In my case, the problem persisted until Telus upgraded the DSLAM locally.

Edit: I forgot to mention that if the lease renewal does not make it through to the DHCP server, the IP assignment is dropped after it times out.


pfak
Premium
join:2002-12-29
Vancouver, BC
reply to hwgasdfasdf
Based on the behaviour you're experiencing, it sounds like your DSLAM is out of IP address in it's pool.

Symtex or someone else on here would be able to tell you.
--
The more I C, the less I see.

hwgasdfasdf

join:2013-08-11
Edmonton, AB
reply to couttsj
I'm not sure if it is a line quality problem though because when it's working, I can easily get the full speed (25Mbps down). I suppose it could be very intermittent problem, but that seems odd. It's a fresh install, and everything at the dmarc was changed (lightning arrestor, and new DSL filter and splitter at the panel), and new jack with cat5 run for the modem, which is on the other side of the wall from where the dmarc is. There was some scratchiness with the phone before though and I reseated some of the "tool-less" punch downs on the arrestor and the filter. I'd much prefer the old style "real" punchdowns that need a punchdown tool, but apparently the old ones are too slow to install or something. Also, the DSLAM (or what I'm assuming is the DSLAM - large cabinet with UPS on the side) is right across the street from me, so I'm pretty sure it's not a distance issue!

Maybe I'll just phone support back and give them the ticket number from last time and see what they say. Pretty annoying to have a connection that drops and sits there disconnected until I intervene. Definitely will not cut it when I'm away, and need the connection to stay connected for months at a time!

hwgasdfasdf

join:2013-08-11
Edmonton, AB
reply to pfak
Yes, I'm pretty sure Symtex would be of great help to figure this out!

Symtex

join:2005-04-06
Burnaby, BC
kudos:22
I need date/time and phone number by pm. I will get an answer.

hwgasdfasdf

join:2013-08-11
Edmonton, AB
PM sent - good thing for VPN / DNS logs to get a nice tight timestamp on when I got disconnected! Thank you very much Symtex!

bjcsoln

join:2013-08-03
As a side note hwgasdfasdf, can you let us know how you got the router into bridged mode? Did you manage to lock out TELUS before it was upgraded to firmware .57 (or some other approach)?