dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
2056
share rss forum feed


Stanley

@186.1.194.x

1 edit

router cisco 2911 configuration support requiered

hello
i have a pwoblem with my router cisco 2911 please help me, i can`t get internet on it when i ping the default gateway of my isp it don`t reply and i don`t have a internet, i send to you the running config, help me to finish the configuration

Last configuration change at 19:38:48 UTC Wed Aug 21 2013
! NVRAM config last updated at 19:38:51 UTC Wed Aug 21 2013
! NVRAM config last updated at 19:38:51 UTC Wed Aug 21 2013
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname LNBTP-ROUTER
!
boot-start-marker
boot-end-marker
!
!
enable secret 4 ankvj6gkQlGG38PDWdEnQq0Pmn05s1O2WNThWVCzfgo
!
no aaa new-model
memory-size iomem 25
!
no ipv6 cef
ip source-route
ip cef
!
!
!
ip dhcp excluded-address 192.168.1.1 192.168.1.99
!
ip dhcp pool LNBTP-DHCP
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8
!
!
multilink bundle-name authenticated
!
!
crypto pki token default removal timeout 0
!
!
license udi pid xxxxxxxxxxxxxxxx
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
ip address xx.xxx.xxx.xxx 255.255.255.252
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
ip default-gateway xx.xxx.xxx.xxx
ip forward-protocol nd
!
ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 xx.xxx.xxx.xxx
!
!
!
!
control-plane
!
!
!
line con 0
exec-timeout 15 0
password 7 0507080D355C
login
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
exec-timeout 30 0
password 7 110517070302
login
transport input all
!
scheduler allocate 20000 1000
end


TomS_
Git-r-done
Premium,MVM
join:2002-07-19
London, UK
kudos:5
eek

Remove or obfuscate your WAN IP and type 7 passwords....!


TomS_
Git-r-done
Premium,MVM
join:2002-07-19
London, UK
kudos:5

1 edit
reply to Stanley
Are you able to ping the ISP gateway from the router itself?

From the looks of it you are most likely missing the NAT overload statement. Such as:

access-list 100 permit ip 192.168.1.0 0.0.0.255 any
!
ip nat inside source list 100 interface GigabitEthernet0/0 overload
 

Other things I would suggest removing are:

"ip default-gateway 186.1.194.101" Remove this line since you have configured a static default route.

HELLFIRE
Premium
join:2009-11-25
kudos:18
reply to Stanley
Some other cleanup items I'd do :

- "no ip source-route" -- for security reasons
- add "import all" into your DHCP config -- this'll import your ISP's DNS settings to your DHCP clients
- "no ip http server" -- for security reasons

Otherwise, the fix TomS_ See Profile gave will fix your problem.

Regards


TomS_
Git-r-done
Premium,MVM
join:2002-07-19
London, UK
kudos:5
said by HELLFIRE:

- add "import all" into your DHCP config -- this'll import your ISP's DNS settings to your DHCP clients

But only if hes using DHCP to obtain an IP from his ISP though, right?

Since hes statically configured his WAN IP, and has specified a DNS server in his DHCP pool anyway, I wouldnt imagine this would achieve much.


battleop

join:2005-09-28
00000
reply to TomS_
He is missing his overload statement and corroonding acl.