dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
1871
share rss forum feed


Hartflat

@172.242.246.x

[Exede] Exede Modem Hijacks Home Network... Solved!

Greetings,

After over a decade with Hughesnet I moved to Wildblue Exede 12. (Sat Internet is my only option) I considered their Gen4 system, but I have never been satisfied with their reliability & customer service. Exede 12 appeared to have good reviews for what you can expect from satellite internet, so I'm giving it a go & I hope I'll have a better experience with Exede.

Well... after signing on the dotted line & as the installer drove off, I discovered that although I had internet access, the Exede modem appeared to have hijacked all the ip addresses of every device on my home network. Wireless access point, network storage device, printer.. all gone! Gateway & subnet gone as well & nowhere to be found. I tried every network troubleshooting option out there, with no results. I did confirm however that the Exede modem was in fact, the culprit. By removing the modem from the network, ip's were restored & device access returned. Here's the rub.. After days of pleading with Exede customer support to escalate my issue, they insisted that since I had internet access, their end of the agreement was fulfilled & resolving any networking issues caused by their modem was not their responsibility. My network configuration consisted of a desktop computer, a Netgear Network Storage Device, a Netgear WAP & an HP printer all connected to a Netgear Gigabit Ethernet switch.

After brainstorming this dilemma, it occurred to me that maybe the Exede 12 modem was behaving like a thieving, out of control parolee on meth & that my home network needed to be protected from it.. a fence? A firewall? Well how about replacing the switch (an unlocked gate of sorts) with a router.

Bingo!! Problem solved!

The moral of this story? Direct connection of an Exede 12 modem WILL hijack your home network, rendering network devices inaccessible. A hub, switch or direct hardwire to your computer do not appear to be options with Exede (at least not in my case) A router is the way to go.

Too bad that Exede tech support either did not know this, of just failed to share this info with a new customer. They do, however list compatible & incompatible routers on their FAQ page.

That's something Hughesnet would have done. :-(


DrStrangLov

join:2012-03-28

said by Hartflat :

A hub, switch or direct hardwire to your computer do not appear to be options with Exede (at least not in my case) A router is the way to go.

Correct...been that way since 2005....router or direct hookup to one computer.


james1979
Premium
join:2012-10-09
Quinault, WA

1 edit
reply to Hartflat

My Surfbeam 2 actually hijacks my Mac and changes the hostname to my public IP address (which messes up my SMB network). I use zsh as my shell, and my shell prompt is "hostname-time-terminal-current_directory% ". Here's what my terminal looks like as I switch from Exede-12 to HughesNet:

99-19X-XX-XX- 1:47PM-s003 ~% hostname
99-19X-XX-XX.cust.wildblue.net
99-19X-XX-XX- 1:47PM-s003 ~% echo 'switched to HughesNet'; hostname
switched to HughesNet
first_name-last_names-Macbook.local
99-196-63-83- 1:47PM-s003 ~% zsh
first_name-lastnames-Macbook- 1:47PM-s003 ~

(The reason that I started a new shell was to show how my prompt changes back to what it is supposed to be.)

This behavior only started in the last month or two.

Is anyone else running OS X experiencing this weirdness?

Edit: As my signature indicates, this behavior is happening through an Airport Express Wi-Fi router.
--
Gen4 - Beam 51 / Time Capsule (3rd gen), Exede 12 / Airport Express (2nd gen), OS X Snow Leopard



Hartflat

@172.242.246.x

I failed to mention that my desktop is a dual boot Windows 8/Ubuntu Linux system & that my laptop is a MacBook Pro running OS X. The issue occurred on all three systems (SMB & Windows). I believe though, that in this case the operating systems had no control over the hijack. Maybe clearing (releasing) & restoring your ip's & DNS on your OS X, plus re-setting your router may help you. In Windows, that would be "ipconfig /release" then "ipconfig /renew" in the command prompt. ..not sure how to do this on OS X.



Hartflat

@172.242.246.x

Here's a link that may help: »support.apple.com/kb/TS1920

Also, to clear DNS on a Mac:
1. Click Applications.
2. Click Utilities.
3. Double-click the Terminal application.
4. Type the following command: sudo killall -HUP mDNSResponder

To renew your DHCP lease, go to system preferences > Network. Then double click the network connection in question > Go to TCP/IP > Renew DHCP lease. and apply now.



james1979
Premium
join:2012-10-09
Quinault, WA

1 edit

Thanks for the info. The hangup signal idea seemed interesting, but it didn't do anything.

I can't figure out how/why the modem changes my hostname to my public, unresolved IP address (meaning that if I published my public IP address / hostname, then you/anyone could ping that address). This seems like a bug, as it makes no sense to set the hostname of my Mac to my public, unresolved IP address. What is the result when you open a terminal and execute the "hostname" command on your Macbook Pro? I'm wondering if this is a Snow leopard bug, or an Exede "feature" ...

I mean setting the hostname to:

99-19X-XX-XX.cust.wildblue.net

doesn't make any sense. (That address resolves to 99.19X.XX.XX of course.)

It's not a big deal, as I just toggle my Mi-Fi to HughesNet if I want to file share with my Linux or Windows boxes.