dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
941
share rss forum feed

Aens

join:2012-11-09

Twitch problems again! Post ATPIA Aug Drama

Alright. Here we go again. Now that the latest ATPIA drama is over and their operations department can't just shrug it off to another unrelated problem (3rd time now).

Watching Riot's LCS stream on twitch. »www.twitch.tv/riotgames What a great screenshot retelling of a live event. Constant warning from the twitch player telling me that I should lower my quality settings as my internet connection is too slow to handle it.

I am getting the advertised speeds and I have no other problems with my connection.
|---------------------------------------------------------------------------------- --------|
|                                      WinMTR statistics                                   |
|                       Host              -   %  | Sent | Recv | Best | Avrg | Wrst | Last |
|------------------------------------------------|------|------|------|------|------|------|
|                         --------------- -    0 |  207 |  207 |    0 |    0 |    1 |    0 |
|                             10.126.87.1 -    0 |  207 |  207 |    3 |   24 |  172 |    7 |
|                          24.156.143.121 -    0 |  207 |  207 |    6 |   30 |  181 |   15 |
|                            69.63.250.21 -    1 |  203 |  202 |    7 |   26 |  180 |   11 |
|                           69.196.136.68 -    1 |  203 |  202 |    5 |   25 |  177 |    9 |
|                 tge6-1.fr4.yyz.llnw.net -    0 |  207 |  207 |    5 |   29 |  183 |   11 |
|                    ve5.fr3.yyz.llnw.net -    1 |  203 |  202 |    5 |   29 |  179 |   12 |
|                 tge8-1.fr3.lga.llnw.net -    0 |  207 |  207 |   24 |   46 |  204 |   28 |
|                   No response from host -  100 |   41 |    0 |    0 |    0 |    0 |    0 |
|                   No response from host -  100 |   41 |    0 |    0 |    0 |    0 |    0 |
 
Expand your moderator at work

34764170

join:2007-09-06
Etobicoke, ON
reply to Aens

Re: Twitch problems again! Post ATPIA Aug Drama

I'm on cable. When going to that channel it never shows anything except "Loading channel data...". I tried 6 other channels and they were all in HD and smooth.

Aens

join:2012-11-09

2 edits
reply to rogersmogers
There is no alternative to twitch and it is a unique product. Also, Playstation 4 will have built in twitch integration. Teksavvy, fix this or this will be yet another preventable problem.

Twitch is also the official streaming partner of Blizzard, Riot, SoE and soon Playstation Network. This problem is also unique to Teksavvy.

I have 3 other friends watching it right now with no problems. Bell Fibe down the street, Wind Mobile tethered and someone else in the US. I am currently watching on my phone via mobilicity 3.5g so it wont stutter during clutch moments. I get better performance when tethered to my phone too.

34764170

join:2007-09-06
Etobicoke, ON
Oh I see after trying on another computer; the usual Flash garbage. Unlike the other channels it required newer Flash.

Anyway, it was also completely smooth.


rodjames
Premium
join:2010-06-19
Gloucester, ON
reply to Aens
That stream is fine for me.

34764170

join:2007-09-06
Etobicoke, ON
reply to Aens
said by Aens:

I have 3 other friends watching it right now with no problems.

and there are TSI customers watching it now with no problems. So it'll take a bit more digging to figure out what is wrong.

Where are you even located?

Aens

join:2012-11-09
toronto atpia. The stream is fine now as it is off peak with less popular teams playing. Twitch is fine at off peak times. When its the good stuff, 250k plus viewers, only I have problems viewing.

Arcturus

join:2008-04-18
London, ON

1 edit
reply to 34764170
I get pauses and shitty streaming on 'source' level res. The high res seems fairly stable, and obviously lower ones are working fine

High quality stuttering all over for me now...

On a site note twitch has been horrible for me since summertime.

P.S. Also would like to make sure the numpties not having problems, are probable on a default medium setting or something..

sakraycore

join:2008-01-08
Scarborough, ON

1 edit
reply to Aens
To OP:

There is still some level of congestion that speedtest will not show that speedof.me shows during peak times. During peak time what you will also notice is packet loss.

Rogers is still doing crap in the background like fibre cutting and stuff. I didn't really notice any problems with twitch however I don't really watch stuff on twitch.tv I only use it to create instant videos kinda like using fraps and then compress it with windows movie maker then uploading to youtube except that with twitch.tv i only need to stream and then twitch.tv saves it automatically and I can create a highlight with previously broadcasted footage.

Route to the same destination seems to be slightly different for me, namely one less node:

|---------------------------------------------------------------------------------- --------|
| WinMTR statistics |
| Host - % | Sent | Recv | Best | Avrg | Wrst | Last |
|------------------------------------------------|------|------|------|------|------|------|
| unknown - 0 | 107 | 107 | 0 | 0 | 2 | 0 |
| 10.126.128.1 - 0 | 107 | 107 | 7 | 8 | 12 | 7 |
| 24.156.136.173 - 0 | 107 | 107 | 8 | 11 | 36 | 12 |
|pos-1-0-0.gw01.mtmc.phub.net.cable.rogers.com - 0 | 107 | 107 | 8 | 11 | 27 | 11 |
| 69.196.136.74 - 0 | 107 | 107 | 8 | 10 | 40 | 10 |
| gw-llnw.torontointernetxchange.net - 0 | 107 | 107 | 8 | 15 | 30 | 14 |
| tge8-1.fr3.lga.llnw.net - 0 | 107 | 107 | 23 | 27 | 38 | 24 |
|________________________________________________|______|______|______|______|______|______|
WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider

It seems to happen a lot. During peak times I often noticed going through one additional node where packet loss occurs enroute to the destination. Sometimes I would go through 69.x.x.x twice whereas during offpeak times I would only go through 69.x.x.x once which suggests that the routing is actually different during offpeak and peak.


rodjames
Premium
join:2010-06-19
Gloucester, ON
reply to Aens
DO NOT USE SPEEDOF.ME IT IS WRONG.

DigitalRain

join:2013-03-16
said by rodjames:

DO NOT USE SPEEDOF.ME IT IS WRONG.

The problem with speedof.me is that there's no way of controlling where you test to. Without this information, it's impossible to ascertain the bottleneck that's resulting in poor Internet throughput. Determining the source of the bottleneck requires finer testing than a speed testing website is capable of offering, but running a test without even knowing where you are testing tells you nothing about the quality of the Internet connection provided by your ISP or its last-mile vendors. It simply tells you that there's a routing problem somewhere between 151 Front Street and Intercourse, Georgia. Hee-haw!

sakraycore

join:2008-01-08
Scarborough, ON
said by DigitalRain:

said by rodjames:

DO NOT USE SPEEDOF.ME IT IS WRONG.

The problem with speedof.me is that there's no way of controlling where you test to. Without this information, it's impossible to ascertain the bottleneck that's resulting in poor Internet throughput. Determining the source of the bottleneck requires finer testing than a speed testing website is capable of offering, but running a test without even knowing where you are testing tells you nothing about the quality of the Internet connection provided by your ISP or its last-mile vendors. It simply tells you that there's a routing problem somewhere between 151 Front Street and Intercourse, Georgia. Hee-haw!

The routing is fine, I get over my profile speed during offpeak times.

Arcturus

join:2008-04-18
London, ON
Aftwer 7PM, twitch, stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter stutter

34764170

join:2007-09-06
Etobicoke, ON
Yet it is completely smooth for me and no its not on the default setting.


oneoneonetwo

@peer1.net
reply to Arcturus
Twitch is ... twitchy. Unless it's something with their "vendor", I'm not sold this is a Teksavvy problem entirely. Some streams are fine, others don't play at all. Maybe some streams are using newer versions of their player or something?

OP's stream for example does not play but others do.

OP:

GET /find/riotgames.json?nauthsig=2012c9387200da0c8df66ec32d92e4a5a6f94e14&private_code=null&nauth=%7B%22

Referer: »www-cdn.jtvnw.net/swflibs/Twitch···37ab.swf

HTTP/1.1 200 OK

Server: nginx
Date: Thu, 05 Sep 2013 00:01:09 GMT
Content-Type: application/json
Content-Length: 2
Connection: keep-alive
via: usher24:8935
[]

Doesn't work. Home page however :

GET /find/esg.xml?type=any&p=746265&group= HTTP/1.1
Referer: »www-cdn.jtvnw.net/widgets/live_f···0751.swf

HTTP/1.1 200 OK
Server: nginx
Date: Thu, 05 Sep 2013 00:03:17 GMT
Content-Type: text/xml
Transfer-Encoding: chunked
Connection: keep-alive
via: usher21:8934
Content-Encoding: gzip

2fb

.. Does work. Few streams I tried are the same thing. Different player versions. I'd say Twitch needs to lay off the crack.

34764170

join:2007-09-06
Etobicoke, ON
said by oneoneonetwo :

Twitch is ... twitchy. Unless it's something with their "vendor", I'm not sold this is a Teksavvy problem entirely. Some streams are fine, others don't play at all. Maybe some streams are using newer versions of their player or something?

OP's stream for example does not play but others do.

The stream posted by the OP requires really recent versions of Flash unlike the handful of random other streams I tried out.