dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
1296
share rss forum feed


Jim_in_VA

join:2004-07-11
Cobbs Creek, VA
kudos:4
Reviews:
·Metrocast Commun..

FYI .. Sprint discontinues the U770

Now supports the NetGear 341U ... which, at this date, is Not supported by Cradlepoint routers. Millenicom is now shipping Netgear devices ... not the U770.
--
... need help? »evdo-tips.com/


Jack_in_VA
Premium
join:2007-11-26
North, VA
kudos:1
Think Millenicom will ship me a new Netgear 341U to replace my discontinued 770?

Darn I just got the 770.


Jim_in_VA

join:2004-07-11
Cobbs Creek, VA
kudos:4
ain't gonna happen


Jack_in_VA
Premium
join:2007-11-26
North, VA
kudos:1
Any idea what triggered this? Problems with the 770?


Jim_in_VA

join:2004-07-11
Cobbs Creek, VA
kudos:4
no problems at all with the U770 ... tech moves on ... probably faster than we want it to
--
... need help? »evdo-tips.com/


Jack_in_VA
Premium
join:2007-11-26
North, VA
kudos:1
Agree with that


xrayman

join:2008-12-09
Kansas City
kudos:1
reply to Jim_in_VA
This is very good news!
The Netgear 341U will receive Sprint/Clearwire TD-LTE at 2.5 GHz that will offer spectacular speed. Some of the Clear LTE sites are now on the air in parts of the country.
Also it will receive Sprint LTE on the 800 MHz band along with the Sprint 1900 MHz LTE.
The 341U has two external antenna ports on the bottom for use by ones in a weak signal area.
Shortly Cradlepoint will have new firmware that supports the 341U. They will put you on an email list to be notified when it is available.

logistiker

join:2013-05-29
reply to Jim_in_VA
I disagree completely with the "no problems at all with the U770". I got the u770 from Millenicom when they first started offering it in June 2013 and I have had nothing but problems with it. It randomly loses all the signal strength on an LTE connection and a lot of times will just hang with no signal strength. If I unplug the modem and plug it back in, it might or might not come back but if it does, it comes back to 3 or 4 bars on LTE (expected strength). The loss of signal strength with a hang occurs with or without an external antenna connected when I'm at home or traveling somewhere. In addition, IPPT (IP Passthrough) does not work properly on the modem. It will assign the external ip address to the computer but will not set up the default route. I contacted Franklin Wireless about it and they assured me it works which is a complete lie since I tested it on different dhcp clients and it still does not set up the default route. Franklin Wireless modems in general are crap. I was glad to get LTE at the time but I was apprehensive of it being a Franklin Wireless modem because I also had a 3G Franklin Wireless 680U before that also turned out to be defective. It is not surprising that Sprint discontinued this modem at all. It's likely due to the number of problems their customers have had with it.

Dexter1992

join:2010-07-16
Winona, MN
The U770 is very problematic with USB ports, it uses the RNDIS driver for Windows. I use mine in a MBR-95 and have had no issues, as CP probably optimized it to function better with it. I am not surprised it was discontunied because if I had issues, many others have. However, the modem is no trouble to me through the Router. Then again, is your USB Root Hub and USB Host Controller drivers installed? You need to make sure you aren't using M$ generic drivers.


Jack_in_VA
Premium
join:2007-11-26
North, VA
kudos:1
Reviews:
·Millenicom
reply to logistiker
The U770 is working ok for me. Previously I had a CDU-680 which also worked just fine. Every persons experience may or may not be positive but it's not a reason to blanket condemn the U770. I've had 2 firmware updates since getting it and one has to assume Franklin is addressing any problems.




Jim_in_VA

join:2004-07-11
Cobbs Creek, VA
kudos:4
Reviews:
·Metrocast Commun..
reply to logistiker
not to denigrate your problems and issues with the U770, but I have never had a problem using it via USB or in a MBR95 router. Computer configurations are wildly different between users, mine works .. yours does not.
--
... need help? »evdo-tips.com/