dslreports logo
 
    All Forums Hot Topics Gallery
spc
Search similar:


uniqs
574

gw66
@verizon.net

gw66

Anon

[HELP] classification

hey guys i'm finally getting back to this project and just had a question

i have r1 & r2 both setup and using say 1.1.1.1 as vip for hsrp . both routers are going to two different pops. both routers are also setup with ibgp . I have two questions ..

for hsrp hw redundancy: .if i loose r1 ( primary( priortiy 110 ) r2 ( priority 50 )picks up traffic but what path does it take after it leaves the gw of r2 ?

for isp line loose. Does r1 stay the primary and just forwards traffic over to r2 via ibgp then out the gw of r2?

Also how would i test both scenerios to ensure it works? I would think for hsrp just unplug r2 , but how would i test if the isp line went down ?

TomS_
Git-r-done
MVM
join:2002-07-19
London, UK

TomS_

MVM

Thought I covered this in my last post. :-P

Depends how iBGP is set up. You might like to take another look at the things I said about localpref.

Depending on which router has the more favourable localpref, traffic will route that way.

If you lose the router, then traffic has no option but to go via the other router. If you lose an ISP link then traffic should automatically start routing over to the other link, so long as you were also using eBGP to your ISP. Traffic will still route in to your primary HSRP router as long as it is up and running. HSRP only provides gateway protection, it doesnt care about anything else that happens on the router.

You can test it by simply unplugging the cable for the ISP line, causing the interface to go down. Or shut the interface. Or shut the eBGP session. Either way you should get the same result.

gw66
@verizon.net

gw66

Anon

OK, i was thinking to deep into it. thanks.

so if i unplugged the isp line on r1 outbound traffic will still use r1 the primary in my hsrp setup (because the hardware was not at fault ?)but still isp link one is down so( like you said) it has no choice but to route to r2 and out it's gw?

do i have that right. Sorry for sounded like a broken record.

I dont want to start with favourable localpref just yet. 1 step at a t time with me. i'm slow:) but as you can see i like to understand things in full before i move on.

thanks TomS_

TomS_
Git-r-done
MVM
join:2002-07-19
London, UK

TomS_

MVM

Yes that is correct.

localpref probably only really matters if r2 took over as the HSRP active router and the ISP connection on r1 was still operational. In that case, localpref would work to ensure that traffic still exited your network via r1.

Otherwise you might find that each router prefers the routes it receives directly via eBGP. Without a localpref tweak, any traffic that comes in to r2 will simply route out of r2's ISP connection, and likewise r1 will route traffic out via its ISP connection.

localpref is a method of traffic engineering to make the network work the way you want, rather than how it would otherwise figure it out itself.

gw66
@verizon.net

gw66

Anon

cool that's what i figured, and maybe when i get this working i'll play around with that and have my ipsec traffic take one path and web traffic take another. Next week i should have my config setup.
thanks again!!

TomS_
Git-r-done
MVM
join:2002-07-19
London, UK

TomS_

MVM

Thats going to be more of a policy routing thing than BGP.

gw66
@verizon.net

gw66

Anon

Ok so i finally was able to work on my config today and this is what i got. I shows bgp is up but i don't see it in my sh ip route. below are both configs TomS_

How can i even test this to ensure it works before i go live? I already tested my hsrp config and that works perfect. thanks for you time

r2 config

loopback 0
ip address 10.18.3.2 255.255.255.255
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description O - [100MB] ISP-PATH2
ip address 1.1.1.1 255.255.255.252
load-interval 30
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1.1
description [LAN] Hand Off - HSRP Interface
encapsulation dot1Q 1 native
ip address 2.2.2.2 255.255.255.224
standby 0 ip 2.2.2.1
standby 0 priority 85
standby 0 preempt
standby 0 authentication 1234
standby 0 track 1 decrement 40
!
interface GigabitEthernet0/1.2
description ISP Service 2
encapsulation dot1Q 2
ip address 3.3.3.3 255.255.255.248
!
router bgp 64611
bgp router-id 10.18.3.2
bgp log-neighbor-changes
neighbor IBGP peer-group
neighbor IBGP remote-as 64611
neighbor IBGP password 7 @@@@@
neighbor IBGP update-source Loopback0
neighbor 10.18.3.1 peer-group IBGP
!
ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 6.6.6.6
ip route 10.18.3.1 255.255.255.255 3.3.3.3

R1 config
loopback 0
ip address 10.18.3.1 255.255.255.255
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description OMSC - [89MB]-Circuit # 01ghkg
ip address 4.4.4.4 255.255.255.252
load-interval 30
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1.1
description [LAN] Hand Off -HSRP interface
encapsulation dot1Q 1 native
ip address 2.2.2.4 255.255.255.224
standby 0 ip 2.2.2.1
standby 0 priority 110
standby 0 preempt
standby 0 authentication 1234
standby 0 track 1 decrement 40
!
interface GigabitEthernet0/1.2
description ISP Service 2
encapsulation dot1Q 2
ip address 3.3.3.4 255.255.255.248
!
router bgp 64611
bgp router-id 10.18.3.1
bgp log-neighbor-changes
neighbor IBGP peer-group
neighbor IBGP remote-as 64611
neighbor IBGP password 7 $$$$$
neighbor IBGP update-source Loopback0
neighbor 10.18.3.2 peer-group IBGP

ip route 0.0.0.0 0.0.0.0 7.7.7.7
ip route 10.18.3.2 255.255.255.255 3.3.3.4

r2 bgp summary

#sh ip bgp summary
BGP router identifier 10.18.3.1, local AS number 64611
BGP table version is 5, main routing table version 5

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.18.3.2 4 64611 51 50 5 0 0 00:42:46 0

r1 bgp summary

sh ip bgp summary
BGP router identifier 10.18.3.2, local AS number 64611
BGP table version is 3, main routing table version 3

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.18.3.1 4 64611 52 53 3 0 0 00:44:31 0

!

TomS_
Git-r-done
MVM
join:2002-07-19
London, UK

TomS_

MVM

What is it that you arent seeing in your routing table?

Could you perhaps attach the full configs in text files rather than a cut down version.