dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
971
share rss forum feed


fixitman

@sbcglobal.net

DSL Connection breaks after 1 hour and Cisco Router wont connect

Hi,

We have had DSL Extreme at our church building for years, and it has worked well. Recently, we started having problems staying connected. DSL Extreme replaced the modem, and we replaced the Cisco 800 Series Router/Firewall, but are still having the same problem. Here is the problem (which we did NOT use to have):

1. DSL Modem connects to the Internet (it is a comtrends 5072T modem)
2. Cisco 800 Series connects to the DSL modem and picks up an IP Address and works fine
3. After 1 hour (approximately), any device connected to the Cisco cannot connect to the Internet.
- power cycling the Cisco will then allow everyone to connect again.

It would appear that maybe the DSL modem is handing out a new IP Address every hour, and somehow the Cisco doesn't know how to refresh that. If that is the case, DSL Extreme didn't used to do this.

Have tried resolving this with call support at DSL Extreme, but they say that everything is working on their side and wont kick it up to a higher level of support.

At any rate, any ideas on how to fix this, or to get the DSL Extreme modem to just keep the same IP Address once it is connected?

Thanks.


NormanS
I gave her time to steal my mind away
Premium,MVM
join:2001-02-14
San Jose, CA
kudos:12
Reviews:
·SONIC.NET
·Pacific Bell - SBC
I am not familiar with that Comtrend modem. I had an ADSL connection with AT&T since before SBC bought them, and had to replace a bricked modem with a newer model; a Siemens SpeedStream 4100. This new modem had some optional settings, including, "Connect on demand", and "Always attempt to connect". The first would behave similar to your description; it would detect no activity and disconnect. Then, when there was activity, there would be trouble re-connecting. By using the "Always attempt to connect" setting the modem would attempt to re-connect if the connection was lost.

So check your modem, or your router for something similar.

BTW, my new ISP, Sonic.net, has given me a single static IP address free (a "/32"). It is one of their options. I believe DSLX does offer a block of static IP addresses (a "/29", which has 5 routeable IPv4 addresses) at an additional fee, which could be useful. A static IP address should not require a CPE "keep alive" setting.
--
Norman
~Oh Lord, why have you come
~To Konnyu, with the Lion and the Drum

jscarville
Premium
join:2013-09-21
Glendora, CA
reply to fixitman
I had a similar problem with fixed IPs that are not the primary one. It was repeatable enough that I could call it a "feature" of the DSL Extreme network. Long story made short, I diagnosed it as the gateway device not sending arp requests after about an hour. I opened a ticket with support but was told that "we" cannot fix that. Then some numbskull tried to blame my DHCP even though I made it clear I had static IP addresses.

Fortunately, I use a linux box as my gateway and firewall so I was able to workaround the problem by sending "arp" pings to the gateway every few minutes. This is similar to the "proxyarp" used by some routers and firewalls. I don't know if that will work on a dynamic (DHCP) address or if the Cisco 800 even supports it but it might be worth a look.


dslx_nick
Premium,VIP
join:2011-12-24
Chatsworth, CA
kudos:28
By default, the Comtrend modems we send out are in Bridged mode - in other words, the IP doesn't get assigned to the modem at all (it gets assigned to the router connected to it). So the modem typically wouldn't be set to Connect on demand vs. Always attempt to connect; those settings would typically be set in the router.

Jscarville is on a Verizon circuit, and I would guess that fixitman is on an AT&T circuit, so... presumably you two are on entirely different equipment, making it less likely the issue is caused by a shared piece of equipment. (For that matter, if one of our servers were causing that issue, we'd probably be deluged by calls from customers having the same issue.) Curious. Fixitman, would you mind sending me an IM with your account information?


fixitman

@sbcglobal.net
Thanks everyone for your responses. @dslx_nick - will send you the information on the account.

Last night, I discovered an interim fix. If I run a Linksys Router (its an older WRT54G, and I just set up a DMZ for the Cisco) between the DSL Modem and the Cisco Router, I don't have the same problem. Everything seems to stay connected. Kind of speaks to the issue that you may have had @jscarville. Seems that whatever the Linksys does, it does differently than the Cisco 800 Series. (of course the really weird thing is that all of this used to work without any problem)

Thanks.


dslx_nick
Premium,VIP
join:2011-12-24
Chatsworth, CA
kudos:28
After investigating... I'm not seeing any relation between fixitman's account and jscarville's account. Completely different in just about every way.

However, checking Cisco's support forums does turn up a surprising number of posts over the years of users encountering the same issue (disconnects after exactly one hour). Most common successful advice seems to be: upgrade to the latest firmware, and if issue persists reset to factory default and reconfigure. One of the odder fixes that worked for someone was to change the local IP range; instead of assigning 192.168.1.1 to the router and 192.168.1.2+ for the other devices, change it to something else (such as 192.168.2.1, 192.168.2.2+). You may want to give those a shot, if you don't want to keep the workaround in place.