dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
1242
share rss forum feed

ssmithereens

join:2013-10-27
Toronto, ON

[Internet] Sagemcom 2864 port forwarding from internal ip is blocked

With Bell, port forwarding from a device on your local network to another device on your local network using an external host name that points to the modem's WAN IP is blocked by the modem. Instead of passing throug, it redirects to a modem authentication page. Port forwarding from an outside address works fine.

(There is an earlier thread on this topic, but because I am a new member I could not post to it, and started this new thread as I think this info could be useful to others who struggle with this problem.)

This is annoying, since you have to remember to use the local ip. So for example if you have a webserver like mywebserver.mydomain.ca that you port map through to 192.168.1.10, you have to use the local ip address to access the server when you are on your local network instead of the hostname. Ugh.

I have found a workaround that avoids having to set-up bridge mode and use an external router, which is the solution others have had to resort to in the earlier thread. Here's what I did:

1. Install the awesome line stats and unlock tool referenced here: »Line Stats & Telnet Unlock Tool for Sagemcom 2864 (V2.00) This will enable telnet access to the modem with a command shell.

2. Telnet to the modem (user: admin, pw: admin, at 192.168.2.1)

3. type "system shell" at the command prompt

4. type "cd /mnt/jffs2"

5. Edit the hosts file in this directory using "vi hosts". You can find references online about how to navigate through vi, but basically all you need to do is press "i", type in an entry for your server with the local ip address e.g. "192.168.2.10 mywebserver.mydomain.ca", hit enter, hit ESC, type ":w" to write the file and type ":q" to quit vi.

6. Type "reboot" to reboot the modem

7. Voila. Now instead of resolving to the public ip address, the router in the modem will resolve the ip for the server's domain name using it's local address. (There will be no impact to users outside your local network.)

Hope this helps people.



HiVolt
Premium
join:2000-12-28
Toronto, ON
kudos:21

Yeah this has never worked in the Sagemcom. As well as many other things, hehe.
--


optimo8

join:2011-03-24
reply to ssmithereens

Can this help me configure RDP? I used to be able to remote desktop from outside the network to my home computer using my no-ip.org account. But since getting the Sagemcom modem, I can't use RDP at all.


ssmithereens

join:2013-10-27
Toronto, ON

I don't think so. For me, coming into my local network from outside using no-ip.org and the appropriate port forwarding mappings works fine with Sagemcom. It's only when I want to access a machine on my local network using an external host name that I had a problem.