dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
3122
share rss forum feed


Sweet Witch
Be the flame, not the moth.
Premium,MVM
join:2003-07-15
Gallifrey

[WIN7] Printer IP wrong, how to change?

Ok, Win7 x64, Verizon FIOS modem, Brother HL-2270DW printer.

When I go to print something, it says the printer is on 192.168.1.2, but when I look in both the modem and printer settings they both say 192.168.1.4. I can't print anything.

How do I get W7 to grasp that the printer is at .4 instead of .2? .2 is another computer btw.
--
"While you can teach an old dog new tricks, you simply can't teach him to be a cat."

"Are you my Mummy?"



darcilicious
Cyber Librarian
Premium
join:2001-01-02
Forest Grove, OR
kudos:4

It might be as simple as rebooting the W7 computer.



Oregonian
Premium
join:2000-12-21
West Linn, OR
Reviews:
·Comcast
reply to Sweet Witch

Click for full size
darcilicious See Profile gave you a good suggestion but it might also be necessary to uninstall and then reinstall the printer software in Windows so that it can properly identify the printer's IP address.

What do you see if you go to the printer properties (Start -> Printers and Devices -> double-click on your printer)?


Sweet Witch
Be the flame, not the moth.
Premium,MVM
join:2003-07-15
Gallifrey
reply to darcilicious

Just did, no change.



Sweet Witch
Be the flame, not the moth.
Premium,MVM
join:2003-07-15
Gallifrey
reply to Oregonian

said by Oregonian:
What do you see if you go to the printer properties (Start -> Printers and Devices -> double-click on your printer)?
192.168.1.2
--
"While you can teach an old dog new tricks, you simply can't teach him to be a cat."

"Are you my Mummy?"


Oregonian
Premium
join:2000-12-21
West Linn, OR

You could try clicking on "Add Port" and add the .4 port. Then select it and deselect the .2 port and see if it works.



billaustin
they call me Mr. Bill
Premium,MVM
join:2001-10-13
North Las Vegas, NV
kudos:5

1 recommendation

reply to Sweet Witch

You need to set your printer so that it always has the same IP address, otherwise this will continue to happen.

Either set a static IP in the printer, or do an IP reservation in the router so that it always hands out the same address to the printer.

After that, remove and reinstall the printer so that the PC finds the printer at the new address.


dave
Premium,MVM
join:2000-05-04
not in ohio
kudos:8
Reviews:
·Verizon FiOS
reply to Sweet Witch

Then change it. Use "configure port"

Note that the port may well be *named* 192.168.1.2 as well as having the *address* 192.168.1.2.

What you need to change is the address, and not necessarily the name. I'd try setting the name to something more useful, like "mylaser".


dave
Premium,MVM
join:2000-05-04
not in ohio
kudos:8
Reviews:
·Verizon FiOS
reply to billaustin

Maybe, maybe not. I use DHCP but on the other hand my verizon-supplied Actiontec router has a very strong tendency to always assign the same IP address to any given MAC. I think you actually need to go and delete entries on the router to make it reuse an IP address.

You're not wrong: a static IP would do the job for sure. But I for one am too lazy to use the manual route; my DHCP-assigned printer address has worked for years.


ajwees41
Premium
join:2002-05-10
Omaha, NE

can't you just share it via the network as a local printer?



darcilicious
Cyber Librarian
Premium
join:2001-01-02
Forest Grove, OR
kudos:4
Reviews:
·Frontier FiOS

said by ajwees41:

can't you just share it via the network as a local printer?

That's what the OP is doing. But unless the computer knows the printer's correct IP address, the computer won't print to it. That's what an IP address does -- it's a "network address".
--
♬ Dragon of good fortune struggles with the trickster Fox ♬


Sweet Witch
Be the flame, not the moth.
Premium,MVM
join:2003-07-15
Gallifrey
reply to dave

I tried to change it but it wouldn't let me. Thankfully reinstalling it seemed to have done the trick. Networking is just SOOO much fun!
--
"While you can teach an old dog new tricks, you simply can't teach him to be a cat."

"Are you my Mummy?"


dave
Premium,MVM
join:2000-05-04
not in ohio
kudos:8
Reviews:
·Verizon FiOS

said by Sweet Witch:

I tried to change it but it wouldn't let me.

Odd. I have the exact same printer, and Windows 7, and was able to change the address.


Oregonian
Premium
join:2000-12-21
West Linn, OR
reply to Sweet Witch

Glad that you got it fixed.



Sweet Witch
Be the flame, not the moth.
Premium,MVM
join:2003-07-15
Gallifrey
reply to dave

I could change the name but not the location.



natedj
Elected
Premium
join:2001-06-06
Columbia, SC

1 recommendation

reply to dave

said by dave:

said by Sweet Witch:

I tried to change it but it wouldn't let me.

Odd. I have the exact same printer, and Windows 7, and was able to change the address.

Same here, I have the same printer and had my router assign an IP to the printers MAC address some years ago and never had any trouble since. Even when moving from Win7 to Win8 to Win8.1
--
Good judgement comes with experience...Experience comes after bad judgements


Kilroy
Premium,MVM
join:2002-11-21
Saint Paul, MN

2 recommendations

reply to ajwees41

said by ajwees41:

can't you just share it via the network as a local printer?

Because that is the wrong way to do it. The printer is on the network and not connected to the machine. The method of connecting is to print to the IP address, not a share.

Sweet Witch See Profile, there are a couple of things you can do to prevent this from happening in the future.

1. Set the printer to a static IP address. This should be as simple as going to the address in your web browser and then changing the address from DHCP to a static address.

2. Set up a reservation on your router so that the printer always gets the same static IP address. Go into your router, look at the DHCP settings for the MAC address of the printer and see if you can set a reservation.

If you do this, you have your bases covered. The only other recommendation I would make would be to set your printer IP address to be outside of your DHCP range. Since you seem to be using the lower part of the range if you set the printer to be 192.168.1.70 you won't have a problem with having its DHCP address assigned to another device if its lease expires and is not renewed on time.
--
"Progress isn't made by early risers. It's made by lazy men trying to find easier ways to do something." - Robert A. Heinlein


natedj
Elected
Premium
join:2001-06-06
Columbia, SC
reply to Sweet Witch

n/m



Konaguy
Live From Kailua-Kona, Hawaii
Premium
join:2000-10-21
Kailua Kona, HI

1 recommendation

reply to Sweet Witch

I had problems printing to my network printer too, which I resolved by reinstalling the drivers. This happened quite frequently, so I did some research. I was able to login in my HP printer by using the currently assigned DHCP IP address and changing it to a static IP address.

»tinyurl.com/pwect7d



NormanS
I gave her time to steal my mind away
Premium,MVM
join:2001-02-14
San Jose, CA
kudos:11
Reviews:
·SONIC.NET
·Pacific Bell - SBC
reply to ajwees41

said by ajwees41:

can't you just share it via the network as a local printer?

I would assume that the printer does not have a direct local (USB, or IEEE-1284) connection; so there is nothing to "share".

The problem is to configure the printer port in the printer properties so that the driver is pointing to the correct network location, defined by an IP address.

In the following screen shot are two printers. The HP Photosmart C6100 series has no IEEE-1284 port, and the USB port is unused; there is an Ethernet cable to a router. The HP LaserJet 5P has no Ethernet port, but the IEEE-1284C port is cabled to an IEEE-1284 port on a Netgear router/print server. The named TCP/IP ports are associated to two IP addresses which are assigned by DHCP reservation from an ASUS router. The respective printer drivers print to the respective IP addresses.

The ports can be changed systemically, and not really difficult to do; but damned inconvenient, if it has to be done on every system reboot. The solutions offered by the posters recommending static assignment of the printer IP address are the ideal method.

Networked printers.

--
Norman
~Oh Lord, why have you come
~To Konnyu, with the Lion and the Drum


Sweet Witch
Be the flame, not the moth.
Premium,MVM
join:2003-07-15
Gallifrey

Ok, well, the stupid thing switched itself back to 192.168.1.2.

How exactly do I set a static IP? In the router or printer?
--
"While you can teach an old dog new tricks, you simply can't teach him to be a cat."

"Are you my Mummy?"



NormanS
I gave her time to steal my mind away
Premium,MVM
join:2001-02-14
San Jose, CA
kudos:11
Reviews:
·SONIC.NET
·Pacific Bell - SBC

said by Sweet Witch:

Ok, well, the stupid thing switched itself back to 192.168.1.2.

How exactly do I set a static IP? In the router or printer?

I would look at the router first. I have had several, from an SMC Barricade 7004BR with the last firmware update to my current Asus RT-AC66U, which allow to configure DHCP reservation.

If the router is not so capable (and I imagine only older routers are lacking), you should be able to limit the DHCP range; then manually assign an IP address outside of that range to the printer.
--
Norman
~Oh Lord, why have you come
~To Konnyu, with the Lion and the Drum


Sweet Witch
Be the flame, not the moth.
Premium,MVM
join:2003-07-15
Gallifrey

I'm using the verizon modem/router.



Sweet Witch
Be the flame, not the moth.
Premium,MVM
join:2003-07-15
Gallifrey
reply to NormanS

Ok, I set it to static in the printer, will that over-ride the modem/router?



NormanS
I gave her time to steal my mind away
Premium,MVM
join:2001-02-14
San Jose, CA
kudos:11
Reviews:
·SONIC.NET
·Pacific Bell - SBC

said by Sweet Witch:

Ok, I set it to static in the printer, will that over-ride the modem/router?

Does the gateway allow you to configure the range of assigned IP addresses? I don't know how that device handles IP addresses if a manual assignment overlaps the DHCP pool.
--
Norman
~Oh Lord, why have you come
~To Konnyu, with the Lion and the Drum

dave
Premium,MVM
join:2000-05-04
not in ohio
kudos:8

What kind of router is it?

My Verizon FIOS actiontec doesn't need any mollycoddling to assign sticky IP addresses; it simply does.



norwegian
Premium
join:2005-02-15
Outback
reply to Sweet Witch


Have you tried flushing the DNS cache on this computer that isn't reading the printer properly?

Also, check the printer has the latest firmware.
--
The only thing necessary for the triumph of evil is for good men to do nothing - Edmund Burke



Kilroy
Premium,MVM
join:2002-11-21
Saint Paul, MN
reply to Sweet Witch

said by Sweet Witch:

Ok, I set it to static in the printer, will that over-ride the modem/router?

Yes, since it is no longer requesting a DHCP address from the modem/router. The only time you might have an issue, and why I suggest doing both, is if the printer loses power and its settings. Normally setting a static IP address on the printer outside of the DHCP range is sufficient.
--
"Progress isn't made by early risers. It's made by lazy men trying to find easier ways to do something." - Robert A. Heinlein


fxtr
Premium
join:2002-09-15
Reston, VA
reply to Sweet Witch

You can set a Static Lease Type to the printer in the FIOS Actiontec Router even if the IP is within the range of assignable IP address. The router will always assign the same static IP to the printer when it requests an IP.
Under Advanced tab, IP Address Distribution, Connection List, edit the printer and select the Static Lease Type check box.
I have two printers, PC and a network disk set up this way and I don't have to deal with IP addresses changing when they have been off for some time



cowboyro
Premium
join:2000-10-11
Shelton, CT

1 recommendation

reply to Sweet Witch

Don't ever give dynamic IPs to printers, you are asking for trouble. Set it for a static IP and be done - just make sure you are either outside the DHCP scope or assign it a reservation in the DHCP server.