dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
2307
share rss forum feed

redgrandam

join:2010-08-10
London, ON

[Networking] HT1000 double NAT error on router

Hey guys. I'm sorry if I'm posting in the wrong spot, but this was the best suited spot I think I could find

I'm pretty new to the satellite internet world, but it was the only choice in our new house. I'm in canada, so I'm on Xplornet, and as of a few weeks ago my router started giving a 'double NAT' error. I've had the service for almost a year and this is a new error, and I don't believe I changed anything to cause this.

My setup is simple, just the modem (HT1000), ethernet to my router (Apple Airport Extreme), then other devices connected to the airport.. I've gone through my settings, and although my service is working, it's very slow at times, but I'm not sure it's related.

I can put my router in bridge mode like the error asks me to do, and things still work, but it just messes up all my IP addresses on the network which is a pain.

Router is currently in "DHCP and NAT" mode, other options are "DHCP", or "off (bridge mode)".

Can anyone suggest what is causing this? and confirm what settings I should be using for this modem? Thanks for any help!



dbirdman
Premium,MVM
join:2003-07-07
usa
kudos:5

In general, double-nat is not a problem unless there is an address conflict. An address conflict would typically appear if the router is set to give out addresses in the same range as the modem is giving out, which is 192.168.0.x (x= between 1 and 254).

You can't change the modem's IP range, but you can change the router's IP range if that is the problem. You can set it to anything between 192.168.1.1 to 192.168.254.1

I haven't messed with a system that used an Airport in quite awhile, but I remember them using 10.x.x.x addresses. Those wouldn't be a problem, and wouldn't explain the error. If you find that yours is NOT using 192.168.0.1 tell us and hopefully other trouble-shooting can be done.
--
Author of hnFAP-Alert, PC-OPI and DSSatTool traveling in a 2004 Blue Bird M380


redgrandam

join:2010-08-10
London, ON

thanks for the quick reply. This was the first thing I thought of. I've always used 10.x.x.x...

Current DHCP range is set to 10.0.1.101 to 10.0.1.200..

Airport utility says my IP address is 10.4.139.xxx
LAN IP is 10.0.1.1

I tried setting my dhcp range to 172.16.x.x the other night, also no help, that and 192.168.x.x are the only other options

So I think that is not the issue, although it seems like it should be related...



dbirdman
Premium,MVM
join:2003-07-07
usa
kudos:5

After replying I spent a few minutes Googling the issue and it appears to be quite common among Airport users. It appears that, if the Airport sees a private IP on its WAN, it will throw the error, even though the situation is not really an error.

As far as I can see, NO other brand of router does that, just Apple. There really isn't an error, just the Airport expecting a public IP on its WAN side like it would see typically with cable or dsl. General thoughts on the subject are: ignore the error, go into bridge mode, or buy another brand of router.
--
Author of hnFAP-Alert, PC-OPI and DSSatTool traveling in a 2004 Blue Bird M380


redgrandam

join:2010-08-10
London, ON

Thanks. Luckily there is an ignore option to get rid of the annoying flashing light. But what you say is the conclusion I was coming to, but I just wasn't sure. I can't explain why it was fine for over 6 months then suddenly decided it was a problem. Something must have changed on the modem from the provider side or firmware I'm guessing (or maybe an IP address change was enough) at any rate thanks



gwalk
Premium
join:2005-07-27
West Mich.
reply to dbirdman

Don,
We have a Hughes subscriber with a really complex "powered By Apple" network.
Can you take a peek, offer your experience ?

Redgrandam, you also are invited to peek, who knows we may find a solution.

»www.ricksyakshack.com/view_topic···um_id=61


LittleBill

join:2013-05-24
kudos:1

gwalk,

if the huges modem can be put in bridge mode, the guys problem goes away



wizkid6

join:2002-03-31
Opelika, AL

said by LittleBill:

gwalk,

if the huges modem can be put in bridge mode, the guys problem goes away

Won't help if Hughes uses CGN. And knowing Hughes, if they do they won't let you escape it...

LittleBill

join:2013-05-24
kudos:1

said by wizkid6:

said by LittleBill:

gwalk,

if the huges modem can be put in bridge mode, the guys problem goes away

Won't help if Hughes uses CGN. And knowing Hughes, if they do they won't let you escape it...

if you honestly think hughes uses 192.168 on their network, your nuts, every single router would pretty much have issues. and if you check the posts on the other website, his modem is in a different range, 101 or something not sure


wizkid6

join:2002-03-31
Opelika, AL

said by LittleBill:

said by wizkid6:

said by LittleBill:

gwalk,

if the huges modem can be put in bridge mode, the guys problem goes away

Won't help if Hughes uses CGN. And knowing Hughes, if they do they won't let you escape it...

if you honestly think hughes uses 192.168 on their network, your nuts, every single router would pretty much have issues. and if you check the posts on the other website, his modem is in a different range, 101 or something not sure

Actually, CGN uses the 100.64.0.0 range of private addresses.

A less common range used is 10.0.x.x range.

LittleBill

join:2013-05-24
kudos:1
reply to redgrandam

thus my comment stands, changing to bridge mode will fix his problem



gwalk
Premium
join:2005-07-27
West Mich.
reply to LittleBill

Hughes modems are not configurable.
Beyond being able to enable/disable Web Acceleration & MBX reset there is nothing.
All Hughes modems are stuck at 192.168.0.1



james1979
Premium
join:2012-10-09
Quinault, WA
reply to dbirdman

said by dbirdman:

It appears that, if the Airport sees a private IP on its WAN, it will throw the error, even though the situation is not really an error.

I can confirm that Apple's routers are prone to "double NAT error"s which are not really errors. One can go to bridge mode or just the ignore the reported error (which is more of an Apple bug).


james1979
Premium
join:2012-10-09
Quinault, WA
reply to redgrandam

I've posted about this about a year ago, but I can't find my post, so I'll essentially repost the same information. (I don't feel like messing with my router right now, so I'm going from memory, so there may be some minor, unimportant misinformation.)

Currently, if you just let the Airport Utility setup the router for you and if you tell it that you have a cable or DSL modem, then it will choose to "Share a public IP address" using the 10.0.1.X prefix. This used to work fine with both the HT1000 and Exede's SB2. I would say that around 6 months ago, I started getting the double NAT error from the Airport Utility with my HT1000. I switched to bridge mode, and the double NAT error went away. The only problem with bridge mode and the HT1000 is the 5 device limitation in bridge mode. So "switch to bridge mode" works fine with the HT1000 unless you want to use more than 5 devices. (Exede doesn't have the 5 device limitation. You'd have to ask a Hughesnet employee why they implemented a 5 device limit.)

--
Gen4 / HT1000 - Beam 51 / Time Capsule (3rd gen), Exede 12 / Airport Express (2nd gen), OSX Snow Leopard



gwalk
Premium
join:2005-07-27
West Mich.

James1979,
Did you ever try the "Alt Router" setting in the modems advanced pages ?
This is supposed to address some timing issues and is for use with Apple routers only.



james1979
Premium
join:2012-10-09
Quinault, WA

said by gwalk:

James1979,
Did you ever try the "Alt Router" setting in the modems advanced pages ?
This is supposed to address some timing issues and is for use with Apple routers only.

Per your suggestion, I did try the "Alt router" setting, but that certainly didn't remedy my speed problems. It might address the "double NAT" problem. That problem is apparently not specific to HughesNet, and I don't have more than 5 devices. (I don't know if the "double NAT" problem occurs with Exede. The firmware in the SB2 was very buggy when it was dumped onto consumers, and I quickly ended up in bridge mode anyway.)


james1979
Premium
join:2012-10-09
Quinault, WA

1 edit
reply to LittleBill

said by LittleBill:

thus my comment stands, changing to bridge mode will fix his problem

And as I just learned, switching an Apple router to bridge mode makes the Guest Network go away too! (The Double NAT error only occurs with my Time Capsule and my HT1000 - not with my Airport Express and Surfbeam 2.)

--
Gen4 / HT1000 - Beam 51 / Time Capsule (3rd gen), Exede 12 / Airport Express (2nd gen), OSX Snow Leopard


gwalk
Premium
join:2005-07-27
West Mich.

Note that Littlebill wanted to put Hughes Modem into bridge mode, not the router. Per him, I must be nuts because every Hughes modem I ever met was not configureable and demanded exclusive use of 192.168.0.1



james1979
Premium
join:2012-10-09
Quinault, WA

Oh, now I notice the wording about modem versus router in bridge mode.

But just in case someone went to bridge mode and wondered "What happened to my Guest Network?", now you know.


LittleBill

join:2013-05-24
kudos:1
reply to gwalk

said by gwalk:

Note that Littlebill wanted to put Hughes Modem into bridge mode, not the router. Per him, I must be nuts because every Hughes modem I ever met was not configureable and demanded exclusive use of 192.168.0.1

i simply asked if it could be put in that mode. that is the first time i have ever seen a hardcoded setup like that.

that being said the OP using the same ranging statically is nutz as well