dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
1704
share rss forum feed


IPingUPing
N4BFR
Premium
join:2002-08-30
Atlanta, GA

APRS Connectivity via VZW Novatel USB 727

I'll start here, but might end up in the Verizon Wireless forum.

My buddy and I are building a portable APRS unit that could be taken to events like Field Day to give some fill-in portable coverage for a few hours. Instead of just digipeating, I would like to give it web access. I'm using a Raspberry Pi with Direwolf to handle the logic, but I've spent about 10 hours trying to get the USB 727 to work on the Pi. It works on a Windows Machine, I can see it on the Pi, but I can't make it connect. Tried WVDIAL and SAKIS3G with not much luck. I'm closer on WVDIAL than the other if that makes a difference.

Any thoughts or suggestions would be appreciated!

73 - N4BFR



leibold
Premium,MVM
join:2002-07-09
Sunnyvale, CA
kudos:10
Reviews:
·SONIC.NET

It sounds like your problems are more related to the linux support for the verizon wireless stick then to anything HAM or APRS related. As such the All Things Unix forum here at dslreports.com may be more appropriate.

Based on some quick search it appears that the USB727 stick is dual purpose (mobile internet as well as memory stick) and there appear to be issues with supporting such devices in linux. Have you tried usb_modeswitch to make sure that linux will see the device as a network device instead of a storage device ?
--
Got some spare cpu cycles ? Join Team Helix or Team Starfire!



IPingUPing
N4BFR
Premium
join:2002-08-30
Atlanta, GA

I have tried USB-modeswitch and I think I am ok from that perspective. I will try the Unix forum. Thanks.



SaltyPeaks

@quadranet.com

I run GNU/Linux and the issue that I had with a Novatel in ExpressCard is that it would emulate a virtual CD-ROM and I'd actually have to 'eject' the CD-ROM before I could treat it as a data modem. I recall I'd dial #777 and go forth and conquer with a PPP connection.

I recall the solution being to modify how udev handled the device so that it would automatically "eject" the CD-ROM and treat the device as a modem. I suspect this is the same issue you're running into, albeit with a mass storage device and not a CD-ROM.

$ cat /etc/udev/rules.d/99-novatel.rules
#Jan 20, 2010.  Eject on insert emulated CD-ROM
ATTRS{manufacturer}=="Novatel Wireless Inc.", RUN+="/usr/bin/eject /dev/%k"
 

This is how I handled the issue, if USB Mass Storage isn't important to you, perhaps you could modprobe -r usb-storage. Hmm, doing some research as I compose this it looks like you can perhps use usb_modeswitch (»ubuntuforums.org/showthread.php?t=2036043) if the 'eject' doesn't work for you.

Coupling the correct 'eject' or 'modprobe -r' command to the above udev 99-novatel.rules I posted might would make for an automated solution.