dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
422
share rss forum feed


Jay864

join:2013-07-18
Reviews:
·Comcast

Network issue, not sure where to look.

Hi Folks,

I just got a new switch (unmanaged) and set up 4 Macs with aggregated links. One Mac set up, perfect. Second Mac set up, both Macs lose network connectivity. Meanwhile other computers on the network are experiencing no issues.

The switch can handle aggregated links as one Mac works. The official documentation does not mention support however. So, as I notice a delay between the creation of the link and receiving an IP (the Zyxel USG 20 is in change of DHCP) I'm wondering if maybe the Zyxel is the problem.

Any thoughts?

Thanks,

Jay


Brano
I hate Vogons
Premium,MVM
join:2002-06-25
Burlington, ON
kudos:14
IP address conflict maybe? Connect both Macs and check their IPs. Make sure that both are set to DHCP.


Jay864

join:2013-07-18
Reviews:
·Comcast
Yes every Mac uses DHCP, I even tried setting IP and other settings manually but the link aggregate setup will not allow it, DHCP is the only option.

I have reserved most of the IP addresses in the Zyxel, linked to MAC addresses. As the link aggregate no longer has a MAC address maybe this is confusing the zyxel, I will disable this and see if it makes a difference. I had not thought about this before. (amazing what a good night sleep can do).

The switch is a TP-Link TL-SG1016, I found some more documentation online and 802.3ad or 802.3ax are not on the supported protocols list (only IEEE 802.3, 802.3u, 802.3ab, 802.3x). Normally I'd say "ok, it's not supported so it's time for another switch" and look no further but since one Mac works perfectly fine using that setup I wonder wth...

Some other details that might help. When both Macs are set up to use a link, I will see the following messages on one or both Macs: "Status: Not Connected. None of the member interfaces are connected. Click Advanced for details." When I click advanced I see both ethernet connections with red dots and status "Wrong Group". Hovering my mouse over the link shows me "The port is connected to a partner but the link aggregation group is different from the one that is active".

Sorry for my (very) incomplete post to begin the thread, I wonder if I was asleep already when I wrote it.


Jay864

join:2013-07-18
Reviews:
·Comcast
Setting all Ip's manually did not work, even disabled DHCP on the zyxel completely and let OS X Server handle DHCP, same results. So it is the switch. Just ordered a replacement: TP-LINK TL-SG2216 which officially supports it, should mean problems solved.


Anav
Sarcastic Llama? Naw, Just Acerbic
Premium
join:2001-07-16
Dartmouth, NS
kudos:5
reply to Jay864
Another option would be to hook up all macs directly to ports on USG and see if they got DHCPs.


Napsterbater
Meh
Premium,MVM
join:2002-12-28
Milledgeville, GA
Reviews:
·VOIPO
·Xcelerate Broadb..
·Windstream
reply to Jay864
What setting on the Macs are you configuring to setup aggregated links.

What Network cards are in the Macs.

You cant have true aggregated links without support from the switch and it requires you to set it up on the switch thus it need to be managed.

Now some network cards can fake it pretty good but still work best with a switch that supports it.
--
ASUS M4A79T Deluxe | AMD Phenom II x3 720 BE AM3 w/4 Cores @ 3.41Ghz(OC) | 8GB DDR3 Memory @ 1600mhz | Sapphire ATI HD4870 1GB 800mhz/1000mhz(OC) | 2x500GB HDD's Raid 0 | Windows 7 Ultimate x64| Xcelerate Broadband FTTH GPON 30Mbps/30Mbps