dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
359
share rss forum feed

centacre

join:2003-03-17
Cypress, TX

Links in Outlook 2010

I wasn't sure where to post this.

I am running Microsoft Office Suite 2010. I use Outlook 2010 32-bit for the e-mail client. This is all on a Windows 7 Pro 64-bit OS. Here's the problem:

Whenever I have a 64-bit browser (Pale Moon or IE 11) as the default, and I click on a link in Outlook that goes to an https URL, I get a message saying to the effect that a group policy is blocking the action. If Pale Moon 32-bit is set as the default, the link works fine. I was wondering:

a. Which group policy would block this?
b. Why would it open a 32-bit browser and not a 64-bit browser?

I am running on SUA with Software Restriction Policy. If I turn SRP off, the above stated still happens. Thanks in adavance.


Frodo

join:2006-05-05
kudos:1

I have no idea what SUA is. However, I started implementing SRP on my Win7 x64.
When I made disallowed the default, a couple of paths were made unrestricted.
%HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\ProgramFilesDir (x86)%
%HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\ProgramFilesDir%
So, I figured my 32 bit and 64 bit program folders were whitelisted. However, I figured wrong.

My event viewer, application log was showing this error when I tried starting a 64 bit process from a 32 bit process.
quote:
Access to C:\Program Files\Windows Media Player\wmplayer.exe has been restricted by your Administrator by the default software restriction policy level.

The problem is, a 32 bit program is going to look for the value for "ProgramFileDir" at HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion. There, the value is "C:\Program Files (x86)". A 64 bit process will see "C:\Program Files". If the 32 bit registry editor is run, there is no Wow6432Node to be found, because it is already substituted for the 64 bit registry node. So a 32 bit process won't see that the 64 bit program files is unrestricted.

So, what I did, using the 64 bit registry editor, was create a new string value ProgramFilesDir (x64) = C:\Program Files at:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion and
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion
Then, in Software Restrictions Policy, I changed the rule for the 64 bit program directory to look like this:
%HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\ProgramFilesDir (x64)%
The problem with a 32 bit program starting a 64 bit program ended for me. I didn't try the following, but as an after thought, this might work as well.
%HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\ProgramW6432Dir%

centacre

join:2003-03-17
Cypress, TX

Brilliant! I tried your second suggestion as follows:

said by Frodo:

I didn't try the following, but as an after thought, this might work as well.
%HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\ProgramW6432Dir%

and links open fine. Thank you so much.

PS When I stated "running on SUA", I meant I always run on Standard User Account. I believe it was called "Limited User Account" in XP.

Frodo

join:2006-05-05
kudos:1
reply to centacre

For SRP in Win 7, there is a hotfix to close a bypass in SRP. I tested the bypass using a powershell version 2 script before installing the hotfix, and afterwords, and the hotfix does close the bypass.


centacre

join:2003-03-17
Cypress, TX

Thanks, Frodo. I installed the hotfix.