dslreports logo
 
    All Forums Hot Topics Gallery
spc
Search similar:


uniqs
373
wirelessdog
join:2008-07-15
Queen Anne, MD

1 edit

wirelessdog

Member

Auto Failover

So...
My router has three Interfaces.

Gig 0/0 WAN1
Gig 0/1 WAN2
Gig 0/3 LAN

WAN1 and WAN2 are two different upstream providers on two different subnets.

I understand I can do:

!WAN1
ip route 0.0.0.0 0.0.0.0 184.x.x.1
!WAN2
ip route 0.0.0.0 0.0.0.0 12.x.x.1

This configuration should load balance

-or-

!WAN1
ip route 0.0.0.0 184.x.x.1
!WAN2
ip route 0.0.0.0 12.x.x.1 254

This configuration should do auto failover

Now here is my question. If 184.x.x.1 is a router sitting right next to my router connected by a patch cable, it is very probable that 184.x.x.1 is still pingable even if the next hop is down.

How can the router determine that WAN1 is down and go to WAN2 or does it try to route the destination through WAN1 and if the destination is unreachable go through WAN2?

I am assuming that the rest is as simple as having the correct IP addresses on each Interface, IP NAT inside on gig 0/3 and IP NAT outside on both gig 0/1 and gig 0/2?

Thanks!

tubbynet
reminds me of the danse russe
MVM
join:2008-01-16
Gilbert, AZ

tubbynet

MVM

this is done through state of the phy on your router.
if you lose the interface with the next hop, it drops out of the table.

ip-sla is your friend to check reachability beyond your next hop to your upstreams.

q.
wirelessdog
join:2008-07-15
Queen Anne, MD

wirelessdog

Member

How does this look?

!
track 10 rtr 1 reachability
delay down 1 up 1
!
interface Gig 0/0
description ISP1
ip address 184.x.x.x 255.255.255.0
ip nat outside
ip virtual-reassembly
!
interface Gig 0/1
description ISP2
ip address 10.105.86.1 255.255.255.0
ip nat outside
ip virtual-reassembly
!
interface Gig 0/3
description LAN
ip nat inside
ip virtual-reassembly
!
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0 184.x.x.1 track 10
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1 10.105.86.2 10
!
ip nat inside source route-map ISP1 interface FastEthernet0/0 overload
ip nat inside source route-map ISP2 interface FastEthernet0/1 overload
!
ip sla 1
icmp-echo 8.8.8.8 source-interface Gig 0/0
timeout 1000
threshold 2
frequency 3
ip sla schedule 1 life forever start-time now
!
route-map ISP2 permit 10
match ip address 1
match interface Gig 0/1
!
route-map ISP1 permit 10
match ip address 1
match interface Gig 0/0
!