dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
7
share rss forum feed

mdochter

join:2004-01-28
Rocklin, CA
reply to tyspeed29

Re: WPC54G WLAN Utility

Am I to understand that XP does not recommend the install of the Wlan Cofig Utility?

I have the wireless WPC54G card working into the new Access Point.

When I start the WLAN config utility I get two popup error messages "Cannot Co-exist" and "wpc54g.exe C++" error (close enough).

Regards
Doc


Rattler

join:2001-04-13
Havertown, PA
kudos:1
Let me jump in here too --

I have a Toshiba 2775XDVD notebook, running W98SE and the device manager says that the cardbus controllers are Toshiba's. All devices listed are running clean with no flags.

With the WPC54g removed & Zone Alarm disabled I uninstalled the driver & apps (V1.2) that came on the CD with the card. I then rebooted, disabled ZA again and installed the new V1.3 package. Shut down the machine, inserted the card, rebooted, new hardware found, files were updated, 'puter rebooted again. When W98SE came back I got the error "ODHOST.EXE cannot coexist" (with what?) and also a window citing a VB runtime error and another saying that the WLAN Monitor did not load.

However, it's icon was in the system tray and when I pulled it up the card was running in Ad Hoc mode (I installed it in infrastructure mode) showing a good signal, but on the site survey page, my WLAN was not detected nor were the other 2 in my vicinity. System response was terrible and I could not "stop" the card. When I tried re-setting up an infrastructure profile, I still could not detect any WLAN in the site survey page, and there was no signal showing on the first monitor page.

Reinstalling V1.2 fixes the problems, but I really would like to run the later application (it looks like the driver supplied with V1.3 is the same version as the one that came with the V1.2 app - 3.30.15.0). I also can't install Odyssey under 1.2 - it says there's a missing component but doesn't say what. I'd like to run WPA.

Has there been any further development on this problem? Is there a light at the end of the tunnel that isn't the engine's headlamp?

Rattler
--
Never raise your hands to your children, it leaves your groin unprotected.


lmann

@bmo.com
I managed to get the WPC54G to work on a laptop with windows 98se with WPA support using the latest drivers from Linksys. In the end, I am not using the WLAN utility, but rather the Odyssey client manager.

I am not sure about windows ME, but what I did here might work for ME as well, since the OS's are so similar.

This wasn't without a lot of gnashing of teeth, alot of trial and error, and cobbling together a bunch of files and drivers to make it work.

Here's the theory, and what I did to make it work. There is probably a better way to do this, but I'll leave that to others to figure out.

Linksys uses (licenses) the odyssey client from Funk software, and they have integrated it into the latest version of the linksys drivers. The problem is that they don't use the latest version of the odyssey client, which I believe is part of the problem with it not working on some laptops.

What I did was download the latest version of the odyssey client from Funk software, but did not install it (yet). You also need access to either another windows 98 machine, or have original windows 98 install cd handy, because a specific file is needed from there.

Then I installed the latest version of the WPC54G driver, using the linksys install program. You need to do this, because this should also install the old version of the odyssey client, and insert the license key for odyssey into your registry. You can check to see if the odyssey client is installed by looking in add/remove programs. If it is not installed, look in the utilities directory of the linksys download, and you will see an odysseysdk executable file which will manually install the odyssey client. Run that to install the old version of odyssey.

Then I uninstalled the linksys driver, using the linksys uninstall utility. This gets rid of wlan utility and the driver, but leaves I believes it leaves the registry entry, including the license key for odyssey. Reboot, and install the old linksys driver.

Then I installed the updated odyssey client I downloaded from Funk software. Don't do an uninstall, but an install/update. Note that after it installs, it might give you an error, something about "Odyssey has detected a missing component. Please reinstall Odyssey." after Odyssey Client installation, ignore that for now, that will be fixed in a later step.

Then, I re-installed the latest linksys driver for the WPC54G, BUT ONLY THE DRIVER. Do not use the linksys install utility, as this will clobber the new odyssey client. Install the driver only by going to control panel-> network adapters ->wireless adapter, click properties, update driver, and navigate to the directory where the new linksys drivers are located, and install the driver only.

Reboot. Ignore the odyssey error. And make sure the wlan utility is not running. If it is running, remove it from the startup folder and reboot.

Now, to fix the odyssey error, which you might get again on reboot. The new odyssey client needs the original windows98se version of the "iphlpapi.dll" that comes on the windows 98se cd. This file has a date sometime in 1999. (I'm not at my laptop, so I don't remember the exact date, you can find more information about this by doing a google search on "odyssey tech note od185"). I restarted the machine in safe mode, and copied this file into the to "c:\windows\system" directory.

Reboot again, and hopefully the machine should start clean, and the odyssey client manager (and not wlan) will be running in your system tray. Left click on the odyssey client manager icon in the system tray, and configure the odyssey client with the essid, wpa passphrase etc. There is online help for that.

Reboot one more time - and it worked for me.

Good luck.



MhicAoidh

@mchsi.com
Might be a dense question, but how did you load the Odyssey Client Manager? I browsed to the Funk Software folder, and there are some files within there, but no execuables. The Odyssey Client is showing in Add/Remove.


chuvrier

@adelphia.net
The only way I could get either of my Linksys Wireless G cards working properly (PC card and PCI) was to remove the horrid WLAN service from Linkysys and download the Odyssey Client from Funk Software.


mhicaoidh

@mchsi.com
Well, I tried the Oydessy client demo, and unfortunately, this created a blue screen before login under 2000. So, no joy there.

I did get a Netgear WG511 which, while it doesn't support WPA yet under 2000, it has worked flawlessly so far. Which is far more than I can say for the WPC54G from Linksys.