dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
1005
share rss forum feed

MercuryK52

join:2004-01-24
Sweden

1 edit

Thinking of getting a 2514, newbie questions..

Alrighty! I'm tired of this netgear P.O.S and I'm tired of the D-Link P.O.S I had before heh and wanna go all cmd line based and have full control, and have something which does not crash for me once every week or as soon as the WAN connection becomes a bit cramped.

I think 2514 is the way to go here with two 10mbit ethernet ports.

I've got a 2.5mbit ADSL connection (which will become 8 in the near future) with a static IP, no login information or anything like that is neccessary. I basically jsut eneter the IP, Gateway and DNS info and I'm up n' running.

I think i will be able to handle setting up a CISCO via the information which s available in books and on the internet. What I do want to know is

1. Which IOS version I need (I will state my needs farther down)
2. How much an IOS license costs
3. If it's feasable / your own oppinion

Alright, I'd like to basically have the same functionally as in a normal std. NAT router.

This is what i've got right now:
WAN IP -> NetGear NAT router -> Simple Cheapo Switch -> [Internal Network]

This is what I had in mind->
WAN IP from Cable Modem -> #et0 -> [2514] -> #et1 -> Switch -> [Internal Network]

I've got a couple of webservers, a ftp server, P2P Community Software. So ports need to be opened for those with free acces basically. I also run a WINS and DHCP server but I'd like to move that duty to the CISCO router.

I run some software which would require me to route specific ports to my workstation (which has got a permanent IP lease). Sofware like ICQ, Lotus Notes, DC and so on. I do have a gamer on this network so I guess I'd need to open up some ports there aswell.

...and that would be all.. so in conclusion

NAT
DHCP (WINS to?)
Open ports for my Server Aps (everyone allowed to access ports)
Open ports for my workstation Aps (everyone allowed to access ports)
I do have one ap which only on IP has access rights to.

Feasable? Comments?

I have gotten some suggestions that I should get a 800 instead which is newer and still supported by CISCO. The onl problem with that would be the prices, Seing as I live in Sweden the "used" market is virtually non-existent on that front...2514 however is easy to come by.


aryoba
Premium,MVM
join:2002-08-22
kudos:4

2 edits

The features you need

=======================================================================
I've got a 2.5mbit ADSL connection (which will become 8 in the near future) with a static IP, no login information or anything like that is neccessary. I basically jsut eneter the IP, Gateway and DNS info and I'm up n' running.

This is what i've got right now:
WAN IP -> NetGear NAT router -> Simple Cheapo Switch -> [Internal Network]

This is what I had in mind->
WAN IP from Cable Modem -> #et0 -> [2514] -> #et1 -> Switch -> [Internal Network]

=====================================================================

I'm confused. Do you ADSL or cable Internet?

Anyway, what you need is a router with the following features:

* at least there are 2 Ethernet interfaces (NOT 2 Ethernet ports) - assuming you use an external modem (either ADSL or cable modem)
* run IOS with NAT, CBAC, and (maybe) DHCP support

If you think you can only afford 2514 router, then it is fine as long as it has at least:
* maximum memory size - 16MB DRAM and 16MB flash
* run the latest IOS version - 12.2.x or 12.3.x

You may get any 2514 router easy. But you may not get 2514 with such feature easy. You may only get a 2514 with minimal memory size and limited IOS feature, which is the common problem for those who cannot afford the current router.

Keep in mind that it is not easy to find latest IOS for the 2514 as it is not supported by Cisco anymore. So my suggestion is that you get a 2514 with all the memory sizes and the features as possible as you can. If not, I may recommend you to get the cheapest current router such as SOHO 90 or 831.


MercuryK52

join:2004-01-24
Sweden

3 edits

Ohh yes, ofcourse, it's ADSL with a static IP. Sorry, my mind must've been elsewhere when I typed that out.

There is a place here in Sweden which sells used 2514 routers faily cheap and they come with 8/16, bu I could prolly cut a deal and get 16/16, if nothing else I guess I could try to find another 8mb flash memstick (or 2X8)on e-bay. The IOS version is a problem. I could probably get a hold of 12.2 something....T7 i think..or was it T8, from my UNI if I ask nicely. (Student license).

Ohh..anotehr question. Will this router allow loopback connect? (Accessing myself with my WAN ip). Many cheapo routers are cranky with this...I figure it can't hurt to ask

Thank you for the information!


aryoba
Premium,MVM
join:2002-08-22
kudos:4

It has almost everything

The 2514 router offer more than just loopback (I'm not sure exactly what you mean by "accessing yourself with your WAN IP). The router support firewall, VPN, dynamic routing protocols (BGP, OSPF, and others), and else.

When you want to play with VoIP and QoS, you will need other routers in addition to the 2514. You then may need 831, 1721, or just 2610 router. You can put up (let's say) two 2610 and one 2514 between them. Then you're gonna have fun playing VoIP and QoS on WAN connection. Add a Catalyst 2950 or 3550 EMI for VoIP and QoS on LAN.


MercuryK52

join:2004-01-24
Sweden

1 edit

Yo!

What I meant was basically that I'll surf to myself via my WAN ip.

Instead of surfing to my webserver with 192.68.xxx.xxx i'll surf with 194.236.XXX.XXX even though I'm behind the router.

What youre talkign about VoIP and QoS sounds like fun. I'm still a n00b in the field but I've always loved to poke around in cmd consoles, do things the "manual" way without any flashy wizards and web.guides etc etc. I*ve looked at a couple of cisco routers to. 2400 series (i think it was) and 1900 series, but I haven't really read up on them..but it could be interresting to fiddle around with a real switch aswell..and not some cheapo 20USD auto 'do it all' swith


BushHamster5

join:2001-04-13
Oxnard, CA
reply to MercuryK52

Re: Thinking of getting a 2514, newbie questions..

i am able to run IOS 12.3(9) on my 2514 with 16/16...

------------------ show version ------------------

Cisco Internetwork Operating System Software
IOS (tm) 2500 Software (C2500-I-L), Version 12.3(9), RELEASE SOFTWARE (fc2)
Copyright (c) 1986-2004 by cisco Systems, Inc.
Compiled Fri 14-May-04 13:52 by dchih
Image text-base: 0x03070FE4, data-base: 0x00001000

ROM: System Bootstrap, Version 11.0(10c), SOFTWARE
BOOTLDR: 3000 Bootstrap Software (IGS-BOOT-R), Version 11.0(10c), RELEASE SOFTWARE (fc1)

Cisco2514 uptime is 2 hours, 43 minutes
System returned to ROM by power-on
System image file is "flash:/c2500-i-l.123-9.bin"

cisco 2500 (68030) processor (revision L) with 14336K/2048K bytes of memory.
Processor board ID 07093176, with hardware revision 00000000
Bridging software.
X.25 software, Version 3.0.0.
2 Ethernet/IEEE 802.3 interface(s)
2 Serial network interface(s)
32K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read ONLY)

Configuration register is 0x2102


Soulas

join:2004-09-10
Chandler, AZ
reply to MercuryK52

I just got my 2514 cisco router and wandering how to configure my cable modem to work on it. I've been trying a few things and haven't got it to work yet. Here is my current config:

version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
service password-encryption
service tcp-small-servers
!
hostname Macgyver
!
logging rate-limit console 10 except errors
enable secret 5 $1$M/Rs$/NlLSwINa/flAHzyDJgC51
!
ip subnet-zero
no ip finger
no ip domain-lookup
ip host TFTP 192.168.1.3
ip name-server 68.2.16.25
ip name-server 68.2.16.30
ip dhcp excluded-address 192.168.0.1
ip dhcp excluded-address 192.168.0.254
!
ip dhcp pool client
import all
network 192.168.0.0 255.255.255.0
dns-server 68.2.16.25 68.2.16.30 68.6.16.30
default-router 192.168.0.1
!
no ip dhcp-client network-discovery
!
!
!
!
interface Ethernet0
description Cable Modem
ip address 68.2.78.69 255.255.252.0
ip nat outside
!
interface Ethernet1
description Internal Network
ip address 192.168.0.1 255.255.255.0
ip nat inside
no ip route-cache
no ip mroute-cache
no cdp enable
!
interface Serial0
no ip address
no ip route-cache
no ip mroute-cache
shutdown
no cdp enable
!
interface Serial1
no ip address
no ip route-cache
no ip mroute-cache
shutdown
no cdp enable
!
ip kerberos source-interface any
ip nat inside source list 101 interface Ethernet0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0
ip http server
!
access-list 101 permit ip 192.168.122.0 0.0.0.255 any
!
!
line con 0
logging synchronous
transport input none
line aux 0
transport input all
line vty 0 4
password 7 12121C18
logging synchronous
login
!
end

I hope someone can help. Thanks