dslreports logo
    All Forums Hot Topics Gallery
spc
Search Topic:
uniqs
76884
share rss forum feed


anon5812

@69.62.x.x
reply to claudeo

Re: Airlink+ AR315W - having some fun

I would really like to know how to flash this firmware as well?!


Misu Pisu

@suceava.astral.ro
reply to claudeo

please help me

one of my friends brought me a Ar315w router from the us.
the problem is that i have to replace it's AC adapter, since here in europe we use 220 volts
my question is : can somebody who has a multimeter please tell me what is the polarity at the end of the AC adaptor's cable (the end that enters the router) ?
thank you very much


anon5812

@69.62.x.x
reply to claudeo

Re: Airlink+ AR315W - having some fun

The center of the DC connector is positive.
the outer barrel is negative.

on my ar315w, this is marked both on the back of the router right beneath the DC input jack, and also on the original AC adapter.

Please note that I did NOT test this with a meter, however I just looked at the back of the unit and checked the AC adapter.

Do you have doubts about this being the proper polarity?


anon5812

@69.62.x.x
reply to claudeo
alright guys, here's how you use the IP806SM .IMG file from the everbestHK site - at least, here's how I loaded it to my AR315W.

First - the IMG file has an incorrect PID as reported by TFTP if I just try to write it to the router. I assume this is productID. by studying several IMG files, I believe that I have determined that the value at 0x26 (hex) in the IMG file is the PID.

A couple of examples:

The hawking firmware has the value "16" (hex) at 0x26.
The airlink "1011 to 1023" firmware has "01" (hex) at 0x26.
The airlink "1021 to 1023" firmware has "14" (hex) at 0x26.
The sercomm/everbestHK firmware has "01" (hex) at 0x26.

I am purely guessing that "01" is the reference board/OEM PID. Probably, the early airlink units were identical clone of the reference board and had 01 as the PID. then later airlink got their own PID (14). That's probably why they released two different IMG firmwares for the same router - the old ones would only recognize PID 01, and the new ones only recognize PID 14. Just a guess!!! Airlink+ also became airlink101 so maybe that had an effect too??

Anyways, I took the most recent IMG file from the sercomm/everbestHK site for the IP806SM, altered the "01" (hex) at 0x26 (hex) in the IMG file to "14" (hex). Saved that, and TFTP'd it. The router took the new firmware on the first try and rebooted just fine at 192.168.0.1. Apparently either the file has no CRC, or the header is not part of the CRC calculations. If you compare the 1011-1023 to the 1021-1023 firmware, the only change I noticed is this single byte.

Disclaimer: if you brick your router trying this, it's NOT my fault, and I don't know how to fix it. This isn't a WRT54G, there isn't much knowledge out there about it. The above information worked for me. in otherwords, don't try this if you can't afford to lose the router in case something goes wrong (power outage when you flash the firmware, aliens invade your router, whatever).

As for the new features/functionality, I can confirm that WPA2 is available. The overall menuing is similiar to the airlink firmware. (setup wizard, LAN ,wireless, password, status, advanced, administration are the opttions running down the left hand side). The region defaults to "europe" after you load this firmware so be sure to change it as necessary. You can apply MAC level access control to filter LAN and/or internet access independently - I don't rememver the stock firmware having this. Theres a few other things that look different too. But it's still a relatively basic firmware, it doesn't have any superadvanced fancy stuff that I saw. I can not comment on any stability or performance fixes as I'm using a WRT54G now - I just upgraded this firmware to play with it.

Finally, when mine reset, the password I had configured prior to the flash, was still in effect. I would suggest to go to "administration" and then to "config file" and then "restore defaults" after flashing, to make sure the router is clean slate for any new code changes, then let it reboot and reconfigure it after that. This is something the WRT54G groups have taught - whenever changing firmwares, erase the settings in case the different firmwares use them differently. Maybe even do the factory defaults before flashing it as well (i.e., set factory default, flash, then factory default again).

firmware reports itself as version 2.3 release 1A.

good luck!!


anewbine

@comcast.net
reply to AnonA
AnonA/anyone
once the AP411W is flashed with other FW (ie. 2.00), is there a way to load other version on it (ex. 2.10eu)? I have tried same method, but looks like there is no recovery mode for Dlink FW?
thanks.


anewbie2

@comcast.net

Re: Airlink101 AP411w DWL2100 firmware; surecom???

well, i put the dwl2100 2.00 fw on my ap411w, cause it has dhcp and thought it would be better... but i notice that the wireless disconnect several times during usage; does not reboot just disconnect wireless (running 54g)!

now just put dwl2100 1.03 backup; I was trying to put Airlink 1.00 back but, after putting ap2100, cannot go back to Airlink FW, still checking connection issue... If any one knows how, please help.

I read in some other thread that, surecom or kcorp has even more options? if some have use these fw on ap411w, please comment. And how to flash ap411w running ap2100 fw with surecome? thanks.


ElChingon2

@ucsc.edu
reply to anon5812

Re: Airlink+ AR315W - having some fun

It works! Thanks anon 5812!!!


anon5812

@69.62.x.x
reply to anon5812
one followup to my previous post.

I changed the PID value at 0x26 to 14 because my ar315w expected a value of 14.

those with older ar315w's who have to use the "1011 to 1023" firmware (which has an 01 at 0x26), will probably be A-OK with the sercomm/everbestHK firmware with NO changes (i.e. you can just flash the firmware right from the download site without messing with it).

good luck.


newbie1

@comcast.net
reply to AnonA

Re: AP411w DWL-2100AP FW DI624 superg MIMO

I have a AP411w running DWL2100 1.03; wanted to try other FW but device will not accept any other FW, does anyone have anyway to flash AP411w with other FW once it's already running DWL2100 ? Have anyone got their AP411w running superg with MIMO (Di624) ??? If so, please email me. thx
»www.dlink.com/products/?sec=0&pi ··· &pid=385


airlink owner

@dsl.chcgil.ameritech
reply to anon5812

Re: Airlink+ AR315W - having some fun

I hate to sound like a dummy, but how do you edit the "at 0x26 (hex) in the IMG file to "14" (hex)"? I apologize if this has been explained before, but I really do not know how to change the hex as mentioned. I have downloaded "ip806sm.img" file and I downloaded XVI32 hex editing prograam, but can't seem to figure out how to edit the file. Thanks in advance. Have a nice day.

pgaster

join:2005-11-30
Palatine, IL
reply to claudeo
I do not understand hex editing either.
Can someone explain this with a bit more detail?
I am a complete newb at hex.

Or can someone host the firmware that anon5812 modified?
Maybe that would be easier for many of us who have this router. And the file looks to be fairly small, it's not a WRT54G firmware that weighs in at about 3 MB. This thing is under a MB.


Andy911

@comcast.net
reply to anon5812
I used Anon5812's directions and loaded the everbestHK firmware after editing the hex ID to 14 and it loaded perfectly on my AR315W. It doesn't seem to be passing DNS address through on DHCP though. I don't care so much about that, I loaded the DNS server addresses into the AR315w and into each computer manually just to be sure then used sprints DNS addresses as my backup.Also changed the power supply to a 9V-500mA from the 12V it came with since people mentioned in earlier posts that the over powerful adapter it comes with could be the reason for overheating and freeze up. We'll see how long it can hang onto the public IP now!

pgaster

join:2005-11-30
Palatine, IL
reply to claudeo
I think I figured out how to edit the file properly.
I used Hex Workshop 4.2
Open the file and look at the second line down. Look for 01 and change it to 14. Save the file.
Now go to the router setup page and ugrade the firmware.

The router reboots to 192.168.0.1 so you need to be aware of that, but other than that issue I have not seen any problems yet.

The router now has AES, or so it says. I have not tried it yet, but it if works, that would be a huge benefit.


antheus

@cox.net
So is there any concensus at this point which firmware works the best? I had the 26 firmware, and downgraded to the 21 because of random disconnects problem...is this a heat issue or an issue with the router firmware? It would happen after about 30 minutes streaming a file and require pulling the power cable and putting it back in.

ytsejam9

join:2006-02-03
Mountain View, CA
reply to claudeo
I guess this product is so crappy that the manufacturer themselves recognized it and posted the old firmware download here:

»www.airlink101.com/support/index ··· es&id=12

Anyway, I downloaded v. 21, downgraded the router... and lo and behold - the problem is still there. Now, in my case these random connection problems are not too severe, i.e. the connection doesn't actually get completely broken, just stalls most of the time... still highly annoying if you're working from home and/or streaming videos or stock quotes, or playing games online... whatever requires a continuous and uninterrupted flow of data.

I might go back to my old 802.11b Belkin router (which was crap too, but at least it didn't have this recurring issue).


doload

@hstntx.swbell.ne
reply to Coorjo
yah,if u all ready bought Air link wireless router.make sure u go to DSL speed test to see it upload speed,because it working ok except u will be lockup when posting something in chat room or try to upload.So watch it and do not to spent your time to config ya PC or internet service


a-nonny-mouse

@69.150.x.x
reply to Misu Pisu

Re: please help me

12v 800mA, positive center


Jakl1

@pmcos.com
reply to claudeo

Re: Airlink+ AR315W - having some fun

Many Thanks to anon5812 for your instructions. They worked great on my Hawking HWR54G Rev. M. I did have some problems with the Sercomm firmware. I would get disconnected frequently when using WPA2-PSK. However, WPA-PSK (AES) worked flawlessly for me.

For those who are interested, I have succeeded in loading the Linksys WRT54GC firmware (version 1.02.8) to my HWR54G. It is the only other compatible firmware that I could find that has WPA2 support. It also includes many other useful features not available on other releases.

The Linksys is basically the same hardware as the AR315W, HWR54G, Sercomm IP806SM, etc... It uses the same Marvell chips rearranged for the smaller case of the WRT54GC. In addition to anon5812's instructions, replace the value at 0x01 to "02" (hex) on the Linksys firmware. In changing this value, you are changing the PID Version (different from PID discussed by anon5812) from "00 01" to "00 02". This value should be the same on all our routers (AR315W, HWR54G, etc...). Then load the modified firmware after restoring defaults (highly recommended) to your router.

Keep in mind that after flashing, the new IP for the router will be 192.168.1.1. Typically, there is no username for the login and the password is "admin" (default on Linksys routers). Since I had restored defaults prior to flashing, I had to use "admin" for the username and "admin" for the password to login after flashing. Then I immediately restored defaults in the Linksys web interface. Thereafter, the default Linksys login applies.

I haven't had a chance to test it yet, but I'm eager to. Good luck to all willing to try.

kindall

join:2003-04-11
Bellevue, WA
reply to claudeo
Anyone had any luck upgrading the firmware on the ARI315W AFTER having installed the Sercomm firmware? I can't get the original Airlink firmware back on, nor the Linksys firmware (appropriately patched).


ruiyang

@yahoo.com
reply to claudeo
I use anon5812 method to upgrade the firmware for my ar315w router (the orginal firmware is 1.0.26). it went smoothly, but after reset the router, I can not find the new IP address for the routher, my PC get IP adress of 192.168.1.201, but if I ping 192.168.1.1 or 192.168.1.254, both not working. can anyone tell me what is the new IP address for the router?
thanks

kindall

join:2003-04-11
Bellevue, WA
With the sercomm firmware? You will want to get a new IP address from the router (release/renew DHCP lease). It should be in the 192.168.0.x range and the router's IP should be 192.168.0.1.

p3n1x

join:2002-07-25
Corona, CA

sweet anon! i finally got around to messin w/ this router again..

did the hex edit, and got the fw loaded finally. my problem was i had flashed to that hawking f/w awhile ago...id saved all the files, firmwares and txt's of what to do, and i couldnt for the life of me get it to flash any other firmware at all...

what i needed to do was take that hex address and change it to the hawking model changed that hex to 16 and BAM! it flashed, and rebooted and now i have the new following

Device: HWR54G
F/W Ver: 2.3 Release 1A

so far so good....now what about changing power bricks to make the damn thing less hot....imma read back on this one to find out more

thanks for everybodies hard work, you are the movement!

ill be keeping posted here, thanks again

enochcheng

join:2004-08-10
hong kong

1 edit
reply to claudeo
Sweet, finally get the stupid router running smoothly with Sercom firmware.
the DNS problem can be solve as follow:
leave the hostname and domain name field blank, and it will give you your ISP's dns instead of your router's ip as DNS, and everything is good afterwards.

the MAC level access control is kind of string, though, the internet access one is fine, but for the lan access one, even when you choose allow lan access by all wireless stations, without choose your station in the select stations field, you would only be able to get your ip address, but you won't be able to communicate with your computer in the lan (but this is pretty sweet for me, since i connect the ADSL modem as bridge, and do a loop-back with the router's wan and lan, making it possible to use the PPPOE in the router, at the same time i can connect PPPOE with individual PCs)

My modem is actually a Eagletec arm-914, and it's exactly the same as Airlink AR315W, with the oldest 1.0.21 without WPA on.
I tried the Airlink newer firmware - it really sucks, and tried the AR315Wupdate.rar from this thread, but have serious problem with auth. (router not working wiv WEP64bit), and finally sercom one works fine

eager to try the linksys firmware latter on. I got a WRT54G with hyperWRT. Hope someone would make a great firmware with WRT54GC

Really thanks for all the great work done on this router. really helps a lot.

stevech0

join:2006-09-17
San Diego, CA
reply to claudeo
I use an older Linksys WRT54G with the DD-WRT firware. For a long time. Works very well. Reliable. Has the features I want that are missing in Linksys' firmware.

I dumped sveasoft's firmware. Crashy and the author is a dolt.


frrrr

@pacbell.net
reply to claudeo
they packaged these units with the wrong power supply. the 12v power supply causes the unit to overheat and all kinds of problems occur.

if you contact them, they will ship you out a 5v power supply for free that will completely fix the problem.


MarconiBR

@201.37.x.x
reply to claudeo
Hi there,

I have a HWR54G rev. M. Since I've read here that it has the same hardware as others, I've been trying different firmwares.

I tried the sercom firmware (pretty much the same as hawking's features, but different layout), and the wrt54gc. To install those, I had to change the bytes at offsets 0x01 and 0x26, to make the installed firmware accept the new one.

I thought the linksys firmware would have something new that the hawking didn't. But not really. After a while, I decided to install the updated hawking firmware. But I can't!

I tried changing the 0x01 and 0x26 bytes to all combinations used previously, and even uploading the official wrt54gc firmware. They are all rejected!

I didn't brick my router, but I'm stuck with the wrt54gc firmware now.

I tried to tftp it on windows (with the -i parameter), and I get the error "PID wrong". I guess tftp'ing also gets to check the header.

Any ideas of what to do? The only thing I can think of is to generate different images with different values at 0x26 and/or 0x01 so I can get the CRC to pass.


AR315W

@pacbell.net
reply to frrrr
So I opened the box to verify if the 12V/5V power
supply claim is valid or not.
The DC-DC converter is AnaChip AP1506 1506-50
»www.anachip.net/products/DATA/AP ··· 1506.pdf

It can handle input voltage up to 22V, and recommended
input is 12V.

I tested 5V 7.5V and 12V, they all work but with 5V
power supply, DC output is only 4.0V

Make your own judge if 5V posts are valid or not


anon25

@comcast.net
reply to kindall
Same here... My wireless does not hold a DHCP address and I cannot change the firmware... Are we stuck with it now? Any help will be appreciated. I need to re-flash any firmware that allow changes after it is loaded.


anon25

@comcast.net
Previous post related to post below:
reply to claudeo
Anyone had any luck upgrading the firmware on the ARI315W AFTER having installed the Sercomm firmware? I can't get the original Airlink firmware back on, nor the Linksys firmware (appropriately patched).


anon25

@comcast.net
JUST FIXED IT !!!

Just get the regular stock 1.0.26 firmware and change the header as follows:

Byte 26: change from 14 to 01
Byte 32: change from 10 to 23
Byte 33: change from 26 to 1A

Save it and use the utility built into the web interface to upgrade the firmware. I assume you are using now the address 192.168.0.1. The firmware update now should work.
After you finish it, you can now load the original 1.0.26 image if you want. It also works.
Note that the new web interface address is the "old" 192.168.1.1 ...

Good luck!
PS: It worked for me. I am not responsible if it does not work for you in any way.