dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
24885
share rss forum feed

nsumner

join:2001-12-13
Israel

Cisco router with "load balancing"

I am looking for a Cisco (or any other relialbe brand) router that offers load balancing of up to 4 ADSL (PPPoE) links.

I don't need anything fancy just your plain old run of the mill on the router only load balancing. I need better speeds then I can get out of the single ADSL line here (where the upload speeds are pathetic) and therefore need a router to do load balancing across multple links. I understand I can't send one file over multple links at the same time (as that would require ISP co-operation) but just something so that I can use 4 links and if the first link is busy it will use the next etc.

Thanks.

jdmatl

join:2000-04-27
Deerfield Beach, FL

1 edit
Not cisco. Router will "kinda" do load balancing with CEF and setting routes with equal weight.

But not like a cyberguard 570 firewall.
It will do 2 ethernet connections PPPOE with failover.
»www.cyberguard.com/products/fire···ng=de_EN

Try Fatpipeinc.com

»www.fatpipeinc.com/stream/index.htm
FatPipe SUPERSTREAM, a lower speed version of FatPipe XTREME, is our number one product for small businesses and branch offices that require redundancy, reliability and speed of their wide area networks. SUPERSTREAM aggregates any combination of multiple T1, DSL, ISDN and Wireless connections up to 2Mbps

Do a search on load balancing here in this forum. It has been discussed before


rolande
Certifiable
Premium,Mod
join:2002-05-24
Dallas, TX
kudos:6
Reviews:
·AT&T U-Verse
·ViaTalk
reply to nsumner
You could run pretty much any Cisco router with dual Ethernet interfaces as long as they support 802.1Q trunking and you have a switch that supports 802.1Q trunking. Plug one ethernet into your internal network and the other interface should plug into a switch connecting to the 4 ADSL modems. Create 4 subinterfaces on the external ethernet interface and setup the switchport to be statically trunking. Connect each of the 4 ADSL modems to the switch and place their ports each into a separate VLAN that correlates with the VLAN subinterfaces you created on the router.

You can run 4 dialer interfaces with PPPoE each tied to one of the 4 VLAN subinterfaces and configure 4 default routes, one pointing to each provider. You will need to make sure you only NAT behind 1 provider's address space so you don't break your IP connectivity.

There are a lot more complex things you can do with NAT route-maps etc. but for your purposes you can get what you want working. I would recommend a Cisco 2621 with 2 FastEthernet interfaces so that you can support trunking.

Here is a link to help you with the configs...
»www.cisco.com/univercd/cc/td/doc···#1079502
--
Ignorance is temporary...stupidity lasts forever!

michaelr7

join:2004-03-26
Tucson, AZ
reply to nsumner
Take a look at OER for load balancing. It supports several different types of load distribution and works really well for me.

»www.cisco.com/go/oer


rolande
Certifiable
Premium,Mod
join:2002-05-24
Dallas, TX
kudos:6
Reviews:
·AT&T U-Verse
·ViaTalk
That is all well and good if you are running a routing protocol like BGP and taking a full view of the Internet routing table. It is highly unlikely that will be the case given 4 consumer grade ADSL connections. not to mention, that will only provide prefix distribution based on policy and performance across multiple paths. It won't help much for actual per packet load sharing to get the most out of the bandwidth.
--
Ignorance is temporary...stupidity lasts forever!

michaelr7

join:2004-03-26
Tucson, AZ

2 edits
quote:
That is all well and good if you are running a routing protocol like BGP and taking a full view of the Internet routing table.
Not true. All OER needs is a static default route and more than 1 internet connection. That is all we have on the 1841 at one site. In fact there is only one router at that site. 2 ISPs connected to the built-in FastEthernet ports and a number of clients connected to a HWIC-4SW.

quote:
It won't help much for actual per packet load sharing to get the most out of the bandwidth.
It works for us on a per packet basis. We have it setup to keep the utilization on each link within 10% of each other and it does. The mrtg graphs show the utilization is actually as we configured it to be.

When one of the ISPs flaked out earlier this week (link was fine to the ISP's network but 90% packet loss to the internet) all traffic was switched to the remaining link. The users didn't notice anything more than a little slowdown in web pages loading. No lost connections. The VPN traffic also switched from the down link to the working link without any problems. (We have a VPN tunnel per ISP.) When the flakey ISP came back online reliably the traffic went back to keeping the utilization equal.

Perhaps a bit of reading is in order before you make blanket statements. There is a good white paper on the Cisco site describing how OER helps in the SoHo/small branch office situation.

(Edit to correct a spelling mistake.)


rolande
Certifiable
Premium,Mod
join:2002-05-24
Dallas, TX
kudos:6
Reviews:
·AT&T U-Verse
·ViaTalk
That is very interesting. Everything I have ever read on OER covers only prefix management within a dynamic routing protocol. I had no idea you could manage individual traffic flows with only efault routes. Can you post your sample configuration? Thanks.
--
Ignorance is temporary...stupidity lasts forever!

michaelr7

join:2004-03-26
Tucson, AZ
quote:
Can you post your sample configuration?
I've been busy with a special customer and haven't been back here since my last post. In fact I'm just passing through now. Things look like they have settled down so I'll have a chance to post my config tomorrow.

I've been testing a couple of different configs - I"ll try to post them both with a bit of explanation.

michaelr7

join:2004-03-26
Tucson, AZ
reply to nsumner
Background:

1841 router with 1 HWIC-4SW (4 port FastEthernet switch) for a total of 6 interfaces.

FastEthernet0/0 connects to ISP 1 using a static address.
FastEthernet0/1 connects to ISP 2 obtaining an address via dhcp

A loopback interface, address 2.2.2.2 is used for communication between the master controller and border process.

Clients are in vlan10 or vlan20 and use dhcp to obtain an address.

The following are not included in the configuration below -

1. There are 4 always up multipoint gre tunnels protected with IPSec using two tunnel interfaces. (One tunnel interface per ISP.)

2. EIGRP is used to pass routes over the tunnels.

3. DMVPN is used.

All addresses shown are fake.

This configuration balances the load across the two ISPs trying to keep
utilization of each external link within 10%. I'll add an alternative
configuration later this weekend which using ISP 1 until it is 70% busy and
then starts using ISP 2. Of course if either ISP fails all traffic is
switched to the other ISP.

Note that OER uses passive information and active probes so it detects problems "black holes, "brown outs" and other bad things happening to traffic on an exit link.

The documentation at www.cisco.com/go/oer describes the commands and gives
background information on OER.

OER configuration -
oer master
policy-rules fixed-static
port 4444
max-range-utilization percent 10
keepalive 1
!
border 2.2.2.2 key-chain key1
interface Vlan20 internal
interface Vlan10 internal
interface FastEthernet0/1 external
interface FastEthernet0/0 external
!
learn
throughput
delay
periodic-interval 1
monitor-period 2
prefixes 200
aggregation-type prefix-length 32
max prefix total 2500
backoff 180 360
mode route control
mode select-exit best
periodic 180
resolve range priority 5
resolve loss priority 7 variance 1
resolve delay priority 8 variance 1
no resolve utilization
!
oer border
local Loopback1
port 4444
active-probe address source interface Vlan10
master 2.2.2.2 key-chain key1
!
interface Loopback1
ip address 2.2.2.2 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 !ISP 1's gateway here
! ISP 2 requires I access their web site and email/news servers from
!their network.
ip route 1.1.1.1 255.255.255.255 FastEthernet0/1 dhcp
ip route 2.1.1.1 255.255.255.255 FastEthernet0/1 dhcp
ip route 3.1.1.1 255.255.255.255 FastEthernet0/1 dhcp
ip route 4.1.1.1 255.255.255.255 FastEthernet0/1 dhcp
!
! These are 4 static routes for the IPSec encapsulated packets via the gre
! tunnels (2 per ISP).
ip route 10.10.10.65 255.255.255.255 !ISP 1's gateway here
ip route 10.10.10.66 255.255.255.255 !ISP 1's gateway here
ip route 10.10.10.67 255.255.255.255 FastEthernet0/1 dhcp
ip route 10.10.10.68 255.255.255.255 FastEthernet0/1 dhcp
!
! ISP 2 requires I access their web site and email/news servers from
!their network. Force OER to never change these routes.
ip prefix-list fixed-static seq 5 deny 1.1.1.1./32
ip prefix-list fixed-static seq 10 deny 2.1.1.1/32
ip prefix-list fixed-static seq 11 deny 3.1.1.1/32
ip prefix-list fixed-static seq 12 deny 4.1.1.1/32
! Force OER to not change the routes for the IPSec encapsulated packets
ip prefix-list fixed-static seq 20 deny 10.10.10.64/28
!
oer-map fixed-static 10
match ip address prefix-list fixed-static
!