dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
2775
share rss forum feed

tpanc13
The Edge Of Beyond

join:2002-12-29
Amarillo, TX

Speedstream 5100 Internet Light Off

About 3 weeks ago I installed Yahoo DSL ISP with Speedstreem 5100 modem. All went well.

About 2 weeks ago I installed Home Network for the first time using a LINKSYS BEFW11S4. It took a while, but all worked and the host and client PCs could both get to Internet. At this time the 5100 modem Lights that were solid green included Ethernet, DSL, AND Internet.

However, I have been having Internet Disconnect problems randomly, such as next day it wouldn't work, or sometimes during a session it would slow done and stop. After several searches through LINKSYS Forum, I implemented a fix that enabled PPPoE on the router. No problems in last 2 days so far.

BUT, I am using the Internet and the Speedstream Internet light is OFF. Yet, both host and client have access w/o problems. Today I thought I'd once again check Yahoo SBC account and tried to get to 192.168.0.1. It FAILED. Can also not PINH it. Yet, Internet works and Light is off.

Do I have a real problem or not?



Heterman
Premium
join:2004-02-28
Fayetteville, AR

4 edits

Click for full size
Linksys WRT54g Static Setup
said by tpanc13:

Do I have a real problem or not?
Depends. If you want to access the modem's internal pages, you will have to set up your router to a static address and let the modem handle the PPPoE. Then you can access the modem at »192.168.0.1 and the router at »192.168.1.1

There is nothing wrong with your connection the way it is, you just aren't able to access the modem's internal pages. I used mine like that for over a year until I dove into trying the other method. Either way works, some just prefer to be able to access their modem.

I am trying to find the instructions now, they are on the site somewhere. I'll get back if someone doesn't beat me to it.

Edit: The internet light on the modem will not illuminate if the router is holding the PPPoE.

Edit 2: Here is the site for instructions »SBC DSL FAQ »How to setup the 5100b or 4100 with a router/hub

Here is how I did it: (follow picture above)

You will have to punch the reset button on the modem to get it out of bridged mode, then connect directly to the computer (no router) and browse to »192.168.0.1 and enter your username and password then look for the DNS servers as they will be different than mine. That should be all you need to change on the router page and then reconnect modem back to router and reboot everything and you should be good to go. Works like a charm for me.

tpanc13
The Edge Of Beyond

join:2002-12-29
Amarillo, TX

Thank You Heterman. I originally had it set up with the default addresses as you indicated, except I didn't create a STATIC IP. I was using DHCP. However, I have been experiencing many disconnect problems. That's why I am trying the PPPoE via router suggestions discussed elsewhere. Now that I know what to expect (i.e., Internet Light off and no access to 192.168.0.1), I think I'll run this way for awhile to see if the disconnects cease. Then I'll go back and try the Static IP and allow the just the modem to handle the PPPoE as suggested. I appreciate your help-- the Links were helpful too.

Can you tell me why I can't PING 192.168.0.1? I assume it has to do with that address only being available within the LAN and the modem is no longer considered part of it. Correct? I don't remember setting up a Bridge though. I assume switching to PPPoE transparently creates the bridge.
--
SBC Yahoo! DSL, Speedstream 5100 Modem, LINKSYS BEFW11S4 Router(firmware 1.52.02)



NormanS
I gave her time to steal my mind away
Premium,MVM
join:2001-02-14
San Jose, CA
kudos:11
Reviews:
·SONIC.NET
·Pacific Bell - SBC

1 edit
reply to tpanc13

said by tpanc13:

About 3 weeks ago I installed Yahoo DSL ISP with Speedstreem 5100 modem. All went well.

About 2 weeks ago I installed Home Network for the first time using a LINKSYS BEFW11S4. It took a while, but all worked and the host and client PCs could both get to Internet. At this time the 5100 modem Lights that were solid green included Ethernet, DSL, AND Internet.

However, I have been having Internet Disconnect problems randomly, such as next day it wouldn't work, or sometimes during a session it would slow done and stop. After several searches through LINKSYS Forum, I implemented a fix that enabled PPPoE on the router. No problems in last 2 days so far.

BUT, I am using the Internet and the Speedstream Internet light is OFF. Yet, both host and client have access w/o problems. Today I thought I'd once again check Yahoo SBC account and tried to get to 192.168.0.1. It FAILED. Can also not PINH it. Yet, Internet works and Light is off.

Do I have a real problem or not?
When the router is initiating the PPPoE session, the packets are encapsulated for transport on the router; they will never reach the modem Ethernet port because they are no longer recognized as TCP packets. Also, you wont get a green Internet light on the modem because the modem is not running the PPPoE session.

I have an SS4100, which is supposedly equivalent in function to the SS5100B. I have tested my modem three ways; all three work.

I tried "PPP is on the modem, use private IP address." I then set the router (Netgear FR114P) to use a static IP address on the WAN port. I set up the router ports as:
IP address  - 192.168.1.1
Subnet mask - 255.255.0.0
DNS server - 192.168.0.1

The LAN port is:
IP address - 192.168.102.1
Subnet mask - 255.255.255.0
Gateway - 192.168.0.1
DNS Server - 192.168.0.1
In this mode I could reach the modem by entering 192.168.0.1. However, all ports were "stealth" (with the computer requesting the probe in the DMZ; which should have shown the ports not blocked by SBC as "closed"), and the modem has no provision to forward specific ports for specific services. I would recommend this setting for Windows computers which are directly connected to the modem. I would not recommend this setting for routers connected to the modem.

Next I tried "PPP is on the modem, use private IP address". I then set the router WAN port to "obtain IP address from ISP". The router status page would then display:
IP address  - 192.168.1.64
Subnet mask - 255.255.0.0
DNS server - 192.168.0.1

The LAN port is:
IP address - 192.168.102.1
Subnet mask - 255.255.255.0
Gateway - 192.168.0.1
DNS Server - 192.168.01
In this mode I could reach the modem by entering 192.168.0.1. With the computer requesting a port probe in the DMZ, those ports not blocked by SBC show up as "closed". This mode should be fine for a router connection; indeed, if you have any thought to use port forwarding, this mode is necessary. I don't recommend this mode for connecting a Windows computer because it does not have the benefit of NAT blocking of unsolicited packets; it is the DMZ for the router hidden within the modem.

Last I set up the modem for "PPP is on the modem, use public IP address." I then set the router WAN port to "obtain IP address from ISP". The router status page would then display:
IP address  - nnn.nnn.x.xx
Subnet mask - 255.255.0.0
DNS server - 192.168.0.1

The LAN port is:
IP address - 192.168.102.1
Subnet mask - 255.255.255.0
Gateway - 192.168.0.1
DNS Server - 192.168.01
This is the method that I am using; it is the factory default setting for the modem. As with "PPP is on the modem, use private IP address", with the modem's DHCP assigned private IP address, this should be fine for a router. Again, with the computer requesting a port probe in the DMZ, those ports not blocked by SBC show up as "closed"; so I don't recommend this mode for connecting a Windows computer because it does not have the benefit of NAT blocking of unsolicited packets.

The distinction of the subnet mask is important; the subnet mask on the LAN side must be larger (more contiguous MSB (Most Significant Bits) set), or the router will think that the IP address is on the local segment, and it will not pass packets to the WAN.

Other important points:

The modem should be set to either "Smart keep alive" (for a router connection), or "Always attempt to connect" (for either a router, or a directly connected Windows computer).

If you have an Ethernet adapter which responds to power management by shutting down, disable this feature.

If the router has a setting for always staying connected, use it. This can be an explicit "stay alive" setting, or it may be a specified period of time, with some specific period designated for the function.

For the LAN IP address, I did use 192.168.102.1 for the router, with subnet mask 255.255.255.0. I have an unrelated reason for this; any decimal value from '1' to '255' should work in place of '102'.

I have tested the three configurations, and all allow Internet access to the computers behind the router, and also allow connection to the modem at 192.168.0.1 through the router.

--
Norman
~Oh Lord, why have you come
~To Konnyu, with the Lion and the Drum


wayjac
Premium,MVM
join:2001-12-22
Indy
kudos:1

When are going to test to see if you can use the DHCP public IP address and simultaneously use a assigned private IP address?
--
God bless our troops



NormanS
I gave her time to steal my mind away
Premium,MVM
join:2001-02-14
San Jose, CA
kudos:11
Reviews:
·SONIC.NET
·Pacific Bell - SBC

said by wayjac:

When are going to test to see if you can use the DHCP public IP address and simultaneously use a assigned private IP address?
I am not sure which way I am expected to do that; a second Ethernet adapter in the computer, with one connected to the router using the public IP address, and the other to the modem network?
SS4100 to hub uplink port:  192.168.0.1/255.255.0.0
Hub port 1 to Netgear WAN port.
Hub port 2 to to Kingston Fast Ethernet port in computer Megumi:
192.168.1.100/255.255.254.0
Netgear LAN port 1 to HP Fast Ethernet port in computer Megumi:
192.168.102.100/255.255.255.0
Netgear LAN port 2 to HP Fast Ethernet port in computer Naomi:
192.168.102.101/255.255.255.0
Netgear LAN port 3 to Sony Playstation 2 Mayuko:
192.168.102.12/255.255.255.0
Something like that? Public IP address will be assigned to the router? Computer "Megumi" port on Kingston Fast Ethernet adapter 192.168.1.100/255.255.254.0 used to communicate with the modem? Or is it to test with the SS4100 in "PPP is on the computer" mode, with the connections above?
I think I would have to use:

C:\> route add 192.168.1.0 mask 255.255.255.0 192.168.1.100

...as well.

Assuming that you were directing the question to me...

--
Norman
~Oh Lord, why have you come
~To Konnyu, with the Lion and the Drum


wayjac
Premium,MVM
join:2001-12-22
Indy
kudos:1

Thanks for the reply, my question was directed to NormanS See Profile
I hit the wrong reply button

With a 5100b I stumbled upon this and I would like to know if the 4100 behaves the same way.

A router is not used in this network only a 10/100 switch.
The modem was set for:
PPP is on the modem
Yes, use Public IP address

The 3 resident computers all have assigned private IP's.
No static routes
Subnet mask 255.255.0.0 for all computers

I added a computer to the network it was set for DHCP. The added computer got the public IP address.
All computers worked well with this setup. I didn't intend to do this but after realizing it I was surprised that it worked.
--
God bless our troops



NormanS
I gave her time to steal my mind away
Premium,MVM
join:2001-02-14
San Jose, CA
kudos:11
Reviews:
·SONIC.NET
·Pacific Bell - SBC

Both the SS5100B and the SS4100 have the same functions, or so I have seen reported. If all computers on that switch are set to use the modem as the gateway, then the modem is acting as an ad hoc router. It seems as though the basic routing function of the device has not been disabled, only its DHCP assignment; i.e., it can only hand out a single IP address: 192.168.1.64. Do keep in mind that the 192.168.1.64 IP address will be sent all unsolicited packets directed to your public IP address; you must have a firewall configured on that computer. If you manually set that computer to an IP address other than 192.168.1.64, it will be protected by the fact that the modem will not forward unsolicited packets to any other possible IP address. You can test this at »www.grc.com. Your firewall on any computer other than the one at 192.168.1.64 should not log probes from the GRC server; but the firewall on the computer at 192.168.1.64 should log probes from the GRC server.

It works because the subnet mask is so broad; there is no IP address within 192.168.0.0/16 that you can't use; except 192.168.0.0 and 192.168.255.255. If none of the three computers with manually assigned IP addresses used 192.168.1.64, then the modem's DHCP server would hand that out to a computer which is configured for DHCP; but only one computer can be configured for DHCP on such an ad hoc LAN.

Personally, I would change the subnet mask on the computers to 255.255.254.0. That would limit the accessible IP address range for the devices to 192.168.0.0 - 192.168.1.255. It is fine the way you have it set up; but I just like the idea of a smaller range.

As it is currently configured, with subnet mask 255.255.0.0, one of your three computers could be assigned 192.168.0.2, another 192.168.255.254, and the remaining two any IP address in between those two. By changing the subnet mask to 255.255.254.0, you change the last usable IP address from 192.168.255.254 to 192.168.1.254.

As for accessing the modem pages; with your configuration, or even my suggested change, you should be able to connect to the modem pages from any computer on your LAN.
--
Norman
~Oh Lord, why have you come
~To Konnyu, with the Lion and the Drum



jake22351

@birch.net
reply to tpanc13

As I understand it the internet light will be off when using a router. I have had the same problems with disconnect for the past week or so. At one point, someone at SBC deleted my account and it had to be rebuilt. Am not happy with the service and will probably soon go with cable.



Heterman
Premium
join:2004-02-28
Fayetteville, AR

said by jake22351 :

As I understand it the internet light will be off when using a router. I have had the same problems with disconnect for the past week or so. At one point, someone at SBC deleted my account and it had to be rebuilt. Am not happy with the service and will probably soon go with cable.
If you don't set up the router correctly it will disconnect at random times. That is why you must set the modem to bridge and let the router handle the PPPoE. You can also do it the other way, but it is a little less straightforeward.

If you have trouble with your SBC DSL, DO NOT call them. They will bump your speed down until you can hold sync. That isn't the problem in the first place if you haven't set up the router correctly. If you take the time and register on this site, we have an EXCELLENT SBC Direct forum where SBC techs can look at line stats and such if your MODEM is loosing sync. For router set-up problems though, try to keep that out here in this forum.

I hope I didn't go on and on just so you can say SBC sucks and go to cable. If you do, good luck with cable, they are always fun to deal with.


wayjac
Premium,MVM
join:2001-12-22
Indy
kudos:1
reply to NormanS

I guess I'll have wait until I have access to a 4100 to answer my question.
--
God bless our troops



NormanS
I gave her time to steal my mind away
Premium,MVM
join:2001-02-14
San Jose, CA
kudos:11
Reviews:
·SONIC.NET
·Pacific Bell - SBC
reply to jake22351

said by jake22351 :

As I understand it the internet light will be off when using a router. I have had the same problems with disconnect for the past week or so. At one point, someone at SBC deleted my account and it had to be rebuilt. Am not happy with the service and will probably soon go with cable.
Tell that to my SS4100. I tried three ways:

PPP is on the modem, use private IP address, with the router configured manually to use 192.168.1.1

PPP is on the modem, use private IP address, with the router configured to obtain the IP address automatically.

PPP is on the modem, use public IP address.

As long as the PPPoE session is on the modem, the Internet light will be lit; even when there is a router connected to the computer.

If the configuration is:

PPP is on the computer; well, then the router will handle the PPPoE session, and the Internet light will not be lit. I have not used that configuration, though.
--
Norman
~Oh Lord, why have you come
~To Konnyu, with the Lion and the Drum


NormanS
I gave her time to steal my mind away
Premium,MVM
join:2001-02-14
San Jose, CA
kudos:11
Reviews:
·SONIC.NET
·Pacific Bell - SBC
reply to wayjac

said by wayjac:

I guess I'll have wait until I have access to a 4100 to answer my question.
It is my understanding that the SS5100B is functionally identical to the SS4100. If you have an SS5100B, you should be able to do anything that you could do with an SS4100.

Are you asking about connecting two, or more, computers through a switch, and using the public IP address on one of the computers, and a private address on any other computer connected through the switch?
--
Norman
~Oh Lord, why have you come
~To Konnyu, with the Lion and the Drum

kasey01

join:2003-06-26
Houston, TX
reply to tpanc13

I've had the exact same problems ever since SBC installed a new modem. My internet connection randomly disconnects causing me to have to reset my modem. I've put a different NIC in the computer and it still happens. It also happens when I use my laptop wirelessly. When it disconnects I can still access my router info page, and on the router info page, it shows "connecting" under connection status. I have a Speedstream 5100b modem and a Microsoft MN-500 router. I chose the setting in the modem configuration that says "allow router to handle PPPoE" or something to that effect. Someone in the forums suggested I change the modem setting to bridge mode. I have it in bridge mode now and it still disconnects randomly though less frequently. Do I have a faulty modem?



McSummation
Mmmm, Zeebas Are Tastee.
Premium,MVM
join:2003-08-13
Fort Worth, TX
kudos:2

Run this test - »/linequality - and then post the URL that is in the red box of the resultant page.


kasey01

join:2003-06-26
Houston, TX

»/quality/nil/1867879



McSummation
Mmmm, Zeebas Are Tastee.
Premium,MVM
join:2003-08-13
Fort Worth, TX
kudos:2

That looks solid.

If you run "PPPoE on the modem" you can look at the line error rates.


tpanc13
The Edge Of Beyond

join:2002-12-29
Amarillo, TX
reply to tpanc13

I have been testing my configuration ever since the original reply from Heterman. Although neither my host nor my client machine had a problem with Internet with the router handling the PPPoE , the LAN communnication for sharing files was not functional -- have a W98 client (maybe the problem). So, I went with the STATIC IP and letting DSL modem handle the PPPoE. Have not had any problems since. Thank you for the guidance.
--
SBC Yahoo! DSL, Speedstream 5100 Modem, LINKSYS BEFW11S4 Router(firmware 1.52.02)