dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
1760
share rss forum feed


teefer

@mtsallstream.net

Upgraded to MTS Ultimate TV, now my internet sucks

Hi,

Hoping someone might be able to point me to the answer, or point me to how I can get MTS to fix the issue.

1 week ago, MTS was here upgrading my 2 TV's from Classic TV to Ultimate TV. While doing this, they also installed a new RG for my internet (required for ultimate TV). Upon a quick test after he had installed everything and was done, everything appeared ok.

However, when I went to watch a TV episode from watch.ctv.ca, it buffered about every 30 seconds to 2 minutes. I then tried globaltv.com and it was buffering lots too (but not quite as bad as ctv). I tried cbc.ca/video and it did the same thing. I tried youtube and youtube played fine.

So I called MTS a couple days later and explained the problem. The first level tech apparently did made some "encryption upgrade" and reset my box, but that didn't fix anything and he sent me to 2nd level support. That guy then proceeded to tell me that the problem was out on the internet because it was doing the same thing to him on both his MTS computer and another computer that's not on MTS internet. I didn't believe him, but wasn't getting anywhere so I said I would try again tomorrow and call back if the problem persists..

I called back again today and got sent to second level again who did a line test and said everything is fine on my internet connection and the problem is out of their control.

Here is what i'm seeing. While watching a video clip from watch.tsn.ca, here is what it looks like while playing from my browser:




Here is the same clip, downloaded with rtmpdump:



Here is a download of a 1.5gig torrent:



Here is a youtube clip playing:



So, for some reason when I try to watch an RTMP video it goes along fine, and then slows down until the buffer runs out, then the speed spikes and it plays again for a while (30 seconds to a couple minutes). When downloading the same video using rtmpdump, it downloads at almost 10 Mbps and then all of a sudden drops to less than 1 Mbps, then picks back up to 10 again.

When I download a torrent, it downloads above 10Mbit for the entire download.

The Youtube graph looks very similar to the TSN clip, but youtube does play just fine for some reason.

I didn't have this problem until I was upgraded to ultimate tv. My household regularly watches globaltv.com, watch.ctv.ca, and cbc.ca/video (daily for almost a year). We watch way more TV by streaming it over the internet then we watch it live, so I know we didn't have this problem until we upgraded to ultimate TV.

I tried hooking up just 1 PC by ethernet, and disabling wireless and I still have the above problem. I've unplugged the box for an hour, and even tried different cables. I'm at a loss as to what to try next.

Any idea what the heck the problem might be? What should I ask mts to check or do?

prairiesky

join:2008-12-08
canada
kudos:2

just trying it now on my connection at home (lightning and ultimate tv), commercials loaded quick

For youtube it makes sense for it to drop out, youtube has started to limit buffer times to X seconds ahead (i don't know how long, i just know it stops).

As for CBC, played fine, global played fine.

If you're getting 10 mbps through your modem, it doesn't seem like it's mts' problem



teefer

@mtsallstream.net

Thanks for the reply and the test. I was thinking about this last night and I decided to download a large file from microsoft.com. I found the same thing happening. It downloads fast for about 40 seconds and then basically stalls, then speeds up for another 40 seconds, then stalls. Here is what the graph of a download from microsoft.com looks like:




I agree, it doesn't sound like MTS's problem, but I have this same problem on 1 hardwired PC, 2 wireless laptops, and 1 apple tv 2. I even turned off everything but the 1 hardwired PC and I still get the same result.

I think if the speedtest.net could do a longer test (like 2 minutes), then I'd see the problem there too. Does anyone know a speedtest site that will do a longer test?

prairiesky

join:2008-12-08
canada
kudos:2
reply to teefer

what happens if you bypass your router and plug directly in?



teefer

@mtsallstream.net

Unfortunately, it's the same thing if I connect just 1 PC via ethernet directly to the MTS box. As a test, I did exactly this:

Unplugged and powered off the asus router. Plugged 1 PC into the mts box. Went into the mts box and turned off the wireless signal. Rebooted the MTS box.

When it was finished rebooting, I rebooted the PC, and tried to download a 300 meg file from microsoft. It goes nice and fast until it his about 70.1 megs, then stayed on 70.1 megs downloaded for about 10 seconds, then sped back up to a good speed until it hit about 107 megs, then it stayed on 107 megs downloaded for about 10 seconds, then sped back up to normal.



tcona

@mtsallstream.net

Yeah thats normal on mts sorry to say it. Went through the same bs over a year ago with them couldn't stream hd netfix cause the speed fluxes every 30-45 seconds just as your graph shows. Same exact graph output i see when i download on mts daily. After 5 service calls and them not even being able to keep 7 mbit going off there ftp at peak traffic times ie: 4:30-11 pm when every1 is online and has tvs on using there bw they upped me to 30mbit. As I was able to prove to them that at peak times speeds were shit just make them have a tech come out after dinner and don't put up with shit. Took me 5 service calls until i got 30mbit config set for same 7mbit price cause they couldn't even deliver 5 mbits during peak times not enough to stream hd netflix. They relocated the 2 wire box to right beside my panel where the service comes in to "fix" it lol. Same problem existed until a senior tech was sent on the 5th service call and got my config bumped to 30mbits. The speed fluxes at 30mbit still happen but doesn't drop to the 200kb range cause it has alot farther to fall during the flux period so lowest ive seen i got back down to maxed during is like 5-10 mbit. So bitch bitch bitch until they fix it or drop them its mts they suck balls compared to shaws network. Only reason were still on mts is cause i like 30mbits for 7mbit price and the bundle discount lost if drop inet isn't worth it to go to shaw. More thinking on the matter and hows its a constant flux makes me wonder if its mts's qos settings kicking in to prioritize tv traffic. Area is also Transcona if that has something to do with it i dunno? Also do tests off ftp.mts.net I bet there just as bad as on the net use this as your main bitching point. I just did a speed test off there ftp and see the exact same dips every 30 seconds down to 2.7 mbits then right back up to 18mbit because all 3 tv streams are on so that takes away from the total 30. test2.mts nice 247 meg test file to use. I hope you get a free upgrade too.