dslreports logo
site
    All Forums Hot Topics Gallery
spc
Search Topic:
uniqs
7
share rss forum feed

guppy_fish
Premium
join:2003-12-09
Lakeland, FL
kudos:1
Reviews:
·Verizon FiOS
reply to jandir

Re: Slow speeds when logged in over remote desktop from outside

said by jandir:

I understand that the RDP connection is going to take some of the bandwidth from my FIOS connection but was not expecting it to reduce from 43 mbps to 10 mbps.

I do not experience this slowdown when I use RDP to log into that PC from another PC at home.

Your local LAN is likely 1,000mbs ( gigabit ) so no surprise it have little to no effect on your WAN which is 43mbs

RDP is highly dependent on a number of factors, such as back ground image ( plain color is best ) , color depth and what the applications are doing for screen updates

You can easily see what the bandwidth RDP is using by starting task manager once your logged into the remote computer and selecting the networking tab

FYI, video rates uncompressed for a typical HDTV resolution

24bit @ 1080i @ 30fps :24*1920*1080*30=1.39Gbps.

So even smaller desktop sizes and compression the RDP uses can easily use every single bit of WAN available ...

jandir

join:2002-05-27
Oakton, VA

Click for full size
Network Usage Stats
So this is interesting. When I look at the bandwidth (I am logged in via RDP from work), as you had suggested, it shows me the interface speed of 10 Mbps and a utilization of 99% (I do have a gigabit network and interface at home) .

Not sure if this is the issue, but why would it show me a 10 Mbps interface? I am assuming this is something to do with RDP. It there a way to configure this correctly?

Mahalo

join:2000-12-20
united state
kudos:1

jandir,
Please try this in a cmd prompt:

netsh interface tcp set global autotuninglevel=disabled

Or just Google the issue and find people with the same issue, or the link I provided above.


jandir

join:2002-05-27
Oakton, VA

1 edit

Thank you KillABrew.

Yes, this seemed to have fixed the issue. Had to reboot after the command though. I see the adapter at 1Gbps now and much higher speeds in speed tests.

Let me test for a couple of days before I declare victory (just worried that rebooting directly into RDP might have changed the scenario a bit).

Thank you

Brahmdeep