dslreports logo
site
 
    All Forums Hot Topics Gallery
spc

spacer




how-to block ads


Search Topic:
uniqs
1195
share rss forum feed


LondonDave
Premium
join:2011-09-05
London, ON
Reviews:
·Bell Fibe

Cisco 1812 Config

I picked up a cisco 1812 to use with my cable internet connection but for the life of me can't get it to pass traffic. I have the most basic nat config setup however it will not let me on the internet. I get a public IP from my ISP which is through a bridge cisco 3825. The wierd thing is I can connect to the webpage on the 3825 which is on the outside side of nat. I've posted the config below.

Router#sh run
Building configuration...

Current configuration : 1147 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
!
interface FastEthernet5
!
interface FastEthernet6
!
interface FastEthernet7
!
interface FastEthernet8
!
interface FastEthernet9
!
interface Vlan1
ip address 192.168.102.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip route 0.0.0.0 0.0.0.0 FastEthernet1
!
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface FastEthernet1 overload
!
access-list 1 permit 192.168.102.0 0.0.0.255
!
!
!
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
!
!
webvpn context Default_context
ssl authenticate verify all
!
no inservice
!
end

Any ideas?

If I stick a PIX, ASA or old 831 on it works fine. I'm stumped.

cramer
Premium
join:2007-04-10
Raleigh, NC
kudos:9
Remove "ip route 0.0.0.0 0.0.0.0 FastEthernet1" That's PROXY ARP.

(dhcp should be setting the default gateway)


NetworkGuy

@rr.com
reply to LondonDave
After you do what cramer says above, add "ip route 0.0.0.0 0.0.0.0 dhcp" to your config. After this you'll never have to worry about updating this route whenever default gateway or subnet changes (which shouldn't be often). This will tell the router to use whatever default gateway is handed out via DHCP. Hope this helps you out!

cramer
Premium
join:2007-04-10
Raleigh, NC
kudos:9

1 edit
DHCP sets the route automatically. No "ip route" command is required. (on a Pix/ASA, you have to tell it to with "setroute", but this is IOS)

[See Also: »blog.ioshints.info/2007/06/dhcp-···ute.html ]


NetworkGuy

@rr.com
I did know about the router obtaining the default gateway from DHCP. What I didn't know is that this information could be used without specifying a route. Cool! I checked your link but it seems to to a non existent page. Was this the one?: »blog.ioshints.info/2007/06/dhcp-···ute.html


LondonDave
Premium
join:2011-09-05
London, ON
Reviews:
·Bell Fibe
reply to LondonDave
Thanks guys, I can't believe it was my default static route. Sometimes its good to have another set of eyes. I'm used to ASA's and PIX's where if you use DHCP you add setroute. Works like a charm.

I'm going to throw my other ftth connection on that and do some policy routing so lets see what happens.

Thanks Again.

cramer
Premium
join:2007-04-10
Raleigh, NC
kudos:9
reply to NetworkGuy
That's exactly what I post, minus the site adding the ']' to it.


NetworkGuy

@rr.com
Yeah I see that, not sure why I couldn't get it to work before. It seems to be working now though.